]> git.pld-linux.org Git - packages/exim.git/commitdiff
rel 2; upstream fixes
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 13 Jul 2022 09:18:06 +0000 (11:18 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 13 Jul 2022 09:18:06 +0000 (11:18 +0200)
branch.sh
exim-git-manual.patch [new file with mode: 0644]
exim.spec

index f8a676f3270c38a2e2ea263e5fb73658da60b497..117650d231da412b9bee406ef2e637120e690a6e 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -7,6 +7,9 @@ branch=exim-4.95+fixes
 out=$package-git.patch
 repo=$package.git
 
+echo "No usable branch on upstream git repository... exiting" >&2
+exit 1
+
 # use filterdiff, etc to exclude bad chunks from diff
 filter() {
        cat
diff --git a/exim-git-manual.patch b/exim-git-manual.patch
new file mode 100644 (file)
index 0000000..a52bada
--- /dev/null
@@ -0,0 +1,30 @@
+From e7ec503729970a03d4509921342bc81313976126 Mon Sep 17 00:00:00 2001
+From: Jeremy Harris <jgh146exb@wizmail.org>
+Date: Tue, 12 Jul 2022 22:14:04 +0100
+Subject: [PATCH] Fix exit on attempt to rewrite a malformed address.  Bug 2903
+
+diff --git a/src/src/rewrite.c b/src/src/rewrite.c
+index bfd78b5..90614e6 100644
+--- a/src/src/rewrite.c
++++ b/src/src/rewrite.c
+@@ -497,15 +497,14 @@ while (*s)
+   if (!recipient)
+     {
+-    /* Handle unparesable addresses in the header. Slightly ugly because a
++    /* Log unparesable addresses in the header. Slightly ugly because a
+     null output from the extract can also result from a header without an
+-    address, "To: undisclosed recpients:;" being the classic case. */
++    address, "To: undisclosed recpients:;" being the classic case. Ignore
++    this one and carry on. */
+     if ((rewrite_rules || routed_old) && Ustrcmp(errmess, "empty address") != 0)
+-      {
+       log_write(0, LOG_MAIN, "rewrite: %s", errmess);
+-      exim_exit(EXIT_FAILURE);
+-      }
++
+     loop_reset_point = store_reset(loop_reset_point);
+     continue;
+     }
+
index e0c11ba5d79154da15cc8fdfe06bbf5faff3e6c6..da8ffa3775635a40669ee047a6c95962250eb893 100644 (file)
--- a/exim.spec
+++ b/exim.spec
@@ -23,7 +23,7 @@ Summary(pl.UTF-8):    Agent Transferu Poczty Uniwersytetu w Cambridge
 Summary(pt_BR.UTF-8):  Servidor de correio eletrônico exim
 Name:          exim
 Version:       4.96
-Release:       1
+Release:       2
 Epoch:         2
 License:       GPL v2+
 Group:         Networking/Daemons/SMTP
@@ -48,7 +48,9 @@ Source14:     ftp://ftp.exim.org/pub/exim/exim4/old/config.samples.tar.bz2
 Source15:      %{name}4-smtp.pamd
 Source16:      %{name}on.png
 # sh branch.sh
-Patch100:      %{name}-git.patch
+# Patch100:    %{name}-git.patch
+# manually created patch with upstream fixes
+Patch100:       %{name}-git-manual.patch
 # Patch100-md5:        706af51f29db2a91422081491fb85d87
 Patch0:                %{name}4-EDITME.patch
 Patch1:                %{name}4-monitor-EDITME.patch
@@ -174,7 +176,7 @@ Pliki nagłówkowe dla Exima.
 
 %prep
 %setup -q -a1 -a7
-#%patch100 -p2
+%patch100 -p2
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
This page took 0.255374 seconds and 4 git commands to generate.