]> git.pld-linux.org Git - packages/exim.git/commitdiff
Rel 3; bring back all git fixes auto/th/exim-4.96-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 12 Sep 2022 09:10:18 +0000 (11:10 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 12 Sep 2022 09:10:18 +0000 (11:10 +0200)
branch.sh
exim.spec

index 117650d231da412b9bee406ef2e637120e690a6e..22e9d86bcb618e53bcbf97f5594b59bb47418773 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -2,17 +2,16 @@
 set -e
 url=git://git.exim.org/exim.git
 package=exim
 set -e
 url=git://git.exim.org/exim.git
 package=exim
-tag=exim-4.95
-branch=exim-4.95+fixes
+tag=exim-4.96
+branch=master
 out=$package-git.patch
 repo=$package.git
 
 out=$package-git.patch
 repo=$package.git
 
-echo "No usable branch on upstream git repository... exiting" >&2
-exit 1
-
 # use filterdiff, etc to exclude bad chunks from diff
 filter() {
 # use filterdiff, etc to exclude bad chunks from diff
 filter() {
-       cat
+    filterdiff \
+        -x '*/test/*' \
+        -x '*/doc/*'
 }
 
 if [ ! -d $repo ]; then
 }
 
 if [ ! -d $repo ]; then
@@ -21,7 +20,7 @@ fi
 
 cd $repo
        git fetch origin +$branch:$branch +refs/tags/$tag:refs/tags/$tag
 
 cd $repo
        git fetch origin +$branch:$branch +refs/tags/$tag:refs/tags/$tag
-       git log -p --reverse $tag..$branch ":(exclude)doc/doc-*" ":(exclude)test" ":(exclude).*" | filter > ../$out.tmp
+       git log -p --reverse --first-parent $tag..$branch ":(exclude)doc/doc-*" ":(exclude)test" ":(exclude).*" | filter > ../$out.tmp
 cd ..
 
 if cmp -s $out{,.tmp}; then
 cd ..
 
 if cmp -s $out{,.tmp}; then
index da8ffa3775635a40669ee047a6c95962250eb893..cb041156934fea3771ce4d6db9e86980d4852492 100644 (file)
--- a/exim.spec
+++ b/exim.spec
@@ -23,7 +23,7 @@ Summary(pl.UTF-8):    Agent Transferu Poczty Uniwersytetu w Cambridge
 Summary(pt_BR.UTF-8):  Servidor de correio eletrônico exim
 Name:          exim
 Version:       4.96
 Summary(pt_BR.UTF-8):  Servidor de correio eletrônico exim
 Name:          exim
 Version:       4.96
-Release:       2
+Release:       3
 Epoch:         2
 License:       GPL v2+
 Group:         Networking/Daemons/SMTP
 Epoch:         2
 License:       GPL v2+
 Group:         Networking/Daemons/SMTP
@@ -48,10 +48,8 @@ Source14:    ftp://ftp.exim.org/pub/exim/exim4/old/config.samples.tar.bz2
 Source15:      %{name}4-smtp.pamd
 Source16:      %{name}on.png
 # sh branch.sh
 Source15:      %{name}4-smtp.pamd
 Source16:      %{name}on.png
 # sh branch.sh
-# Patch100:    %{name}-git.patch
-# manually created patch with upstream fixes
-Patch100:       %{name}-git-manual.patch
-# Patch100-md5:        706af51f29db2a91422081491fb85d87
+Patch100:      %{name}-git.patch
+# Patch100-md5:        740ae0b0e536781a04fd566d8e523fe9
 Patch0:                %{name}4-EDITME.patch
 Patch1:                %{name}4-monitor-EDITME.patch
 Patch2:                %{name}4-cflags.patch
 Patch0:                %{name}4-EDITME.patch
 Patch1:                %{name}4-monitor-EDITME.patch
 Patch2:                %{name}4-cflags.patch
This page took 0.132201 seconds and 4 git commands to generate.