]> git.pld-linux.org Git - packages/exim.git/commitdiff
- rel 3; drop sigalarm workaround (didn't see it needed for very long time); update... auto/th/exim-4.91-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 23 Apr 2018 13:31:59 +0000 (15:31 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 23 Apr 2018 13:31:59 +0000 (15:31 +0200)
branch.sh
exim-force-sigalrm.patch [deleted file]
exim.spec
localscan_dlopen_exim_4.20_or_better.patch

index 9ccfc99924aa1cbb041011e28973d0506cb3d49f..b82d66e462e72c090bb73e9f20d390f9d1eed71c 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -3,7 +3,7 @@ set -e
 url=git://git.exim.org/exim.git
 package=exim
 tag=exim-4_91
-branch=exim-4_90+fixes
+branch=exim-4_91+fixes
 out=$package-git.patch
 repo=$package.git
 
diff --git a/exim-force-sigalrm.patch b/exim-force-sigalrm.patch
deleted file mode 100644 (file)
index f0ca2e6..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
---- exim-4.69.org/src/daemon.c 2009-06-01 23:02:02.505119117 +0200
-+++ exim-4.69/src/daemon.c     2009-06-01 23:09:58.088404461 +0200
-@@ -25,7 +25,7 @@
- static smtp_slot empty_smtp_slot = { 0, NULL };
--
-+static time_t sigalrm_seen_last;
- /*************************************************
- *               Local static variables           *
-@@ -1603,6 +1603,8 @@
- smtp_input = TRUE;
-+time(&sigalrm_seen_last);
-+
- /* Enter the never-ending loop... */
- for (;;)
-@@ -1753,6 +1753,8 @@
-       {
-       DEBUG(D_any) debug_printf("SIGALRM received\n");
-+      time(&sigalrm_seen_last);
-+
-       /* Do a full queue run in a child process, if required, unless we already
-       have enough queue runners on the go. If we are not running as root, a
-       re-exec is required. */
-@@ -1885,11 +1889,19 @@
-   else
-     {
-+    int time_diff;
-     struct timeval tv;
-     tv.tv_sec = queue_interval;
-     tv.tv_usec = 0;
-     select(0, NULL, NULL, NULL, &tv);
-     handle_ending_processes();
-+
-+    time_diff = (int)difftime(time(NULL), sigalrm_seen_last);
-+    if ((queue_interval > 0) && (time_diff > (2*queue_interval)))
-+      {
-+        sigalrm_seen = TRUE;
-+        log_write(0, LOG_MAIN|LOG_PANIC, "daemon: queue-runner not run for %ds. Forcing. Is SIGALRM delivery broken on this system ?", time_diff);
-+      }
-     }
-   /* Re-enable the SIGCHLD handler if it has been run. It can't do it
index 971d8271794e9c759ace529381f82502f6586608..db1af6a80cd87fa13b777cda3fe5fe35a90005a2 100644 (file)
--- a/exim.spec
+++ b/exim.spec
@@ -25,7 +25,7 @@ Summary(pl.UTF-8):    Agent Transferu Poczty Uniwersytetu w Cambridge
 Summary(pt_BR.UTF-8):  Servidor de correio eletrônico exim
 Name:          exim
 Version:       4.91
-Release:       2
+Release:       3
 Epoch:         2
 License:       GPL
 Group:         Networking/Daemons/SMTP
@@ -51,7 +51,7 @@ Source15:     %{name}4-smtp.pamd
 Source16:      %{name}on.png
 # sh branch.sh
 Patch100:      %{name}-git.patch
-# Patch100-md5:        abd612ef67d49fdfffe8c63da1ba39fb
+# Patch100-md5:        a3758d59413ab02d5025c63d84ed6189
 Patch0:                %{name}4-EDITME.patch
 Patch1:                %{name}4-monitor-EDITME.patch
 Patch2:                %{name}4-cflags.patch
@@ -62,8 +62,6 @@ Patch5:               localscan_dlopen_%{name}_4.20_or_better.patch
 
 Patch8:                %{name}-spam-timeout.patch
 
-Patch10:       %{name}-force-sigalrm.patch
-
 Patch20:       %{name}4-disableSSLv3.patch
 URL:           http://www.exim.org/
 %{?with_sasl:BuildRequires:    cyrus-sasl-devel >= 2.1.0}
@@ -178,7 +176,7 @@ Pliki nagłówkowe dla Exima.
 
 %prep
 %setup -q -a1 -a7
-#%patch100 -p2
+%patch100 -p2
 
 %patch0 -p1
 %patch1 -p1
@@ -189,8 +187,6 @@ Pliki nagłówkowe dla Exima.
 
 %patch8 -p1
 
-%patch10 -p1
-
 install %{SOURCE4} exim4.conf
 install %{SOURCE14} doc/config.samples.tar.bz2
 %patch20 -p1
index 03010eb6b34354b5269de680ab8f4f482a25eab5..1a941ed89fc6c2fd3274f47890168fda50564b45 100644 (file)
@@ -74,7 +74,7 @@ diff -urN exim-4.14-0/src/globals.h exim-4.14-1/src/globals.h
 diff -urN exim-4.14-0/src/local_scan.c exim-4.14-1/src/local_scan.c
 --- exim-4.14-0/src/local_scan.c       Tue Mar 11 04:20:20 2003
 +++ exim-4.14-1/src/local_scan.c       Sun Mar 23 15:34:15 2003
-@@ -5,60 +5,131 @@
+@@ -5,61 +5,131 @@
  /* Copyright (c) University of Cambridge 1995 - 2003 */
  /* See the file NOTICE for conditions of use and distribution. */
  
@@ -86,6 +86,7 @@ diff -urN exim-4.14-0/src/local_scan.c exim-4.14-1/src/local_scan.c
 -Local/local_scan.c, and edit the copy. To use your version instead of the
 -default, you must set
 -
+-HAVE_LOCAL_SCAN=yes
 -LOCAL_SCAN_SOURCE=Local/local_scan.c
 -
 -in your Local/Makefile. This makes it easy to copy your version for use with
This page took 0.330498 seconds and 4 git commands to generate.