]> git.pld-linux.org Git - packages/exim.git/commitdiff
- rel 7; and one more fix (manual backport of upstream commit c14470c30aa0) auto/th/exim-4.86-7
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 2 Dec 2015 18:29:21 +0000 (19:29 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 2 Dec 2015 18:29:21 +0000 (19:29 +0100)
exim-dkim.patch
exim.spec

index 0dcdbea6f4a0f534454257b19b349269b398550f..80dd59b327d7372e17e907154007b07d77f9e2da 100644 (file)
@@ -135,3 +135,34 @@ index 99948ff..94328f7 100644
        goto BAIL;
      }
 
+--- a/src/src/pdkim/pdkim.c~   2015-12-02 19:18:54.000000000 +0100
++++ a/src/src/pdkim/pdkim.c    2015-12-02 19:22:09.149625694 +0100
+@@ -1096,6 +1096,7 @@
+ int pdkim_bodyline_complete(pdkim_ctx *ctx) {
+   char *p = ctx->linebuf;
+   int   n = ctx->linebuf_offset;
++  pdkim_signature *sig = ctx->sig;       /*XXX assumes only one sig */
+   /* Ignore extra data if we've seen the end-of-data marker */
+   if (ctx->seen_eod) goto BAIL;
+@@ -1108,7 +1109,8 @@
+     if (memcmp(p,".\r\n",3) == 0) {
+       /* In simple body mode, if any empty lines were buffered,
+       replace with one. rfc 4871 3.4.3 */
+-      if (ctx->sig && ctx->sig->canon_body == PDKIM_CANON_SIMPLE
++      if (  sig && sig->canon_body == PDKIM_CANON_SIMPLE
++         && sig->signed_body_bytes == 0
+        && ctx->num_buffered_crlf > 0)
+       pdkim_update_bodyhash(ctx,"\r\n",2);
+@@ -1128,8 +1130,8 @@
+     goto BAIL;
+   }
+-  if (  ctx->sig
+-     && ctx->sig->canon_body == PDKIM_CANON_RELAXED) {
++  if (  sig
++     && sig->canon_body == PDKIM_CANON_RELAXED) {
+     /* Lines with just spaces need to be buffered too */
+     char *check = p;
+     while(memcmp(check,"\r\n",2) != 0) {
index 878bdcbc6d64d8bfbb856cecb2c668d033456941..ad6928c9256624a01e2667acf65c251b08b8e3ee 100644 (file)
--- a/exim.spec
+++ b/exim.spec
@@ -21,7 +21,7 @@ Summary(pl.UTF-8):    Agent Transferu Poczty Uniwersytetu w Cambridge
 Summary(pt_BR.UTF-8):  Servidor de correio eletrônico exim
 Name:          exim
 Version:       4.86
-Release:       6
+Release:       7
 Epoch:         2
 License:       GPL
 Group:         Networking/Daemons/SMTP
This page took 0.171492 seconds and 4 git commands to generate.