]> git.pld-linux.org Git - packages/exact-image.git/commitdiff
- initial PLD release
authorTomasz Pala <gotar@pld-linux.org>
Fri, 13 May 2011 22:48:49 +0000 (22:48 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    exact-image-libs.patch -> 1.1
    exact-image.spec -> 1.1

exact-image-libs.patch [new file with mode: 0644]
exact-image.spec [new file with mode: 0644]

diff --git a/exact-image-libs.patch b/exact-image-libs.patch
new file mode 100644 (file)
index 0000000..c16adef
--- /dev/null
@@ -0,0 +1,45 @@
+diff -ur -urp exact-image-0.8.5.orig/api/lua/Makefile exact-image-0.8.5/api/lua/Makefile
+--- exact-image-0.8.5.orig/api/lua/Makefile    2008-10-18 11:11:43.000000000 +0200
++++ exact-image-0.8.5/api/lua/Makefile 2011-05-14 00:01:05.000000000 +0200
+@@ -16,7 +16,7 @@ X_BUILD_IMPLICIT := 0
+ include build/bottom.make
+ X_BUILD_IMPLICIT := $(_X_BUILD_IMPLICIT)
+-api/lua/libdir := $(shell pkg-config lua --variable INSTALL_CMOD)
++api/lua/libdir := $(shell pkg-config lua51 --variable INSTALL_CMOD)
+ # install
+ all:: $($(X_MODULE)_BINARY)
+diff -ur -urp exact-image-0.8.5.orig/codecs/png.cc exact-image-0.8.5/codecs/png.cc
+--- exact-image-0.8.5.orig/codecs/png.cc       2010-03-03 22:04:44.000000000 +0100
++++ exact-image-0.8.5/codecs/png.cc    2011-05-14 00:28:20.000000000 +0200
+@@ -16,7 +16,7 @@
+  */
+ #include <stdlib.h>
+-#include <png.h>
++#include <libpng12/png.h>
+ #include <iostream>
+diff -ur -urp exact-image-0.8.5.orig/configure exact-image-0.8.5/configure
+--- exact-image-0.8.5.orig/configure   2010-11-21 11:01:04.000000000 +0100
++++ exact-image-0.8.5/configure        2011-05-14 00:22:45.000000000 +0200
+@@ -63,7 +63,7 @@ fi
+ pkgcheck libjpeg header LIBJPEG cc jconfig.h
+ pkgcheck libtiff header LIBTIFF c++ tiffconf.h tiffio.h tiffio.hxx
+-pkgcheck libpng pkg-config LIBPNG atleast 1.2
++pkgcheck libpng12 pkg-config LIBPNG atleast 1.2
+ pkgcheck libungif header LIBUNGIF c++ gif_lib.h
+ pkgcheck jasper header JASPER c++ jasper/jasper.h
+ if pkgcheck expat header EXPAT c++ expat.h; then # just for the SVG parser
+@@ -91,7 +91,7 @@ pkgcheck swig shell SWIG 'swig -version 
+ # supported swig target languages so far
+-pkgcheck lua pkg-config LUA atleast 5.1
++pkgcheck lua51 pkg-config LUA atleast 5.1
+ pkgcheck perl shell PERL 'perl -version 2>/dev/null | sed -n "s/This is perl.*v\([0-9.]*\).*built.*/\1/p"' atleast 5.8.0 &&
+       PERLINCS="`perl -MExtUtils::Embed -e ccopts`"
diff --git a/exact-image.spec b/exact-image.spec
new file mode 100644 (file)
index 0000000..09db626
--- /dev/null
@@ -0,0 +1,57 @@
+Summary:       A fast, modern and generic image processing library
+Name:          exact-image
+Version:       0.8.5
+Release:       1
+License:       GPL v2
+Group:         Applications/Graphics
+Source0:       http://dl.exactcode.de/oss/exact-image/%{name}-%{version}.tar.bz2
+# Source0-md5: 54c5dc9afd86ec573e7e2e9a80f45c71
+Patch0:                %{name}-libs.patch
+URL:           http://www.exactcode.de/site/open_source/exactimage/
+BuildRequires: OpenEXR-devel >= 1.2.0
+BuildRequires: agg-devel >= 2.3
+BuildRequires: evas-devel >= 0.9.9
+BuildRequires: jasper-devel
+BuildRequires: lcms-devel >= 1.10
+BuildRequires: libpng12-devel >= 1.2
+BuildRequires: libstdc++-devel
+BuildRequires: libtiff-cxx-devel
+BuildRequires: libungif-devel
+BuildRequires: lua51-devel
+BuildRequires: perl-devel >= 5.8.0
+BuildRequires: php-devel >= 5.2.0
+BuildRequires: python-devel >= 2.5.0
+BuildRequires: ruby >= 1.8.5
+BuildRequires: swig-perl >= 1.3.32
+BuildRequires: swig-php >= 1.3.32
+BuildRequires: swig-python >= 1.3.32
+BuildRequires: xorg-lib-libX11-devel >= 1.3
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+A fast, modern and generic (template) based C++ image processing library,
+alternative to ImageMagick.
+
+%prep
+%setup -q
+%patch0 -p1
+
+%build
+./configure --prefix=%{_prefix}
+%{__make} \
+       CFLAGS="%{rpmcflags}" \
+       CXXFLAGS="%{rpmcflags}"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README TODO
+%attr(755,root,root) %{_bindir}/*
This page took 0.102478 seconds and 4 git commands to generate.