]> git.pld-linux.org Git - packages/ex.git/blame - ex.spec
- up to 1.0.6
[packages/ex.git] / ex.spec
CommitLineData
c3888f16 1#
2# Conditional build:
0d0b2909
JB
3%bcond_without static_libs # don't build static libraries
4%bcond_without tests # don't perform "make check"
c3888f16 5#
55c4faf9 6Summary: OSSP ex - Exception Handling
fd487d2d 7Summary(pl.UTF-8): OSSP ex - biblioteka obsługi wyjątków
55c4faf9 8Name: ex
7e5df30e 9Version: 1.0.6
2fa2c553 10Release: 0.1
16a700a0 11Epoch: 0
55c4faf9 12License: distributable (see README)
13Group: Libraries
383e2333 14Source0: ftp://ftp.ossp.org/pkg/lib/ex/%{name}-%{version}.tar.gz
7e5df30e 15# Source0-md5: 20ff7fb1c49968c51b77e4c669a67e25
f8c7265c 16Patch0: %{name}-libs.patch
376c6ccd 17URL: http://www.ossp.org/pkg/lib/ex/
55c4faf9 18BuildRequires: autoconf
19BuildRequires: automake
20BuildRequires: libtool
55c4faf9 21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24OSSP ex is a small ISO-C++ style exception handling library for use in
25the ISO-C language. It allows you to use the paradigm of throwing and
26catching exceptions in order to reduce the amount of error handling
27code without making your program less robust.
28
29This is achieved by directly transferring exceptional return codes
30(and the program control flow) from the location where the exception
31is raised (throw point) to the location where it is handled (catch
32point) -- usually from a deeply nested sub-routine to a parent
33routine. All intermediate routines no longer have to make sure that
34the exceptional return codes from sub-routines are correctly passed
35back to the parent.
36
37The OSSP ex facility also provides advanced exception handling
38features like shielded and deferred exceptions. Additionally, OSSP ex
39allows you to choose the used underlying machine context switching
40facility and optionally support multi-threading environments by
41allowing you to store the exception catching stack in a thread-safe
42way.
43
159c1ab4
JR
44%description -l pl.UTF-8
45OSSP ex to mała biblioteka do obsługi wyjątków w stylu ISO-C++
46przeznaczona do używania w języku ISO-C. Umożliwia korzystanie z
47paradygmatu rzucania i wyłapywania wyjątków w celi ograniczenia
48ilości kodu obsługującego błędy bez czynienia programu uboższym.
49
50Zostało to osiągnięte poprzez bezpośrednie przesyłanie wyjątkowych
51kodów powrotu (i przepływu sterowania programu) z miejsca gdzie
52wystąpił wyjątek (miejsca rzucenia) do miejsca jego obsługi (miejsca
53wyłapania) - zwykle z głęboko zagnieżdżonej podprocedury do procedury
54nadrzędnej. Pośrednie procedury nie muszą się już upewniać, że
55wyjątkowe kody powrotu z podprocedur są poprawnie przekazywane do z
383e2333
JB
56powrotem do rodzica.
57
159c1ab4
JR
58Ułatwienia OSSP ex dają także zaawansowane możliwości obsługi
59wyjątków, takie jak osłaniane i opóźnione wyjątki. Ponadto OSSP ex
60umożliwia wybór udogodnień maszyny przełączającej kontekst oraz
61opcjonalną obsługę środowisk wielowątkowych poprzez umożliwienie
62przechowywania stosu wyłapywania wyjątków w sposób bezpieczny dla
63wątków.
55c4faf9 64
65%package devel
383e2333 66Summary: OSSP ex - Exception Handling - header files and development libraries
fd487d2d 67Summary(pl.UTF-8): OSSP ex - biblioteka obsługi wyjątków - pliki nagłówkowe i biblioteki dla deweloperów
55c4faf9 68Group: Development/Libraries
69Requires: %{name} = %{epoch}:%{version}-%{release}
70
71%description devel
72OSSP ex - Exception Handling - header files and development
73libraries.
74
159c1ab4
JR
75%description devel -l pl.UTF-8
76OSSP ex - biblioteka obsługi wyjątków - pliki nagłówkowe i biblioteki
77dla deweloperów.
55c4faf9 78
79%package static
383e2333 80Summary: OSSP ex - Exception Handling - static libraries
fd487d2d 81Summary(pl.UTF-8): OSSP ex - biblioteka obsługi wyjątków - biblioteki statyczne
55c4faf9 82Group: Development/Libraries
83Requires: %{name}-devel = %{epoch}:%{version}-%{release}
84
85%description static
86OSSP ex - Exception Handling - static libraries.
87
159c1ab4
JR
88%description static -l pl.UTF-8
89OSSP ex - biblioteka obsługi wyjątków - biblioteki statyczne.
55c4faf9 90
91%prep
92%setup -q
f8c7265c 93%patch0 -p1
383e2333 94
55c4faf9 95%build
96mv -f aclocal.m4 acinclude.m4
97%{__libtoolize}
98%{__aclocal}
99%{__autoconf}
100
2fa2c553 101%configure \
102 --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
55c4faf9 103%{__make}
c3888f16 104
105%{?with_tests:%{__make} check}
55c4faf9 106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110%{__make} install \
111 DESTDIR=$RPM_BUILD_ROOT
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
383e2333
JB
116%post -p /sbin/ldconfig
117%postun -p /sbin/ldconfig
55c4faf9 118
119%files
120%defattr(644,root,root,755)
121%doc AUTHORS ChangeLog README THANKS
122%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
123
124%files devel
125%defattr(644,root,root,755)
126%attr(755,root,root) %{_bindir}/*
127%attr(755,root,root) %{_libdir}/lib*.so
128%{_libdir}/lib*.la
129%{_includedir}/*
130%{_mandir}/man3/*
131
2fa2c553 132%if %{with static_libs}
55c4faf9 133%files static
134%defattr(644,root,root,755)
135%attr(755,root,root) %{_libdir}/lib*.a
2fa2c553 136%endif
This page took 0.085696 seconds and 4 git commands to generate.