]> git.pld-linux.org Git - packages/ewebkit.git/commitdiff
- WIP on building with recent gcc and on x32: added x32 patch, enhanced werror patch
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 9 Oct 2015 20:43:58 +0000 (22:43 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 9 Oct 2015 20:43:58 +0000 (22:43 +0200)
ewebkit-werror.patch
ewebkit-x32.patch [new file with mode: 0644]
ewebkit.spec

index 8d5a27e8ffb951e812af3c7c29bca46320baefa3..91f8c089705ae535144da57e043a9038e156145f 100644 (file)
          getLineAndColumn(info, line, column);
          dumpLineColumnEntry(i, instructions(), info.instructionOffset, line, column);
      }
+--- efl-webkit/Source/cmake/WebKitHelpers.cmake.orig   2013-12-27 11:25:36.000000000 +0100
++++ efl-webkit/Source/cmake/WebKitHelpers.cmake        2015-10-09 21:45:01.022925646 +0200
+@@ -44,7 +44,7 @@
+         # Enable errors on warning
+         if (OPTION_ENABLE_WERROR)
+-            set(OLD_COMPILE_FLAGS "-Werror -Wno-error=unused-parameter ${OLD_COMPILE_FLAGS}")
++            set(OLD_COMPILE_FLAGS "-Werror -Wno-error=unused-parameter -Wno-error=uninitialized -Wno-error=parentheses ${OLD_COMPILE_FLAGS}")
+         endif ()
+         set_target_properties(${_target} PROPERTIES
diff --git a/ewebkit-x32.patch b/ewebkit-x32.patch
new file mode 100644 (file)
index 0000000..03054b7
--- /dev/null
@@ -0,0 +1,29 @@
+From: Daniel Schepler <dschepler@gmail.com>
+Subject: Fix FTBFS in x32
+Bug-Debian: https://bugs.debian.org/700795
+Index: webkitgtk/Source/WTF/wtf/Platform.h
+===================================================================
+--- webkitgtk.orig/Source/WTF/wtf/Platform.h
++++ webkitgtk/Source/WTF/wtf/Platform.h
+@@ -179,8 +179,12 @@
+ /* CPU(X86_64) - AMD64 / Intel64 / x86_64 64-bit */
+ #if   defined(__x86_64__) \
+     || defined(_M_X64)
++#ifdef __ILP32__
++#define WTF_CPU_X86_64_32 1
++#else
+ #define WTF_CPU_X86_64 1
+ #endif
++#endif
+ /* CPU(ARM64) - Apple */
+ #if defined(__arm64__) && defined(__APPLE__)
+@@ -826,7 +826,7 @@
+ #define ENABLE_REGEXP_TRACING 0
+ /* Yet Another Regex Runtime - turned on by default for JIT enabled ports. */
+-#if !defined(ENABLE_YARR_JIT) && (ENABLE(JIT) || ENABLE(LLINT_C_LOOP))
++#if !defined(ENABLE_YARR_JIT) && ENABLE(JIT)
+ #define ENABLE_YARR_JIT 1
+ /* Setting this flag compares JIT results with interpreter results. */
index 73403a2660249abd5d1c3dd0a5eddde1c90d4624..5e978fc963e06ece7081fd240c91cda5006d58dc 100644 (file)
@@ -24,6 +24,7 @@ Patch0:               %{name}-lib.patch
 Patch1:                %{name}-werror.patch
 Patch2:                %{name}-include.patch
 Patch3:                %{name}-build.patch
+Patch4:                %{name}-x32.patch
 URL:           http://trac.enlightenment.org/e/wiki/EWebKit
 BuildRequires: OpenGL-devel
 BuildRequires: atk-devel >= 1:2.10.0
@@ -133,6 +134,7 @@ Pliki nagłówkowe biblioteki WebKit-EFL.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 # replace -g2 with -g1 to not run into 4 GB ar format limit
@@ -141,6 +143,9 @@ Pliki nagłówkowe biblioteki WebKit-EFL.
 CFLAGS="%(echo %{rpmcflags} | sed 's/ -g2/ -g1/g')"
 CXXFLAGS="%(echo %{rpmcxxflags} | sed 's/ -g2/ -g1/g') -Wno-deprecated-declarations"
 %cmake . \
+%ifarch x32
+       -DENABLE_JIT=OFF \
+%endif
        -DPORT=Efl
 %{__make}
 
This page took 0.08686 seconds and 4 git commands to generate.