]> git.pld-linux.org Git - packages/ewebkit.git/commitdiff
- fix build with icu 59 master auto/th/ewebkit-0.1.0-0.r164189.9
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 27 Apr 2017 18:35:21 +0000 (20:35 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 27 Apr 2017 18:35:21 +0000 (20:35 +0200)
- rel 9

ewebkit.spec
icu59.patch [new file with mode: 0644]

index b9186dc68172f1a8c9b842dbda4f0127712f53d6..785a75999a75c72d7531c3becaecbeb48a73b20f 100644 (file)
@@ -3,7 +3,7 @@
 %bcond_with    elementary      # MiniBrowser build (needs Elementary); not installed anyway
 #
 %define                efl_ver 1.8
-%define                rel 8
+%define                rel 9
 Summary:       WebKit-EFL - Web content engine for EFL applications
 Summary(pl.UTF-8):     WebKit-EFL - silnik WWW dla aplikacji EFL
 Name:          ewebkit
@@ -31,6 +31,7 @@ Patch7:               gstreamer-headers.patch
 Patch8:                cmake-3.4.patch
 Patch9:                cxx.patch
 Patch10:       missing-headers.patch
+Patch11:       icu59.patch
 URL:           http://trac.enlightenment.org/e/wiki/EWebKit
 BuildRequires: OpenGL-devel
 BuildRequires: atk-devel >= 1:2.10.0
@@ -148,6 +149,7 @@ Pliki nagłówkowe biblioteki WebKit-EFL.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
 
 %build
 # replace -g2 with -g1 to not run into 4 GB ar format limit
diff --git a/icu59.patch b/icu59.patch
new file mode 100644 (file)
index 0000000..a7c190e
--- /dev/null
@@ -0,0 +1,38 @@
+--- qtwebkit-opensource-src-5.5.1/Source/JavaScriptCore/API/JSStringRef.h.orig 2015-10-13 06:37:10.000000000 +0200
++++ qtwebkit-opensource-src-5.5.1/Source/JavaScriptCore/API/JSStringRef.h      2017-04-24 12:26:42.495345570 +0200
+@@ -32,6 +32,7 @@
+ #include <stdbool.h>
+ #endif
+ #include <stddef.h> /* for size_t */
++#include <uchar.h>
+ #ifdef __cplusplus
+ extern "C" {
+@@ -43,7 +44,7 @@
+ @typedef JSChar
+ @abstract A Unicode character.
+ */
+-    typedef unsigned short JSChar;
++    typedef char16_t JSChar;
+ #else
+     typedef wchar_t JSChar;
+ #endif
+--- qtwebkit-opensource-src-5.5.1/Source/WebKit2/Shared/API/c/WKString.h.orig  2015-10-13 06:37:12.000000000 +0200
++++ qtwebkit-opensource-src-5.5.1/Source/WebKit2/Shared/API/c/WKString.h       2017-04-24 12:27:33.432011867 +0200
+@@ -31,6 +31,7 @@
+ #ifndef __cplusplus
+ #include <stdbool.h>
+ #endif
++#include <uchar.h>
+ #ifdef __cplusplus
+ extern "C" {
+@@ -38,7 +39,7 @@
+ #if !defined(WIN32) && !defined(_WIN32) \
+     && !((defined(__CC_ARM) || defined(__ARMCC__)) && !defined(__linux__)) /* RVCT */
+-    typedef unsigned short WKChar;
++    typedef char16_t WKChar;
+ #else
+     typedef wchar_t WKChar;
+ #endif
This page took 0.096815 seconds and 4 git commands to generate.