- merged from DEVEL and updated to 2.8.0
authorgrzegol <grzegol@pld-linux.org>
Wed, 6 Sep 2006 21:05:31 +0000 (21:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    evolution-exchange.spec -> 1.11

evolution-exchange.spec

index fc02d81..5eb7d10 100644 (file)
@@ -5,31 +5,37 @@
 # the evo-openldap package, or building OpenLDAP with the patch in
 # docs/openldap-ntlm.diff
 #
+%define        filterout_ld    -Wl,--as-needed
 Summary:       Microsoft Exchange support for Evolution
 Summary(pl):   Wsparcie dla Microsoft Exchange w Evolution
 Name:          evolution-exchange
-Version:       2.4.2
-Release:       2
+Version:       2.8.0
+Release:       1
 License:       GPL v2
 Group:         X11/Applications
-Source0:       http://ftp.gnome.org/pub/gnome/sources/evolution-exchange/2.4/%{name}-%{version}.tar.bz2
-# Source0-md5: 67802f9c0be1528edaa0612188588914
-BuildRequires: GConf2-devel
+Source0:       http://ftp.gnome.org/pub/gnome/sources/evolution-exchange/2.8/%{name}-%{version}.tar.bz2
+# Source0-md5: 72f595063fc19a2e7325ea73438faa87
+BuildRequires: GConf2-devel >= 2.14.0
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
-BuildRequires: evolution-data-server-devel >= 1.4.1
-BuildRequires: evolution-devel >= 2.4.0
-BuildRequires: gtk+2-devel >= 2:2.8.3
+BuildRequires: evolution-data-server-devel >= 1.8.0
+BuildRequires: evolution-devel >= 2.8.0
+BuildRequires: gtk+2-devel >= 2:2.10.3
+BuildRequires: gtk-doc >= 1.7
 BuildRequires: heimdal-devel >= 0.7
-BuildRequires: intltool
-BuildRequires: libgnomeui-devel >= 2.12.0
-BuildRequires: libsoup-devel >= 2.2.6.1
+BuildRequires: intltool >= 0.35.0
+BuildRequires: libbonobo-devel >= 2.16.0
+BuildRequires: libglade2-devel >= 2.6.0
+BuildRequires: libgnomeprint-devel >= 2.12.1
+BuildRequires: libgnomeui-devel >= 2.16.0
+BuildRequires: libsoup-devel >= 2.2.96
+BuildRequires: libxml2-devel >= 2.6.26
 BuildRequires: openldap-devel >= 2.3.0
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.197
-Requires(post,preun):  GConf2
-Requires:      evolution >= 2.4.1
-Requires:      gtk+2 >= 2:2.8.3
+Requires(post,preun):  GConf2 >= 2.14.0
+Requires:      evolution >= 2.8.0
+Requires:      gtk+2 >= 2:2.10.3
 Obsoletes:     ximian-connector
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -44,14 +50,16 @@ Ten pakiet dodaje do Evolution obs
 %setup -q
 
 %build
-%{__intltoolize}
 %{__glib_gettextize}
+%{__intltoolize}
 %{__aclocal}
 %{__autoconf}
 %{__automake}
 %configure \
-       --with-openlda-=/usr \
+       --with-openldap=/usr \
        --with-krb5=/usr \
+       --disable-schemas-install \
+       --enable-gtk-doc \
        --with-html-dir=%{_gtkdocdir}
 %{__make}
 
@@ -61,18 +69,17 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
 rm -f $RPM_BUILD_ROOT%{_libdir}/evolution-data-server-*/camel-providers/*.{la,a}
 
-%find_lang %{name}-2.4
+%find_lang %{name}-2.8
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files -f %{name}-2.4.lang
+%files -f %{name}-2.8.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README 
-%attr(755,root,root) %{_bindir}/ximian-connector-setup-*
+%attr(755,root,root) %{_bindir}/exchange-connector-setup-*
 %attr(755,root,root) %{_libdir}/evolution-data-server-*/camel-providers/*.so
 %attr(755,root,root) %{_libdir}/evolution/*/evolution-exchange-storage
 %{_datadir}/%{name}
This page took 0.051529 seconds and 4 git commands to generate.