- merged from DEVEL and updated to 2.8.0
[packages/evolution-exchange.git] / evolution-exchange.spec
1
2 # configure: WARNING:
3 # No NTLM support in OpenLDAP; Plaintext password authentication will be
4 # used when connecting to the Global Catalog server. Consider installing
5 # the evo-openldap package, or building OpenLDAP with the patch in
6 # docs/openldap-ntlm.diff
7 #
8 %define filterout_ld    -Wl,--as-needed
9 Summary:        Microsoft Exchange support for Evolution
10 Summary(pl):    Wsparcie dla Microsoft Exchange w Evolution
11 Name:           evolution-exchange
12 Version:        2.8.0
13 Release:        1
14 License:        GPL v2
15 Group:          X11/Applications
16 Source0:        http://ftp.gnome.org/pub/gnome/sources/evolution-exchange/2.8/%{name}-%{version}.tar.bz2
17 # Source0-md5:  72f595063fc19a2e7325ea73438faa87
18 BuildRequires:  GConf2-devel >= 2.14.0
19 BuildRequires:  autoconf >= 2.53
20 BuildRequires:  automake
21 BuildRequires:  evolution-data-server-devel >= 1.8.0
22 BuildRequires:  evolution-devel >= 2.8.0
23 BuildRequires:  gtk+2-devel >= 2:2.10.3
24 BuildRequires:  gtk-doc >= 1.7
25 BuildRequires:  heimdal-devel >= 0.7
26 BuildRequires:  intltool >= 0.35.0
27 BuildRequires:  libbonobo-devel >= 2.16.0
28 BuildRequires:  libglade2-devel >= 2.6.0
29 BuildRequires:  libgnomeprint-devel >= 2.12.1
30 BuildRequires:  libgnomeui-devel >= 2.16.0
31 BuildRequires:  libsoup-devel >= 2.2.96
32 BuildRequires:  libxml2-devel >= 2.6.26
33 BuildRequires:  openldap-devel >= 2.3.0
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(macros) >= 1.197
36 Requires(post,preun):   GConf2 >= 2.14.0
37 Requires:       evolution >= 2.8.0
38 Requires:       gtk+2 >= 2:2.10.3
39 Obsoletes:      ximian-connector
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 This package adds support for Microsoft Exchange 2000 and 2003 to
44 Evolution.
45
46 %description -l pl
47 Ten pakiet dodaje do Evolution obs³ugê Microsoft Exchange 2000 i 2003.
48
49 %prep
50 %setup -q
51
52 %build
53 %{__glib_gettextize}
54 %{__intltoolize}
55 %{__aclocal}
56 %{__autoconf}
57 %{__automake}
58 %configure \
59         --with-openldap=/usr \
60         --with-krb5=/usr \
61         --disable-schemas-install \
62         --enable-gtk-doc \
63         --with-html-dir=%{_gtkdocdir}
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 rm -f $RPM_BUILD_ROOT%{_libdir}/evolution-data-server-*/camel-providers/*.{la,a}
73
74 %find_lang %{name}-2.8
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files -f %{name}-2.8.lang
80 %defattr(644,root,root,755)
81 %doc AUTHORS ChangeLog NEWS README 
82 %attr(755,root,root) %{_bindir}/exchange-connector-setup-*
83 %attr(755,root,root) %{_libdir}/evolution-data-server-*/camel-providers/*.so
84 %attr(755,root,root) %{_libdir}/evolution/*/evolution-exchange-storage
85 %{_datadir}/%{name}
86 %{_gtkdocdir}/*
87 %{_libdir}/bonobo/servers/*
88 %{_libdir}/evolution-data-server-*/camel-providers/*.urls
This page took 0.061559 seconds and 3 git commands to generate.