b325559d87584436662933a146a01330ebe5ec1c
[packages/evolution-ews.git] / evolution-ews.spec
1 Summary:        Evolution extension for Exchange Web Services
2 Summary(pl.UTF-8):      Rozszerzenie Evolution dla Exchange Web Services
3 Name:           evolution-ews
4 Version:        3.22.5
5 Release:        1
6 License:        LGPL v2+
7 Group:          X11/Applications/Mail
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/evolution-ews/3.22/%{name}-%{version}.tar.xz
9 # Source0-md5:  b7d899526798620ac63e8a97ee922a2f
10 Patch0:         %{name}-link.patch
11 URL:            http://projects.gnome.org/evolution/
12 BuildRequires:  autoconf >= 2.58
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  evolution-data-server-devel >= %{version}
15 BuildRequires:  evolution-devel >= %{version}
16 BuildRequires:  gettext-tools
17 BuildRequires:  glib2-devel >= 1:2.40.0
18 BuildRequires:  gtk+3-devel >= 3.0.0
19 BuildRequires:  gtk-doc >= 1.9
20 BuildRequires:  intltool >= 0.40.0
21 BuildRequires:  libical-devel
22 BuildRequires:  libmspack-devel >= 0.4
23 BuildRequires:  libsoup-devel >= 2.42.0
24 BuildRequires:  libtool >= 2:2.2
25 BuildRequires:  pkgconfig
26 BuildRequires:  sqlite3-devel
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Requires:       evolution >= %{version}
30 Requires:       evolution-data-server >= %{version}
31 Requires:       glib2 >= 1:2.40.0
32 Requires:       libsoup >= 2.42.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This package allows Evolution to interact with Microsoft Exchange
37 servers, versions 2007 and later, through its Exchange Web Services
38 (EWS) interface.
39
40 %description -l pl.UTF-8
41 Ten pakiet pozwala programowi Evolution współpracować z serwerami
42 Microsoft Exchange w wersji 2007 lub nowszej poprzez interfejs EWS
43 (Exchange Web Services).
44
45 %package devel
46 Summary:        Development files for EWS libraries
47 Summary(pl.UTF-8):      Pliki programistyczne bibliotek EWS
48 Group:          X11/Development/Libraries
49 Requires:       evolution-data-server-devel >= %{version}
50 Requires:       glib2-devel >= 1:2.40.0
51 Requires:       libsoup-devel >= 2.42.0
52
53 %description devel
54 This package provides development files for EWS library.
55
56 %description devel -l pl.UTF-8
57 Ten pakiet zawiera pliki programistyczne bibliotek EWS.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62
63 %build
64 %{__intltoolize}
65 %{__libtoolize}
66 %{__aclocal} -I m4
67 %{__autoconf}
68 %{__autoheader}
69 %{__automake}
70 %configure \
71         --disable-silent-rules
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %{__rm} $RPM_BUILD_ROOT%{_libdir}/evolution-data-server/*.la
81 %{__rm} $RPM_BUILD_ROOT%{_libdir}/evolution-data-server/*/*.la
82 %{__rm} $RPM_BUILD_ROOT%{_libdir}/evolution/modules/*.la
83
84 %find_lang %{name}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files -f %{name}.lang
90 %defattr(644,root,root,755)
91 %doc AUTHORS ChangeLog NEWS README
92 %attr(755,root,root) %{_libdir}/evolution-data-server/libeews-1.2.so*
93 %attr(755,root,root) %{_libdir}/evolution-data-server/libewsutils.so*
94 %attr(755,root,root) %{_libdir}/evolution-data-server/addressbook-backends/libebookbackendews.so
95 %attr(755,root,root) %{_libdir}/evolution-data-server/calendar-backends/libecalbackendews.so
96 %attr(755,root,root) %{_libdir}/evolution-data-server/camel-providers/libcamelews.so
97 %attr(755,root,root) %{_libdir}/evolution-data-server/registry-modules/module-ews-backend.so
98 %{_libdir}/evolution-data-server/camel-providers/libcamelews.urls
99 %attr(755,root,root) %{_libdir}/evolution/modules/module-ews-configuration.so
100 %{_datadir}/evolution/errors/module-ews-configuration.error
101 %{_datadir}/evolution-data-server/ews
102 %{_datadir}/appdata/evolution-ews.metainfo.xml
103
104 %files devel
105 %defattr(644,root,root,755)
106 %{_includedir}/evolution-data-server/ews
This page took 0.052271 seconds and 2 git commands to generate.