]> git.pld-linux.org Git - packages/everygui.git/blob - everygui.spec
automatic change: use py_build/py_install macros
[packages/everygui.git] / everygui.spec
1 #
2 # TODO:
3 # - BRs
4 # - Rs and check existing one
5 # - patch easygui's code to run egdesigner from different location
6 #
7 Summary:        A GUI for everything
8 Summary(pl.UTF-8):      GUI do wszystkiego
9 Name:           everygui
10 Version:        0.99.b
11 Release:        0.1
12 License:        GPL
13 Group:          X11/Applications
14 Source0:        http://dl.sourceforge.net/everygui/%{name}-%{version}.tar.gz
15 # Source0-md5:  78953de66b973b97b194d679969acc9f
16 Patch0:         %{name}-setup.patch
17 Patch1:         %{name}-exec.patch
18 URL:            http://everygui.sourceforge.net/
19 BuildRequires:  python-pygtk-gtk >= 2:2.6
20 Requires:       python >= 2.3
21 Requires:       python-pygtk-libglade >= 2:2.6
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 EveryGui is an attempt at being a GTK+ Graphical User Interface for
26 "Everything" (involving command line programs) on UNIX systems. This
27 goal is achieved by providing two powerful applications:
28
29 Chameleon, which is a dynamic GUI for virtually any tool or OS
30 command. It loads config files of tools which are chosen from a list,
31 and dynamically creates widgets reperesenting the tools' options. Not
32 only does it execute the commands, but it can save a batch of commands
33 into a shell script for later/repeated use.
34
35 And Designer, which is a visual environment for creating/editing
36 config files that determine Chameleon's different behaviours for each
37 tool/command. Designer feels like a cross between QT Designer and
38 Glade, but requires no coding at all to get the functionality working
39 (that's Chameleon's job to do it automagically).
40
41 %description -l pl.UTF-8
42 EveryGui to jest próbą stworzenia GUI w GTK+ do "wszystkiego"
43 (związanego z programami działającymi z linii poleceń) na systemach
44 UNIX. Cel osiągnięto dostarczając dwóch potężnych aplikacji:
45
46 Chameleona, który jest dynamicznym GUI dla niemalże każdego
47 narzędzia albo komendy systemowej. Ładuje pliki konfiguracyjne
48 narzędzi wybranych z listy i dynamicznie tworzy kontrolki
49 reprezentujące przełączniki narzędzia. Chameleon nie tylko
50 wywołuje komendy ale i również może zachować serię komend w
51 pliku powłoki dla późniejszego/powtarzającego się użycia.
52
53 I Designera, który jest wizualnym środowiskiem do tworzenia/edycji
54 plików konfiguracyjnych, które powodują różne zachowanie
55 Chameleona dla każdego narzędzia/polecenia. Designer przypomina w
56 zachowaniu mieszankę Qt Designera i Glade'a, ale nie wymaga żadnego
57 programowania do uruchomienia funkcjonalności (to w końcu zadanie
58 Chameleona, aby robić to automagicznie).
59
60 %prep
61 %setup -q -n %{name}
62 %patch0 -p1
63 %patch1 -p1
64
65 %build
66 cat << EOF > everygui
67 #!/bin/sh
68
69 #start everygui
70 %{__python} %{py_sitescriptdir}/everygui/everygui.pyc
71 EOF
72
73 cat << EOF > egdesign
74 #!/bin/sh
75
76 #start designer
77 %{__python} %{py_sitescriptdir}/everygui/designer.pyc
78 EOF
79
80 %py_build
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %py_install -O1 --skip-build --root $RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS ChangeLog README TODO
93 %attr(755,root,root) %{_bindir}/*
94 %{_datadir}/everygui
95 %dir %{py_sitescriptdir}/everygui
96 %{py_sitescriptdir}/everygui/*.py[co]
97 %{py_sitescriptdir}/everygui-%{version}-*.egg-info
This page took 0.086843 seconds and 3 git commands to generate.