]> git.pld-linux.org Git - packages/eventum.git/commitdiff
- up to r4034 snap, crons in subdir
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 30 Jan 2010 05:14:40 +0000 (05:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    eventum-mail-download.cron -> 1.8
    eventum-mail-queue.cron -> 1.9
    eventum-monitor.cron -> 1.9
    eventum-reminder.cron -> 1.8
    eventum.spec -> 1.313

eventum-mail-download.cron
eventum-mail-queue.cron
eventum-monitor.cron
eventum-reminder.cron
eventum.spec

index bf70e73aea0110c18fae2b68e18e4ee0861d81bc..c67b43ad07394346751cee6d55c0844844ea38fc 100644 (file)
@@ -11,4 +11,4 @@ MAILTO=root
 #
 # Administration >>> Manage Email Accounts
 
-#0 * * * * http /usr/share/eventum/download_emails.php username_here mail.domain.com INBOX
+#0 * * * * http /usr/share/eventum/crons/download_emails.php username_here mail.domain.com INBOX
index 7e687d768baf47229a2145ac9ea7485e70789929..8ed141e505822b190a341c41f62ee759c3ec33dc 100644 (file)
@@ -2,7 +2,7 @@
 # bounce messages back to root
 MAILTO=root
 
-* * * * * http /usr/share/eventum/process_mail_queue.php
+* * * * * http /usr/share/eventum/crons/process_mail_queue.php
 
 # The above line will run the mail queue script every minute. To setup
 # the SMTP server that Eventum should use to send these queued emails,
index 6e6522855d62efe44ce08ef89638d2d22a1c900d..ca42bd2650dd45ce83228f211c897ba138b3f64e 100644 (file)
@@ -2,4 +2,4 @@
 # bounce messages back to root
 MAILTO=root
 
-*/10 * * * * http /usr/share/eventum/monitor.php
+*/10 * * * * http /usr/share/eventum/crons/monitor.php
index 040ab15e990e0f61d78ef15dd0aad4c9b67478e3..39cc57098ce99cf8482380b894db1167305d4c23 100644 (file)
@@ -2,7 +2,7 @@
 # bounce messages back to root
 MAILTO=root
 
-*/10 * * * * http /usr/share/eventum/check_reminders.php
+*/10 * * * * http /usr/share/eventum/crons/check_reminders.php
 
 # It is recommended that you run the reminder cron job every 10 minutes,
 # so it won't flood you with alerts too often, but it would still be
index 2b6d0383e1e0be0caa7532073ed12dfbe6fd4783..cd592f03f2d3acd70821a27f17acffe99e592ce4 100644 (file)
@@ -10,8 +10,8 @@
 %bcond_without order   # with experimental order patch
 
 #define        snap    20060921
-%define        rev             r4030
-%define        rel             2.56
+%define        rev             r4034
+%define        rel             2.58
 #define        _rc             RC3
 
 %define                php_min_version 5.1.2
@@ -28,7 +28,7 @@ Group:                Applications/WWW
 #Source0:      http://mysql.easynet.be/Downloads/eventum/%{name}-%{version}.tar.gz
 # bzr branch lp:eventum eventum && cd eventum && make dist
 Source0:       %{name}-%{version}-dev-%{rev}.tar.gz
-# Source0-md5: a1cb91569360e55a0224bad2ec2113ca
+# Source0-md5: 17c325c4a26d8da3f47eb5dcc24b0fe0
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -92,7 +92,7 @@ Conflicts:    logrotate < 3.7-4
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautopear     'pear(init.php)' 'pear(/etc/webapps/.*)' 'pear(%{_appdir}/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)' 'pear(Services/JSON.php)'
+%define                _noautopear     'pear(../init.php)' 'pear(init.php)' 'pear(/etc/webapps/.*)' 'pear(%{_appdir}/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)' 'pear(Services/JSON.php)'
 
 # exclude optional php dependencies
 %define                _noautophp      'php-gnupg' 'php-hash' 'php-pecl-http' 'php-json' 'php-tk'
@@ -441,6 +441,9 @@ Szczegóły na temat instalacji można przeczytać pod
 %prep
 %setup -q
 
+# GPL v2
+rm docs/COPYING
+
 rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
 rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
 rm upgrade/flush_compiled_templates.php
@@ -654,7 +657,8 @@ fi
 %triggerun -- lighttpd
 %webapp_unregister lighttpd %{_webapp}
 
-%triggerpostun -- %{name} < 2.2-2.54
+%triggerpostun -- %{name} < 2.2-2.57
+# switching eventum->http user
 chgrp http %{_webappdir}/config.php
 chgrp http %{_webappdir}/private_key.php
 chgrp http %{_webappdir}/setup.php
@@ -665,6 +669,19 @@ for a in /etc/cron.d/eventum-*; do
        rm -f $a.rpmtmp
 done
 
+# crontabs moved to crons subdir
+%{__sed} -i -e '
+       s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
+       s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
+       s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
+       s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
+' /etc/cron.d/eventum-*
+
+%triggerpostun mail-download -- %{name}-mail-download < 2.2-2.57
+%triggerpostun reminder -- %{name}-reminder < 2.2-2.57
+%triggerpostun monitor -- %{name}-monitor < 2.2-2.57
+
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc docs/* htdocs/setup/schema.sql mysql-permissions.sql
@@ -682,6 +699,7 @@ done
 %dir %attr(750,root,root) /var/log/archive/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
 
+%dir %{_appdir}/crons
 %{_appdir}/init.php
 %dir %{_appdir}/htdocs
 %{_appdir}/htdocs/*.php
@@ -731,23 +749,23 @@ done
 
 %files mail-queue
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_appdir}/process_mail_queue.php
+%attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
 
 %files mail-download
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_appdir}/download_emails.php
+%attr(755,root,root) %{_appdir}/crons/download_emails.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
 
 %files reminder
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_appdir}/check_reminders.php
+%attr(755,root,root) %{_appdir}/crons/check_reminders.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
 
 %files monitor
 %defattr(644,root,root,755)
 %{_appdir}/lib/eventum/class.monitor.php
-%attr(755,root,root) %{_appdir}/monitor.php
+%attr(755,root,root) %{_appdir}/crons/monitor.php
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
 
 %files route-drafts
This page took 0.090587 seconds and 4 git commands to generate.