]> git.pld-linux.org Git - packages/eventum.git/commitdiff
up to 3.4.2-30-ga83a1da8
authorElan Ruusamäe <glen@delfi.ee>
Sun, 20 May 2018 12:48:57 +0000 (15:48 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 20 May 2018 13:20:22 +0000 (16:20 +0300)
irc bot moved to separate package: eventum-irc-bot

autoload.patch
eventum-irc.init [deleted file]
eventum-irc.sysconfig [deleted file]
eventum.spec

index b76f8d047441944b83519fdd6d75a0a08f3f09cd..183c303a9408328ef887e460e900fe8a32902e3a 100644 (file)
      'd12685060d57775f2bc3adf90c7d62bd' => $baseDir . '/lib/eventum/gettext.php',
 +    'b2b3f01361f3aaeab67fde08ae76446f' => $phpDir. '/Smarty3/plugins/block.t.php',
  );
---- eventum-3.3.4-421-g0643f20c/vendor/composer/autoload_namespaces.php~       2018-04-13 20:24:15.000000000 +0300
-+++ eventum-3.3.4-421-g0643f20c/vendor/composer/autoload_namespaces.php        2018-04-14 03:29:01.691158504 +0300
+--- eventum-3.4.2-27-g4318eb0a/vendor/composer/autoload_namespaces.php~        2018-05-20 15:47:14.000000000 +0300
++++ eventum-3.4.2-27-g4318eb0a/vendor/composer/autoload_namespaces.php 2018-05-20 15:55:55.040415223 +0300
 @@ -3,19 +3,22 @@
  // autoload_namespaces.php @generated by Composer
  
      'SecurityLib' => array($vendorDir . '/ircmaxell/security-lib/lib'),
      'RandomLib' => array($vendorDir . '/ircmaxell/random-lib/lib'),
 -    'PEAR' => array($vendorDir . '/pear/pear_exception'),
--    'Net' => array($vendorDir . '/pear/net_smartirc/Net', $vendorDir . '/pear/net_smtp'),
+-    'Net' => array($vendorDir . '/pear/net_smtp'),
      'Enrise\\' => array($vendorDir . '/enrise/urihelper/src'),
      'Doctrine\\ORM\\' => array($vendorDir . '/doctrine/orm/lib'),
      'Doctrine\\DBAL\\' => array($vendorDir . '/doctrine/dbal/lib'),
      'Doctrine\\Common\\Collections\\' => array($vendorDir . '/doctrine/collections/lib'),
 -    'Auth' => array($vendorDir . '/pear/auth_sasl'),
 -    '' => array($vendorDir . '/pear/pear-core-minimal/src'),
-+      // PEAR deps
++    // PEAR deps
 +    'Auth' => array($pearDir),
 +    'Mail' => array($pearDir),
 +    'Net' => array($pearDir),
diff --git a/eventum-irc.init b/eventum-irc.init
deleted file mode 100755 (executable)
index 6a0aff8..0000000
+++ /dev/null
@@ -1,101 +0,0 @@
-#!/bin/sh
-#
-# chkconfig:   345 29 71
-# description: Eventum IRC Notification Bot
-
-# Source function library
-. /etc/rc.d/init.d/functions
-
-# Get network config
-. /etc/sysconfig/network
-
-PIDFILE=/var/run/eventum/irc_bot.pid
-
-# Get service config
-[ -f /etc/sysconfig/eventum-irc ] && . /etc/sysconfig/eventum-irc
-
-# Check that networking is up.
-if is_yes "${NETWORKING}"; then
-       if [ ! -f /var/lock/subsys/network -a "$1" != stop -a "$1" != status -a "$1" != init ]; then
-               msg_network_down "Eventum IRC Bot"
-               exit 1
-       fi
-else
-       exit 0
-fi
-
-start() {
-       if [ -f /var/lock/subsys/eventum-irc ]; then
-               msg_already_running "Eventum IRC Bot"
-               return
-       fi
-
-       msg_starting "Eventum IRC Bot"
-       start-stop-daemon --start \
-               --exec /usr/share/eventum/bin/irc-bot.php \
-               -m \
-               --pidfile $PIDFILE \
-               --chuid http \
-               --background
-
-       RETVAL=$?
-       if [ $RETVAL -eq 0 ]; then
-               touch /var/lock/subsys/eventum-irc
-               ok
-       else
-               fail
-       fi
-}
-
-stop() {
-       if [ ! -f /var/lock/subsys/eventum-irc ]; then
-               msg_not_running "Eventum IRC Bot"
-               return
-       fi
-
-       msg_stopping "Eventum IRC Bot"
-       if start-stop-daemon --stop --oknodo --pidfile $PIDFILE; then
-               rm -f $PIDFILE /var/lock/subsys/eventum-irc >/dev/null 2>&1
-               ok
-       else
-               fail
-       fi
-}
-
-condrestart() {
-       if [ ! -f /var/lock/subsys/eventum-irc ]; then
-               msg_not_running "Eventum IRC Bot"
-               RETVAL=$1
-               return
-       fi
-
-       stop
-       start
-}
-
-RETVAL=0
-# See how we were called.
-case "$1" in
-  start)
-       start
-       ;;
-  stop)
-       stop
-       ;;
-  restart)
-       stop
-       start
-       ;;
-  force-reload)
-       condrestart 7
-       ;;
-  status)
-       status --pidfile $PIDFILE eventum-irc
-       exit $?
-       ;;
-  *)
-       msg_usage "$0 {start|stop|restart|force-reload|status}"
-       exit 3
-esac
-
-exit $RETVAL
diff --git a/eventum-irc.sysconfig b/eventum-irc.sysconfig
deleted file mode 100644 (file)
index 5336260..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-# $Id$
-# Config file for Eventum IRC Bot
-
-# nice level
-#SERVICE_RUN_NICE_LEVEL="+1"
-
-# give it 16mb memory and 16m stack
-SERVICE_LIMITS="$DEFAULT_SERVICE_LIMITS -m 16384 -s 16384"
index eb380797d8f77c076fcc6ae1a9fa3b78014af53b..fe47684dc8b0b8e262ccb58a7fd1cff145bfb496 100644 (file)
@@ -3,8 +3,8 @@
 %bcond_with    order   # with experimental order patch
 
 %define                rel             1
-%define                subver  6
-%define                githash fb792422
+%define                subver  30
+%define                githash a83a1da8
 %define                php_min_version 5.6.0
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
@@ -15,14 +15,12 @@ License:    GPL v2+
 Group:         Applications/WWW
 #Source0:      https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
 Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
-# Source0-md5: 959b620f33b3ca66729da53c18e539c4
+# Source0-md5: 3b06621384082cd09260641fbd3fa154
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
 Source4:       %{name}-reminder.cron
 Source5:       %{name}-monitor.cron
-Source8:       %{name}-irc.init
-Source9:       %{name}-irc.sysconfig
 Source10:      sphinx.crontab
 Source13:      %{name}-router-postfix.sh
 Source14:      %{name}.logrotate
@@ -267,41 +265,6 @@ przez Postfiksa.
 Opis konfiguracji Postfiksa można znaleźć pod adresem
 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
 
-%package irc
-Summary:       Eventum IRC Notification Bot
-Summary(pl.UTF-8):     IRC-owy bot powiadamiający dla Eventum
-Group:         Applications/WWW
-Requires(post,preun):  /sbin/chkconfig
-Requires:      %{name} = %{version}-%{release}
-Requires:      php(pcntl)
-Requires:      php(sockets)
-Requires:      php-pear-Net_SmartIRC >= 1.1.9
-Requires:      rc-scripts >= 0.4.0.18
-
-%description irc
-The IRC notification bot is a nice feature for remote teams that want
-to handle issues and want to have a quick and easy way to get simple
-notifications. Right now the bot notifies of the following actions:
-- New Issues
-- Blocked emails
-- Issues that got their assignment list changed
-
-NOTE: You will need to manually edit the bot.php script to set your
-appropriate preferences, like IRC server and channel that the bot
-should join.
-
-%description irc -l pl.UTF-8
-IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
-zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
-uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
-następujących zdarzeniach:
-- nowych sprawach
-- zablokowanych listach
-- sprawach, dla których zmieniła się lista powiązań
-
-UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
-kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
-
 %package cli
 Summary:       Eventum command-line interface
 Summary(pl.UTF-8):     Interfejs linii poleceń dla Eventum
@@ -367,7 +330,6 @@ rm config/config.php
 
 rm htdocs/.htaccess.dist
 
-mv config/irc_config{.dist.php,.php}
 rm config/config.dist.php
 
 # cleanup vendor. keep only needed libraries.
@@ -471,9 +433,6 @@ cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
 
-install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
-cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
-
 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
 # postfix router
@@ -498,7 +457,6 @@ for a in \
        errors.log login_attempts.log \
        eventum.log \
        auth.log cli.log \
-       irc_bot_error.log irc_bot_smartirc.log \
 ; do
        test -f /var/log/%{name}/$a && continue
        install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
@@ -537,16 +495,6 @@ if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
        chown root:http %{_webappdir}/{config,private_key,secret_key}.php
 fi
 
-%post irc
-/sbin/chkconfig --add eventum-irc
-%service eventum-irc restart "Eventum IRC Bot"
-
-%preun irc
-if [ "$1" = 0 ]; then
-       %service eventum-irc stop
-       /sbin/chkconfig --del eventum-irc
-fi
-
 %triggerin -- apache1 < 1.3.37-3, apache1-base
 %webapp_register apache %{_webapp}
 
@@ -694,13 +642,6 @@ done
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/router-postfix
 
-%files irc
-%defattr(644,root,root,755)
-%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
-%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
-%attr(755,root,root) %{_appdir}/bin/irc-bot.php
-%attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
-
 %files cli
 %defattr(644,root,root,755)
 %doc cli/eventumrc
This page took 0.091202 seconds and 4 git commands to generate.