]> git.pld-linux.org Git - packages/eventum.git/commitdiff
support tar.xz source
authorElan Ruusamäe <glen@delfi.ee>
Sat, 5 May 2018 18:33:25 +0000 (21:33 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 15 May 2018 08:35:40 +0000 (11:35 +0300)
eventum.spec
update-source.sh

index c43b5e605c6245eece76938940f615b395a667af..eb380797d8f77c076fcc6ae1a9fa3b78014af53b 100644 (file)
@@ -3,19 +3,19 @@
 %bcond_with    order   # with experimental order patch
 
 %define                rel             1
 %bcond_with    order   # with experimental order patch
 
 %define                rel             1
-#define                subver  40
-#define                githash e965ea80
+%define                subver  6
+%define                githash fb792422
 %define                php_min_version 5.6.0
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
 %define                php_min_version 5.6.0
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       3.4.4
+Version:       3.4.2
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2+
 Group:         Applications/WWW
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2+
 Group:         Applications/WWW
-Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 605fe70ac0d069fdbef65a83a89e8526
-#Source0:      https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
+#Source0:      https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
+Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
+# Source0-md5: 959b620f33b3ca66729da53c18e539c4
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
index d956e7a763957b9d16d79fb913f0db8edd3115c5..c006f34a5a270eb5056d6c1dcbefa51fed3f74d8 100755 (executable)
@@ -10,8 +10,11 @@ cd "$dir"
 
 if [ -f "$1" ]; then
        rev=$1
 
 if [ -f "$1" ]; then
        rev=$1
+       version=${rev#eventum-}
+       version=${version%%-*}
        rev=${rev#eventum-*-}
        rev=${rev%.tar.gz}
        rev=${rev#eventum-*-}
        rev=${rev%.tar.gz}
+       rev=${rev%.tar.xz}
 elif [ "$1" ]; then
        rev=$1
 else
 elif [ "$1" ]; then
        rev=$1
 else
@@ -20,7 +23,7 @@ else
        # save this under some local ref, so repeated calls don't have to fetch everything
        git update-ref refs/keep-around/snapshot FETCH_HEAD
        out=$(git show FETCH_HEAD -s)
        # save this under some local ref, so repeated calls don't have to fetch everything
        git update-ref refs/keep-around/snapshot FETCH_HEAD
        out=$(git show FETCH_HEAD -s)
-       tarball=$(echo "$out" | grep -o 'eventum-.*\.tar.gz')
+       tarball=$(echo "$out" | grep -oE 'eventum-.*\.tar.(gz|xz)')
        url="$repo_url/releases/download/snapshot/$tarball"
        test -f "$tarball" || wget -c $url
        exec "$0" "$tarball"
        url="$repo_url/releases/download/snapshot/$tarball"
        test -f "$tarball" || wget -c $url
        exec "$0" "$tarball"
@@ -44,3 +47,5 @@ sed -i -re "
        s/^[#%](define[ \t]+githash[ \t]+)[0-9a-fg]+\$/%\1$githash/
 " $specfile
 ../builder -ncs -5 $specfile
        s/^[#%](define[ \t]+githash[ \t]+)[0-9a-fg]+\$/%\1$githash/
 " $specfile
 ../builder -ncs -5 $specfile
+
+git commit -am "up to $version-$rev"
This page took 0.035109 seconds and 4 git commands to generate.