]> git.pld-linux.org Git - packages/eventum.git/commitdiff
up to git 4b3453d (3.0.0 + 262)
authorElan Ruusamäe <glen@delfi.ee>
Sun, 19 Apr 2015 11:59:47 +0000 (14:59 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 19 Apr 2015 12:22:23 +0000 (15:22 +0300)
- jpgraph replaced with phplot
- scm install fixed by upstream make

eventum-paths.patch
eventum.spec

index 3b116b54a3bd4de351bc35033d3ed0d898a7552e..7bb7cd815c88640139fcc2666e8a92406be8901d 100644 (file)
  
  if (!defined('SPHINX_LOG_PATH')) {
      define('SPHINX_LOG_PATH', '/var/log/sphinx/');
---- eventum-3.0.0/vendor/autoload-dist.php     2014-11-12 18:47:36.000000000 +0200
-+++ eventum-3.0.0/vendor/autoload-dist.php     2015-03-28 20:29:06.247165544 +0200
-@@ -50,11 +50,11 @@
- define('APP_USE_COMPONENTS', false);
+--- eventum-3.0.0-pre1-258-g90ba413/autoload.php~      2015-04-12 21:59:45.000000000 +0300
++++ eventum-3.0.0-pre1-258-g90ba413/autoload.php       2015-04-19 14:20:30.900010382 +0300
+@@ -54,11 +54,11 @@
+  */
  
  if (!defined('APP_PEAR_PATH')) {
--    define('APP_PEAR_PATH', APP_PATH . '/lib/pear');
+-    define('APP_PEAR_PATH', '');
 +    define('APP_PEAR_PATH', '/usr/share/pear');
  }
  
  if (!defined('APP_SPHINXAPI_PATH')) {
--    define('APP_SPHINXAPI_PATH', APP_PATH . '/lib/sphinxapi');
+-    define('APP_SPHINXAPI_PATH', '');
 +    define('APP_SPHINXAPI_PATH', '/usr/share/php');
  }
  
  if (!defined('APP_PHP_GETTEXT_PATH')) {
-@@ -62,7 +62,7 @@
+@@ -66,7 +66,7 @@
  }
  
  if (!defined('APP_SMARTY_PATH')) {
--    define('APP_SMARTY_PATH', APP_PATH . '/lib/Smarty');
+-    define('APP_SMARTY_PATH', '');
 +    define('APP_SMARTY_PATH', '/usr/share/php/Smarty3');
  }
  
- if (!defined('APP_JPGRAPH_PATH')) {
+ // add PEAR to the include path, required by PEAR classes
index 79c19896de6f8082d96c8287886534c97641d982..fce005acb3b829d1b553362e97919adf9dd14a25 100644 (file)
@@ -1,23 +1,22 @@
-# TODO
-# - discard bundled packages (from INSTALL):
-#  - JpGraph 1.5.3 (last GPL version)
 #
 # Conditional build:
 %bcond_with    order   # with experimental order patch
 
-%define                subver  pre1
-%define                rel             0.14
+%define                rel             0.16
+%define                subver  262
+%define                githash 4b3453d
 %define                php_min_version 5.3.3
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
 Version:       3.0.0
-Release:       0.%{subver}.%{rel}
+Release:       1.%{subver}.%{rel}
 License:       GPL v2
 Group:         Applications/WWW
-Source0:       https://github.com/eventum/eventum/releases/download/v%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
-# Source0-md5: 786930171e278f03baa7b174f52e43d0
+#Source0:      https://github.com/eventum/eventum/releases/download/v%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
+Source0:       %{name}-%{version}-%{subver}-g%{githash}.tar.gz
+# Source0-md5: d571072508b7254ed26dd21e5878ed6c
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -47,7 +46,7 @@ Patch107:     %{name}-gettext.patch
 Patch200:      %{name}-fixed-nav.patch
 URL:           http://eventum.mysql.org/
 BuildRequires: /usr/bin/php
-BuildRequires: gettext-tools
+BuildRequires: gettext-devel
 BuildRequires: php(core) >= %{php_min_version}
 BuildRequires: rpm-php-pearprov >= 4.0.2-98
 BuildRequires: rpmbuild(macros) >= 1.654
@@ -90,7 +89,7 @@ Conflicts:    logrotate < 3.8.0
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* jpgraph_dir.php .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
+%define                _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
 
 # exclude optional php dependencies
 %define                _noautophp      php-gnupg php-hash php-pecl-http php-tk
@@ -453,7 +452,7 @@ Sphinx search integration for Eventum.
 This package contains the cron job.
 
 %prep
-%setup -qn %{name}-%{version}%{?subver:-%{subver}}
+%setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
 
 mv docs/examples .
 
@@ -514,14 +513,11 @@ install -d \
        $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
        $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
-%{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
+%{__make} install-eventum install-cli install-irc install-scm install-localization \
        sysconfdir=%{_webappdir} \
        localedir=%{_localedir} \
        DESTDIR=$RPM_BUILD_ROOT
 
-cp -p scm/helpers.php $RPM_BUILD_ROOT%{_sbindir}
-install -p scm/eventum-git-hook.php  $RPM_BUILD_ROOT%{_sbindir}/eventum-git-hook
-
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
@@ -671,6 +667,7 @@ done
 %dir %{_appdir}/bin
 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
 
+%{_appdir}/autoload.php
 %{_appdir}/init.php
 %dir %{_appdir}/htdocs
 %{_appdir}/htdocs/*.php
@@ -698,7 +695,6 @@ done
 
 %dir %{_appdir}/lib
 %{_appdir}/lib/eventum
-%{_appdir}/lib/jpgraph
 %exclude %{_appdir}/lib/eventum/class.monitor.php
 
 %{_appdir}/vendor
This page took 0.048855 seconds and 4 git commands to generate.