]> git.pld-linux.org Git - packages/eventum.git/commitdiff
- up to r3934
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 12 Oct 2009 19:48:56 +0000 (19:48 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    eventum-order.patch -> 1.24
    eventum-paths.patch -> 1.46
    eventum.spec -> 1.305

eventum-order.patch
eventum-paths.patch
eventum.spec

index 14c6fd3d26a8432c6b31c98a5df22b14f1baba22..ab398d328437a9f12cb16e84ad5fa2979b3873ae 100644 (file)
 +        }
 +    }
 +}
---- eventum-2.2/htdocs/ajax/update.php 1970-01-01 02:00:00.000000000 +0200
-+++ eventum-2.2-order/htdocs/ajax/update.php   2009-10-12 22:10:36.439185157 +0300
-@@ -0,0 +1,38 @@
-+<?
-+require_once(dirname(__FILE__) . '/../init.php');
-+require_once(APP_INC_PATH . "class.auth.php");
-+require_once(APP_INC_PATH . "class.issue.php");
-+
-+// check login
-+if (!Auth::hasValidCookie(APP_COOKIE)) {
-+    exit;
-+}
-+
-+if (!is_numeric($_POST['issueID'])) {
-+    exit;
-+}
+--- eventum-2.2/htdocs/css/style.css~  2009-10-12 22:27:13.000000000 +0300
++++ eventum-2.2/htdocs/css/style.css   2009-10-12 22:28:31.402712101 +0300
+@@ -176,3 +176,22 @@
+ .custom_field {
+     cursor: pointer;
+ }
 +
-+switch ($_POST['fieldName']) {
-+  case 'expected_resolution_date':
-+    $day = (int)$_POST['day'];
-+    $month = (int)$_POST['month'];
-+      $year = (int)$_POST['year'];
-+      if ($day == 0 && $month == 1 && $year == 0) {
-+              // clear button
-+              $date = null;
-+      } else {
-+              $date = sprintf('%04d-%02d-%02d', $year, $month, $day);
-+      }
-+      if (Issue::updateField($_POST['issueID'], $_POST['fieldName'], $date) !== -1) {
-+              if (!is_null($date)) {
-+            echo Date_Helper::getSimpleDate(sprintf('%04d-%02d-%02d', $year, $month, $day), false);
-+              }
-+    } else {
-+        echo 'update failed';
-+    }
-+    exit;
-+  break;
-+  default:
-+      die('object type not supported');
-+  break;
-+}
---- eventum-2.2/htdocs/css/style.css   2009-09-14 18:07:55.000000000 +0300
-+++ eventum-2.2-order/htdocs/css/style.css     2009-10-12 22:10:36.439185157 +0300
-@@ -172,4 +172,22 @@
-     font-size: 70%;
-     font-family: Verdana, Arial, Helvetica, sans-serif;
-     padding: 10px;
--}
-\ No newline at end of file
-+}
 +.tDnD_whileDrag td {
 +    background-color: #ffffdd;
 +}
 +    background-repeat: no-repeat;
 +    background-position: center center;
 +}
---- eventum-2.2/htdocs/js/global.js    2009-09-14 18:07:55.000000000 +0300
-+++ eventum-2.2-order/htdocs/js/global.js      2009-10-12 22:10:36.439185157 +0300
-@@ -798,4 +798,44 @@
-         firstDay: user_prefs.week_firstday
-     });
- });
-+
-+$(document).ready(function() {
-+    // dialog type calender isn't working in Konqueror beacuse it's not a supported browser for either jQuery or jQuery UI
-+    // http://groups.google.com/group/jquery-ui/browse_thread/thread/ea61238c34cb5f33/046837b02fb90b5c
-+    if (navigator.appName != 'Konqueror') {
-+        $(".inline_date_pick").click(function() {
-+        var masterObj = this;
-+        var masterObjPos = $(masterObj).offset();
-+        // offset gives uses top and left but datepicker needs pageX and pageY
-+        var masterObjPos = {pageX: masterObjPos.left, pageY: masterObjPos.top};
-+        $(this).datepicker(
-+            // we use dialog type calender so we won't haveto have a hidden element on the page
-+            'dialog',
-+            // selected date
-+            masterObj.innerHTML,
-+            // onclick handler
-+            function (date, dteObj) {
-+                fieldName = masterObj.id.substr(0,masterObj.id.indexOf('|'));
-+                issueID = masterObj.id.substr(masterObj.id.indexOf('|')+1);
-+                              if (date == '') {
-+                                      // clear button
-+                                      dteObj.selectedDay = 0;
-+                                      dteObj.selectedMonth = 0;
-+                                      dteObj.selectedYear = 0;
-+                              }
-+                              //alertProperties(date);
-+                $.post("/ajax/update.php", {fieldName: fieldName, issueID: issueID, day: dteObj.selectedDay, month: (dteObj.selectedMonth+1), year: dteObj.selectedYear}, function(data) {
-+                    masterObj.innerHTML = data;
-+                }, "text");
-+            },
-+            // config
-+            {dateFormat: 'dd M yy', duration: ""},
-+            // position of the datepicker calender - taken from div's offset
-+            masterObjPos
-+        );
-+        return false;
-+        });
-+    }
-+});
-+
- //-->
 --- eventum-2.2/htdocs/js/jquery/jquery.tablednd.js    1970-01-01 02:00:00.000000000 +0200
 +++ eventum-2.2-order/htdocs/js/jquery/jquery.tablednd.js      2009-10-12 22:10:36.435851675 +0300
 @@ -0,0 +1,382 @@
            <td align="{$column.align|default:'center'}" class="default_white" nowrap {if $column.width != ''}width="{$column.width}"{/if}>
              {if $field_name == 'iss_summary'}
              <table cellspacing="0" cellpadding="1" width="100%">
-@@ -232,20 +261,21 @@
+@@ -268,8 +268,9 @@
            {/if}
            {/foreach}
          </tr>
            {if $current_role > $roles.developer}
            <td bgcolor="{$list[i].status_color}" width="1%" class="default" align="center"><input type="checkbox" name="item[]" value="{$list[i].iss_id}" onchange="toggleBulkUpdate();"></td>
            {/if}
-           {foreach from=$columns item=column key=field_name}
-           {if $field_name == 'custom_fields'}
-             {foreach from=$list[i].custom_field key=fld_id item=fld_value}
--                <td bgcolor="{$list[i].status_color}" align="{$column.align|default:'center'}" class="default">
--                  {$fld_value|formatCustomValue:$fld_id:$list[i].iss_id}
-+                <td bgcolor="{$list[i].status_color}" align="{$column.align|default:'center'}" class="default custom_field" onclick="return updateCustomFields({$list[i].iss_id});">
-+                    {$fld_value|formatCustomValue:$fld_id:$list[i].iss_id}
+@@ -280,8 +281,8 @@
+                   {$fld_value|formatCustomValue:$fld_id:$list[i].iss_id}
                  </td>
                {/foreach}
 -          {else}
              {if $field_name == 'iss_id'}
                <a href="view.php?id={$list[i].iss_id}" class="link" title="{t}view issue details{/t}">{$list[i].iss_id}</a>
              {elseif $field_name == 'pri_rank'}
-@@ -279,7 +309,7 @@
-             {elseif $field_name == 'iss_percent_complete'}
-               {$list[i].iss_percent_complete|escape:"html"}%
-             {elseif $field_name == 'iss_expected_resolution_date'}
--              {$list[i].iss_expected_resolution_date|escape:"html"}
-+              <div class="inline_date_pick" id="expected_resolution_date|{$list[i].iss_id}">{$list[i].iss_expected_resolution_date|escape:"html"}&nbsp;</div>
-             {elseif $field_name == 'iss_summary'}
-               <a href="view.php?id={$list[i].iss_id}" class="link" title="{t}view issue details{/t}">{$list[i].iss_summary|escape:"html"}</a>
-               {if $list[i].redeemed}
 @@ -288,6 +318,8 @@
                {if $list[i].iss_private == 1}
                    <b>[Private]</b>
 +</script>
  {include file="app_info.tpl.html"}
  {include file="footer.tpl.html"}
---- eventum-2.2/upgrade/patches/04_isu_order.php       1970-01-01 02:00:00.000000000 +0200
-+++ eventum-2.2-order/upgrade/patches/04_isu_order.php 2009-10-12 22:10:36.439185157 +0300
-@@ -0,0 +1,15 @@
-+<?php
-+
-+function db_patch_4() {
-+      $stmts = array();
-+
-+      $columns = db_getCol('DESC %TABLE_PREFIX%issue_user');
-+      if (in_array('isu_order', $columns)) {
-+              return $stmts;
-+      }
-+
-+      $stmts[] = "ALTER TABLE %TABLE_PREFIX%issue_user ADD isu_order int(11) NOT NULL DEFAULT '0' AFTER isu_assigned_date, ADD INDEX isu_order (isu_order)";
-+      $stmts[] = "UPDATE %TABLE_PREFIX%issue_user set isu_order=isu_iss_id";
-+
-+      return $stmts;
-+}
---- eventum-2.2/upgrade/update-database.php    2009-09-14 18:07:55.000000000 +0300
-+++ eventum-2.2-order/upgrade/update-database.php      2009-10-12 22:10:36.439185157 +0300
-@@ -73,6 +73,7 @@
-               1 => '01_notes.php',
-               2 => '02_usr_alias.php',
-               3 => '03_prj_mail_aliases.php',
-+              4 => '04_isu_order.php',
-       );
-       // sanity check. check that the version table exists.
index c00c94b4fe80a34d197e19ba787084c1d6656fa2..1951487b13513981d49bccdb4a3044c74db09705 100644 (file)
  
  if (defined('APP_PEAR_PATH')) {
      set_include_path(APP_PEAR_PATH . PATH_SEPARATOR . get_include_path());
---- trunk/init.php~    2009-06-27 17:31:32.000000000 +0300
-+++ trunk/init.php     2009-06-27 17:33:35.745565456 +0300
-@@ -26,7 +26,7 @@
+--- eventum-2.2/init.php~      2009-10-12 22:40:04.000000000 +0300
++++ eventum-2.2/init.php       2009-10-12 22:40:41.619219457 +0300
+@@ -27,7 +27,7 @@
  // | Authors: Elan Ruusamäe <glen@delfi.ee>                               |
  // +----------------------------------------------------------------------+
  
--if (!file_exists(dirname(__FILE__) . '/config/config.php')) {
-+if (!file_exists('/etc/webapps/eventum/config.php')) {
+-if (!file_exists(dirname(__FILE__) . '/config/config.php') || !filesize(dirname(__FILE__) . '/config/config.php')) {
++if (!file_exists('/etc/webapps/eventum/config/config.php') || !filesize('/etc/webapps/eventum/config/config.php')) {
      Header('Location: setup/');
-     exit;
+     exit(0);
  }
 @@ -46,7 +46,7 @@
  
  }
  
  if (!defined('APP_ROUTED_MAILS_SAVEDIR')) {
---- trunk/htdocs/setup/index.php~      2009-06-27 17:34:22.000000000 +0300
-+++ trunk/htdocs/setup/index.php       2009-06-27 17:35:07.108898271 +0300
+--- eventum-2.2/htdocs/setup/index.php~        2009-10-12 22:41:28.000000000 +0300
++++ eventum-2.2/htdocs/setup/index.php 2009-10-12 22:43:06.524225893 +0300
 @@ -42,14 +42,14 @@
  define('APP_PATH', realpath(dirname(__FILE__) . '/../..'));
  define('APP_INC_PATH', APP_PATH . '/lib/eventum');
- define('APP_PEAR_PATH', APP_INC_PATH . '/lib/pear');
--define('APP_SMARTY_PATH', APP_INC_PATH . '/lib/Smarty');
+ define('APP_PEAR_PATH', APP_PATH . '/lib/pear');
+-define('APP_SMARTY_PATH', APP_PATH . '/lib/Smarty');
 -define('APP_CONFIG_PATH', APP_PATH . '/config');
 +define('APP_SMARTY_PATH', '/usr/share/php/Smarty');
 +define('APP_CONFIG_PATH', '/etc/webapps/eventum');
  
  header('Content-Type: text/html; charset=' . APP_CHARSET);
  
-@@ -192,10 +192,6 @@
-     if (ini_get('file_uploads') != "1") {
-         $errors[] = "The 'file_uploads' directive needs to be enabled in your PHP.INI file in order for Eventum to work properly.";
+@@ -241,10 +241,6 @@
+         $warnings[] = "The Multibyte String Functions extension is not enabled in your PHP installation. For localization to work properly " .
+             "you need to install this extension. If you do not install this extension localization will be disabled.";
      }
 -    $error = checkPermissions(APP_CONFIG_PATH, "Directory '" . APP_CONFIG_PATH . "'", TRUE);
 -    if (!empty($error)) {
 -        $errors[] = $error;
 -    }
-     $error = checkPermissions(APP_LOCKS_PATH, "Directory '" . APP_LOCKS_PATH . "'", TRUE);
+     $error = checkPermissions(APP_SETUP_FILE, "File '" . APP_SETUP_FILE. "'");
      if (!empty($error)) {
          $errors[] = $error;
 @@ -329,10 +325,6 @@
index 57bf903929bebd01c37194564c3ed5cee72fc5d4..7dbe8a2673f661a2ab2c01df23028e9efaac2a01 100644 (file)
@@ -10,8 +10,8 @@
 %bcond_without order   # with experimental order patch
 
 #define        snap    20060921
-%define        rev             r3903
-%define        rel             2.29
+%define        rev             r3934
+%define        rel             2.30
 #define        _rc             RC3
 
 %include       /usr/lib/rpm/macros.php
@@ -26,8 +26,8 @@ Group:                Applications/WWW
 #Source0:      http://eventum.mysql.org/downloads/eventum-2.0.RC3.tar.gz
 #Source0:      http://mysql.easynet.be/Downloads/eventum/%{name}-%{version}.tar.gz
 # bzr branch lp:eventum eventum && tar -cjf eventum.tar.bz2 --exclude=.bzr --exclude=.bzrignore eventum
-Source0:       eventum-%{version}-dev-%{rev}.tar.gz
-# Source0-md5: 30160fd1733dc845e5242af878bfe36f
+Source0:       %{name}-%{version}-dev-%{rev}.tar.gz
+# Source0-md5: 2913cf48467a40785c26dbe4aacc7e68
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -82,6 +82,7 @@ Requires:     php-pear-Net_UserAgent_Detect
 Requires:      php-pear-PEAR-core
 Requires:      php-pear-Text_Diff
 Requires:      php-pear-XML_RPC
+Requires:      php-session
 Requires:      smarty-gettext
 Requires:      webapps
 Requires:      webserver(access)
@@ -265,19 +266,19 @@ Requires: eventum(router)
 
 %description route-drafts
 The draft routing feature is used to automatically associate a thread
-of drafts into an Eventum issue. By setting up Postfix
-to deliver emails sent to a specific address (usually
-draft-<number>@<domain>) to the above script, users are able to send
-drafts written in their mail client to be stored in Eventum. These
-drafts will NOT broadcasted to the notification list.
+of drafts into an Eventum issue. By setting up Postfix to deliver
+emails sent to a specific address (usually draft-<number>@<domain>) to
+the above script, users are able to send drafts written in their mail
+client to be stored in Eventum. These drafts will NOT broadcasted to
+the notification list.
 
 %description route-drafts -l pl.UTF-8
 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
-problemem w Eventum. Ustawiając Postfiksa, aby
-dostarczał pocztę wysłaną na podany adres (zwykle
-draft-<liczba>@<domena>) do tego skryptu umożliwia się użytkownikom
-wysyłanie szkiców napisanych w ich kliencie pocztowym do zapisania w
-Eventum. Szkice te NIE będą wysyłane na listę powiadomień.
+problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
+wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
+skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
+kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
+na listę powiadomień.
 
 %package route-emails
 Summary:       Eventum Email Routing
@@ -288,17 +289,17 @@ Requires: eventum(router)
 
 %description route-emails
 The email routing feature is used to automatically associate a thread
-of emails into an Eventum issue. By setting up Postfix
-to deliver emails sent to a specific address (usually
-issue-<number>@<domain>) to the above script, users are able to use
-their email clients to reply to emails coming from Eventum, and those
-replies will be automatically associated with the issue and
-broadcasted to the entire notification list.
+of emails into an Eventum issue. By setting up Postfix to deliver
+emails sent to a specific address (usually issue-<number>@<domain>) to
+the above script, users are able to use their email clients to reply
+to emails coming from Eventum, and those replies will be automatically
+associated with the issue and broadcasted to the entire notification
+list.
 
 %description route-emails -l pl.UTF-8
 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
-wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet
-Postfiksa, aby dostarczał listy wysyłane na pewien adres (zwykle
+wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
+aby dostarczał listy wysyłane na pewien adres (zwykle
 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
 używać klientów pocztowych do odpowiadania na listy przychodzące z
 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
@@ -313,17 +314,17 @@ Requires: eventum(router)
 
 %description route-notes
 The note routing feature is used to automatically associate a thread
-of notes into an Eventum issue. By setting up Postfix
-to deliver emails sent to a specific address (usually
-note-<number>@<domain>) to the above script, users are able to use
-their email clients to reply to internal notes coming from Eventum,
-and those replies will be automatically associated with the issue and
-broadcasted to the notification list staff members.
+of notes into an Eventum issue. By setting up Postfix to deliver
+emails sent to a specific address (usually note-<number>@<domain>) to
+the above script, users are able to use their email clients to reply
+to internal notes coming from Eventum, and those replies will be
+automatically associated with the issue and broadcasted to the
+notification list staff members.
 
 %description route-notes -l pl.UTF-8
 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
-wątku notatek ze sprawą w Eventum. Po ustawieniu
-Postfiksa, aby dostarczał listy wysyłane na pewien adres (zwykle
+wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
+dostarczał listy wysyłane na pewien adres (zwykle
 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
@@ -705,7 +706,7 @@ fi
 %attr(751,root,root) %dir %{_sysconfdir}
 %dir %{_libdir}
 %dir %{_appdir}
-%attr(755,root,root) %dir /var/lib/%{name}
+%dir /var/lib/%{name}
 # saved mail copies
 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
This page took 0.126255 seconds and 4 git commands to generate.