]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
up to 3.4.3
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 #define         subver  40
7 #define         githash e965ea80
8 %define         php_min_version 5.6.0
9 Summary:        Eventum Issue / Bug tracking system
10 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
11 Name:           eventum
12 Version:        3.4.3
13 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
14 License:        GPL v2+
15 Group:          Applications/WWW
16 Source0:        https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
17 # Source0-md5:  5f829fdaf6db53e44780a4f23dd4fd69
18 #Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
19 Source1:        %{name}-apache.conf
20 Source2:        %{name}-mail-queue.cron
21 Source3:        %{name}-mail-download.cron
22 Source4:        %{name}-reminder.cron
23 Source5:        %{name}-monitor.cron
24 Source8:        %{name}-irc.init
25 Source9:        %{name}-irc.sysconfig
26 Source10:       sphinx.crontab
27 Source13:       %{name}-router-postfix.sh
28 Source14:       %{name}.logrotate
29 Source15:       %{name}-lighttpd.conf
30 Source16:       http://www.isocra.com/images/updown2.gif
31 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
32 Source17:       %{name}.tmpfiles
33 Patch2:         %{name}-order.patch
34 #Patch3:                group-users.patch
35 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
36 # packaging patches that probably never go upstream
37 Patch100:       %{name}-paths.patch
38 Patch107:       %{name}-gettext.patch
39 Patch108:       autoload.patch
40 # some tests
41 Patch200:       %{name}-fixed-nav.patch
42 URL:            https://wiki.github.com/eventum/eventum/
43 BuildRequires:  gettext-tools
44 BuildRequires:  rpmbuild(macros) >= 1.654
45 BuildRequires:  sed >= 4.0
46 Requires(post): sudo
47 Requires(postun):       /usr/sbin/groupdel
48 Requires(postun):       /usr/sbin/userdel
49 Requires(pre):  /bin/id
50 Requires(pre):  /usr/bin/getgid
51 Requires(pre):  /usr/sbin/groupadd
52 Requires(pre):  /usr/sbin/useradd
53 Requires:       fonts-TTF-RedHat-liberation
54 Requires:       php(core) >= %{php_min_version}
55 Requires:       php(filter)
56 Requires:       php(iconv)
57 Requires:       php(imap)
58 Requires:       php(json)
59 Requires:       php(mbstring)
60 Requires:       php(pcre)
61 Requires:       php(pdo_mysql)
62 Requires:       php(session)
63 Requires:       php-Smarty >= 3.1
64 Requires:       php-Smarty-plugin-gettext
65 Requires:       php-ZendFramework-Config >= 2.4
66 Requires:       php-ZendFramework-Loader >= 2.4
67 Requires:       php-ZendFramework-Mail >= 2.4.13-2
68 Requires:       php-ZendFramework-Mime >= 2.4
69 Requires:       php-ZendFramework-ServiceManager >= 2.4
70 Requires:       php-ZendFramework-Validator >= 2.4
71 Requires:       php-monolog >= 1.17.2
72 Requires:       php-pear-Math_Stats
73 Requires:       php-pear-Net_SMTP
74 Requires:       php-pear-Net_Socket
75 Requires:       php-pear-Net_URL
76 Requires:       php-pear-PEAR-core
77 Requires:       php-pear-Text_Diff
78 Requires:       php-psr-Log >= 1.0.0-2
79 Requires:       phplot >= 5.8.0
80 Requires:       webapps
81 Requires:       webserver(access)
82 Requires:       webserver(alias)
83 Requires:       webserver(indexfile)
84 Requires:       webserver(php) >= 4.2.0
85 Suggests:       localedb
86 Suggests:       php(mcrypt)
87 Suggests:       php(openssl)
88 Suggests:       php-pear-Net_POP3
89 Suggests:       webserver(setenv)
90 Provides:       group(eventum)
91 Provides:       user(eventum)
92 Obsoletes:      eventum-base < 3.0.3-1.305
93 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
94 Obsoletes:      eventum-route-emails < 3.0.8-1.1
95 Obsoletes:      eventum-route-notes < 3.0.8-1.1
96 Conflicts:      logrotate < 3.8.0
97 BuildArch:      noarch
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         _libdir         %{_prefix}/lib/%{name}
101 %define         _appdir         %{_datadir}/%{name}
102 %define         _smartydir      %{php_data_dir}/Smarty
103 %define         _webapps        /etc/webapps
104 %define         _webapp         %{name}
105 %define         _webappdir      %{_webapps}/%{_webapp}
106 %define         _sysconfdir     /etc/%{name}
107
108 %description
109 Eventum is a user-friendly and flexible issue tracking system that can
110 be used by a support department to track incoming technical support
111 requests, or by a software development team to quickly organize tasks
112 and bugs.
113
114 %description -l pl.UTF-8
115 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
116 może być używany przez dział obsługi do śledzenia przychodzących żądań
117 obsługi technicznej albo przez zespół tworzący oprogramowanie do
118 szybkiej organizacji zadań i błędów.
119
120 %package setup
121 Summary:        Eventum setup package
122 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
123 Group:          Applications/WWW
124 Requires:       %{name} = %{version}-%{release}
125
126 %description setup
127 Install this package to configure initial Eventum installation. You
128 should uninstall this package when you're done, as it considered
129 insecure to keep the setup files in place.
130
131 %description setup -l pl.UTF-8
132 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
133 pierwszej instalacji. Potem należy go odinstalować, jako że
134 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
135
136 %package doc
137 Summary:        Eventum documentation and Wiki
138 Group:          Documentation
139
140 %description doc
141 Eventum documentation and copy of Wiki.
142
143 %package mail-queue
144 Summary:        Eventum mail queue process
145 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
146 Group:          Applications/WWW
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       crondaemon
149
150 %description mail-queue
151 Beginning with the first release of Eventum, emails are not directly
152 sent out from the various scripts, but rather added to a mail queue
153 table that is processed by a cron job. If an email cannot be sent, it
154 will be marked as such in the mail queue log, and the cron job script
155 will re-try to send it again the next time it runs.
156
157 This package contains the cron job.
158
159 %description mail-queue -l pl.UTF-8
160 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
161 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
162 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
163 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
164 następnym razem.
165
166 Ten pakiet zawiera zadanie dla crona.
167
168 %package mail-download
169 Summary:        Eventum email download
170 Summary(pl.UTF-8):      Ściąganie poczty Eventum
171 Group:          Applications/WWW
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       crondaemon
174
175 %description mail-download
176 In order for Eventum's email integration feature to work, you need to
177 setup a cron job to run the script every so often.
178
179 This package contains the cron job.
180
181 %description mail-download -l pl.UTF-8
182 Aby integracja poczty elektronicznej w Eventum działała, trzeba
183 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
184 często.
185
186 Ten pakiet zawiera zadanie dla crona.
187
188 %package reminder
189 Summary:        Eventum Reminder System
190 Summary(pl.UTF-8):      System przypominania dla Eventum
191 Group:          Applications/WWW
192 Requires:       %{name} = %{version}-%{release}
193 Requires:       crondaemon
194
195 %description reminder
196 The reminder system was designed with the objective as serving as a
197 safe net for issues that need attention. Depending on what
198 configuration you create, you may have several reminders (or alerts)
199 be sent out whenever an issue needs attention, for whatever parameter
200 you may deem necessary.
201
202 This package contains the cron job.
203
204 %description reminder -l pl.UTF-8
205 System przypominania został zaprojektowany tak, aby służył jako
206 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
207 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
208 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
209 uważać za potrzebny.
210
211 Ten pakiet zawiera zadanie dla crona.
212
213 %package monitor
214 Summary:        Eventum Heartbeat Monitor
215 Summary(pl.UTF-8):      Monitor życia dla Eventum
216 Group:          Applications/WWW
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       crondaemon
219 Requires:       php(posix)
220
221 %description monitor
222 The heartbeat monitor is a feature designed for the administrator that
223 wants to be alerted whenever a common problem in Eventum is detected,
224 like the database server not being available anymore, or maybe when
225 the recommended permissions for certain configuration files are
226 changed.
227
228 Please note that before running the heartbeat monitor, you may need to
229 customize some of the checks to be appropriate for your own system,
230 particularly the permission and file checks on
231 Monitor::checkConfiguration().
232
233 This package contains the cron job.
234
235 %description monitor -l pl.UTF-8
236 Monitor życia to funkcjonalność zaprojektowana dla administratora
237 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
238 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
239 do plików konfiguracyjnych.
240
241 Należy zauważyć, że przed uruchomieniem tego monitora może być
242 konieczne dostosowanie niektórych testów do systemu, w szczególności
243 testów uprawnień i plików w Monitor::checkConfiguration().
244
245 Ten pakiet zawiera zadanie dla crona.
246
247 %package router-postfix
248 Summary:        Eventum Mail Routing - Postfix
249 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
250 Group:          Applications/Mail
251 Requires:       %{name} = %{version}-%{release}
252 Requires:       postfix
253 Provides:       eventum(router)
254 Obsoletes:      eventum(router)
255
256 %description router-postfix
257 This package provides way of routing notes and emails back to Eventum
258 via Postfix.
259
260 The Postfix configuration instructions you can find from
261 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
262
263 %description router-postfix -l pl.UTF-8
264 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
265 przez Postfiksa.
266
267 Opis konfiguracji Postfiksa można znaleźć pod adresem
268 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
269
270 %package irc
271 Summary:        Eventum IRC Notification Bot
272 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
273 Group:          Applications/WWW
274 Requires(post,preun):   /sbin/chkconfig
275 Requires:       %{name} = %{version}-%{release}
276 Requires:       php(pcntl)
277 Requires:       php(sockets)
278 Requires:       php-pear-Net_SmartIRC >= 1.1.9
279 Requires:       rc-scripts >= 0.4.0.18
280
281 %description irc
282 The IRC notification bot is a nice feature for remote teams that want
283 to handle issues and want to have a quick and easy way to get simple
284 notifications. Right now the bot notifies of the following actions:
285 - New Issues
286 - Blocked emails
287 - Issues that got their assignment list changed
288
289 NOTE: You will need to manually edit the bot.php script to set your
290 appropriate preferences, like IRC server and channel that the bot
291 should join.
292
293 %description irc -l pl.UTF-8
294 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
295 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
296 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
297 następujących zdarzeniach:
298 - nowych sprawach
299 - zablokowanych listach
300 - sprawach, dla których zmieniła się lista powiązań
301
302 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
303 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
304
305 %package cli
306 Summary:        Eventum command-line interface
307 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
308 Group:          Applications/WWW
309 Requires:       php(core) >= %{php_min_version}
310 Requires:       php(phar)
311
312 %description cli
313 The Eventum command-line interface allows you to access most of the
314 features of the web interface straight from your command shell.
315
316 %description cli -l pl.UTF-8
317 Interfejs linii poleceń Eventum pozwala na dostęp do większości
318 funkcji interfejsu WWW prosto z linii poleceń powłoki.
319
320 %package sphinx
321 Summary:        Eventum Sphinx Search
322 Group:          Applications/WWW
323 Requires:       %{name} = %{version}-%{release}
324 Requires:       crondaemon
325 Requires:       sphinx
326
327 %description sphinx
328 Sphinx search integration for Eventum.
329
330 This package contains the cron job.
331
332 %prep
333 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
334
335 mv docs/examples .
336
337 # bug fixes / features
338 %{?with_order:%patch2 -p1}
339 #%patch3 -p0
340 #%patch4 -p1
341
342 %{?with_order:cp -p %{SOURCE16} htdocs/images}
343
344 #%patch200 -p1
345
346 # produce default sphinx config
347 # must be run before paths.patch
348 %if 0
349 cat <<'EOF' > config/config.php
350 <?php
351 define('APP_SQL_DBTYPE', 'mysql');
352 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
353 define('APP_SQL_DBPORT', 3306);
354 define('APP_SQL_DBNAME', 'eventum');
355 define('APP_SQL_DBUSER', 'mysql');
356 define('APP_SQL_DBPASS', '');
357 define('APP_TABLE_PREFIX', 'eventum_');
358 EOF
359 php config/sphinx.conf.php > config/sphinx.conf
360 rm config/config.php
361 %endif
362
363 # packaging
364 %patch100 -p1
365 %patch107 -p1
366 %patch108 -p1
367
368 rm htdocs/.htaccess.dist
369
370 mv config/irc_config{.dist.php,.php}
371 rm config/config.dist.php
372
373 # cleanup vendor. keep only needed libraries.
374 # (the rest are packaged with system packages)
375 mv vendor vendor.dist
376 vendor() {
377         local path dir
378         for path; do
379                 dir=$(dirname $path)
380                 test -d vendor/$dir || mkdir -p vendor/$dir
381                 mv vendor.dist/$path vendor/$path
382         done
383 }
384 vendor autoload.php
385 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
386 vendor composer/ClassLoader.php
387 vendor ircmaxell/{random-lib,security-lib}
388 vendor defuse/php-encryption
389 vendor willdurand/email-reply-parser
390 vendor theorchard/monolog-cascade
391 vendor malkusch/lock
392 vendor phpxmlrpc/phpxmlrpc
393 vendor robmorgan/phinx
394 vendor mnapoli/silly
395 vendor psr/container
396 vendor phlib/flysystem-pdo
397 vendor league/flysystem
398 vendor php-di/invoker
399 vendor container-interop/container-interop
400 vendor symfony/config
401 vendor symfony/console
402 vendor symfony/debug
403 vendor symfony/event-dispatcher
404 vendor symfony/filesystem
405 vendor symfony/http-foundation
406 vendor symfony/options-resolver
407 vendor symfony/serializer
408 vendor symfony/yaml
409 vendor symfony/ldap
410 vendor paragonie/random_compat
411 vendor symfony/polyfill-php70
412 vendor symfony/polyfill-intl-normalizer
413 vendor glen/filename-normalizer
414 vendor doctrine/annotations
415 vendor doctrine/cache
416 vendor doctrine/collections
417 vendor doctrine/common
418 vendor doctrine/dbal
419 vendor doctrine/inflector
420 vendor doctrine/instantiator
421 vendor doctrine/lexer
422 vendor doctrine/orm
423 vendor cebe/markdown
424 vendor enrise/urihelper
425
426 # remove backups from patching as we use globs to package files to buildroot
427 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
428
429 %build
430 %{__make} -C localization
431
432 %install
433 rm -rf $RPM_BUILD_ROOT
434 install -d \
435         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
436         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
437         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
438         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
439         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
440         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
441
442 %{__make} install-eventum install-cli install-localization \
443         sysconfdir=%{_webappdir} \
444         localedir=%{_localedir} \
445         DESTDIR=$RPM_BUILD_ROOT
446
447 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
448
449 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
450
451 # unsupported locale
452 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
453
454 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
455 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
456
457 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
458
459 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
460 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
461 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
462 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
463
464 install -d $RPM_BUILD_ROOT/etc/sphinx
465 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
466 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
467
468 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
469 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
470 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
471 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
472 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
473
474 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
475 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
476
477 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
478
479 # postfix router
480 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
481
482 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
483
484 %find_lang %{name}
485
486 %clean
487 rm -rf $RPM_BUILD_ROOT
488
489 %pre
490 %groupadd -g 146 %{name}
491 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
492 %addusertogroup http %{name}
493
494 %post
495 # create empty ghost files
496 # these permissions ensure the logs are write only
497 for a in \
498         errors.log login_attempts.log \
499         eventum.log \
500         auth.log cli.log \
501         irc_bot_error.log irc_bot_smartirc.log \
502 ; do
503         test -f /var/log/%{name}/$a && continue
504         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
505 done
506
507 # run database update if configured
508 test -s %{_webappdir}/config.php && \
509 sudo -H -u http -- %{_appdir}/bin/upgrade.php || :
510
511 # nuke Smarty templates cache after upgrade
512 rm -f /var/cache/eventum/*.php
513
514 # Restart webserver on upgrade to get .mo translations reloaded.
515 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
516 %php_webserver_restart
517
518 %preun
519 if [ "$1" = "0" ]; then
520         # nuke cache
521         rm -f /var/cache/eventum/*.php 2>/dev/null || :
522 fi
523
524 %postun
525 if [ "$1" = "0" ]; then
526         %userremove %{name}
527         %groupremove %{name}
528 fi
529
530 %post setup
531 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
532 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
533
534 %postun setup
535 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
536         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
537         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
538 fi
539
540 %post irc
541 /sbin/chkconfig --add eventum-irc
542 %service eventum-irc restart "Eventum IRC Bot"
543
544 %preun irc
545 if [ "$1" = 0 ]; then
546         %service eventum-irc stop
547         /sbin/chkconfig --del eventum-irc
548 fi
549
550 %triggerin -- apache1 < 1.3.37-3, apache1-base
551 %webapp_register apache %{_webapp}
552
553 %triggerun -- apache1 < 1.3.37-3, apache1-base
554 %webapp_unregister apache %{_webapp}
555
556 %triggerin -- apache < 2.2.0, apache-base
557 %webapp_register httpd %{_webapp}
558
559 %triggerun -- apache < 2.2.0, apache-base
560 %webapp_unregister httpd %{_webapp}
561
562 %triggerin -- lighttpd
563 %webapp_register lighttpd %{_webapp}
564
565 %triggerun -- lighttpd
566 %webapp_unregister lighttpd %{_webapp}
567
568 %triggerpostun -- %{name} < 3.0.0-0.2
569 for f in /etc/cron.d/eventum-*; do
570         # crontabs moved to bin
571         %{__sed} -i -e '
572                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
573                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
574                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
575                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
576         ' $f
577 done
578
579 %files -f %{name}.lang
580 %defattr(644,root,root,755)
581 %attr(771,root,http) %dir %{_webappdir}
582 %attr(751,root,http) %dir %{_webappdir}/crm
583 %attr(751,root,http) %dir %{_webappdir}/custom_field
584 %attr(751,root,http) %dir %{_webappdir}/partner
585 %attr(751,root,http) %dir %{_webappdir}/templates
586 %attr(751,root,http) %dir %{_webappdir}/workflow
587 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
588 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
589 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
590 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
591 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
592 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
593 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
594 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
595
596 %dir %attr(731,root,http) /var/log/%{name}
597 %attr(620,root,http) %ghost /var/log/%{name}/*
598 %dir %attr(750,root,root) /var/log/archive/%{name}
599 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
600
601 %dir %{_appdir}
602 %{_appdir}/config
603
604 %dir %{_appdir}/bin
605 %attr(755,root,root) %{_appdir}/bin/extension.php
606 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
607 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
608 %attr(755,root,root) %{_appdir}/bin/upgrade.php
609
610 %{_appdir}/autoload.php
611 %{_appdir}/globals.php
612 %{_appdir}/init.php
613 %{_appdir}/phinx.php
614 %dir %{_appdir}/htdocs
615 %{_appdir}/htdocs/*.php
616 %{_appdir}/htdocs/*.ico
617 %{_appdir}/htdocs/ajax
618 %{_appdir}/htdocs/css
619 %{_appdir}/htdocs/customer
620 %{_appdir}/htdocs/images
621 %{_appdir}/htdocs/js
622 %{_appdir}/htdocs/manage
623 %{_appdir}/htdocs/reports
624 %{_appdir}/htdocs/rpc
625 %{_appdir}/htdocs/components
626 %{_appdir}/templates
627
628 %dir %{_appdir}/db
629 %dir %{_appdir}/db/migrations
630 %{_appdir}/db/migrations/*.php
631
632 %{_appdir}/res
633 %{_appdir}/src
634 %{_appdir}/vendor
635 %dir %{_appdir}/lib
636 %{_appdir}/lib/eventum
637 %exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
638 %exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
639 %exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
640 %exclude %{_appdir}/src/Console/Command/MonitorCommand.php
641 %exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
642
643 %dir %{_libdir}
644
645 %{systemdtmpfilesdir}/%{name}.conf
646
647 %dir /var/lib/%{name}
648 %dir %attr(730,root,http) /var/run/%{name}
649 %dir %attr(730,root,http) /var/cache/%{name}
650
651 # saved mail copies
652 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
653 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
654 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
655 # attachment storage
656 %attr(770,root,http) %dir /var/lib/%{name}/storage
657
658 %files setup
659 %defattr(644,root,root,755)
660 %{_appdir}/htdocs/setup
661
662 %files doc
663 %defattr(644,root,root,755)
664 %doc docs/*
665 %{_examplesdir}/%{name}-%{version}
666
667 %files mail-queue
668 %defattr(644,root,root,755)
669 %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
670 %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
671 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
672 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
673 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
674
675 %files mail-download
676 %defattr(644,root,root,755)
677 %{_appdir}/src/Console/Command/MailDownloadCommand.php
678 %attr(755,root,root) %{_appdir}/bin/download_emails.php
679 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
680
681 %files reminder
682 %defattr(644,root,root,755)
683 %{_appdir}/src/Console/Command/ReminderCheckCommand.php
684 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
685 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
686
687 %files monitor
688 %defattr(644,root,root,755)
689 %{_appdir}/src/Console/Command/MonitorCommand.php
690 %attr(755,root,root) %{_appdir}/bin/monitor.php
691 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
692
693 %files router-postfix
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_libdir}/router-postfix
696
697 %files irc
698 %defattr(644,root,root,755)
699 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
700 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
701 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
702 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
703
704 %files cli
705 %defattr(644,root,root,755)
706 %doc cli/eventumrc
707 %attr(755,root,root) %{_bindir}/%{name}
708
709 %files sphinx
710 %defattr(644,root,root,755)
711 %{_webappdir}/sphinx.conf.php
712 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
713 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.073885 seconds and 3 git commands to generate.