]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
Up to 3.10.12
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 #define         subver  189
7 #define         githash 7b4eddae
8 %define         php_min_version 5.6.0
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.3.3
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2+
16 Group:          Applications/WWW
17 Source0:        https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  7fde18feb868ad965aa186418eccd1c1
19 #Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source8:        %{name}-irc.init
26 Source9:        %{name}-irc.sysconfig
27 Source10:       sphinx.crontab
28 Source13:       %{name}-router-postfix.sh
29 Source14:       %{name}.logrotate
30 Source15:       %{name}-lighttpd.conf
31 Source16:       http://www.isocra.com/images/updown2.gif
32 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
33 Source17:       %{name}.tmpfiles
34 Patch2:         %{name}-order.patch
35 #Patch3:                group-users.patch
36 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
37 # packaging patches that probably never go upstream
38 Patch100:       %{name}-paths.patch
39 Patch107:       %{name}-gettext.patch
40 Patch108:       autoload.patch
41 # some tests
42 Patch200:       %{name}-fixed-nav.patch
43 URL:            https://wiki.github.com/eventum/eventum/
44 BuildRequires:  gettext-tools
45 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
46 BuildRequires:  rpmbuild(macros) >= 1.654
47 BuildRequires:  sed >= 4.0
48 Requires(postun):       /usr/sbin/groupdel
49 Requires(postun):       /usr/sbin/userdel
50 Requires(pre):  /bin/id
51 Requires(pre):  /usr/bin/getgid
52 Requires(pre):  /usr/sbin/groupadd
53 Requires(pre):  /usr/sbin/useradd
54 Requires:       fonts-TTF-RedHat-liberation
55 Requires:       php(core) >= %{php_min_version}
56 Requires:       php(filter)
57 Requires:       php(iconv)
58 Requires:       php(imap)
59 Requires:       php(json)
60 Requires:       php(mbstring)
61 Requires:       php(pcre)
62 Requires:       php(pdo_mysql)
63 Requires:       php(session)
64 Requires:       php-Smarty >= 3.1
65 Requires:       php-Smarty-plugin-gettext
66 Requires:       php-ZendFramework-Config >= 2.4
67 Requires:       php-ZendFramework-Loader >= 2.4
68 Requires:       php-ZendFramework-Mail >= 2.4.11-4
69 Requires:       php-ZendFramework-Mime >= 2.4
70 Requires:       php-ZendFramework-ServiceManager >= 2.4
71 Requires:       php-ZendFramework-Validator >= 2.4
72 Requires:       php-monolog >= 1.17.2
73 Requires:       php-pear-Mail_Mime
74 Requires:       php-pear-Mail_mimeDecode
75 Requires:       php-pear-Math_Stats
76 Requires:       php-pear-Net_SMTP
77 Requires:       php-pear-Net_Socket
78 Requires:       php-pear-Net_URL
79 Requires:       php-pear-PEAR-core
80 Requires:       php-pear-Text_Diff
81 Requires:       php-psr-Log >= 1.0.0-2
82 Requires:       phplot >= 5.8.0
83 Requires:       webapps
84 Requires:       webserver(access)
85 Requires:       webserver(alias)
86 Requires:       webserver(indexfile)
87 Requires:       webserver(php) >= 4.2.0
88 Suggests:       localedb
89 Suggests:       php(mcrypt)
90 Suggests:       php(openssl)
91 Suggests:       php-pear-Net_LDAP2
92 Suggests:       php-pear-Net_POP3
93 Suggests:       webserver(setenv)
94 Provides:       group(eventum)
95 Provides:       user(eventum)
96 Obsoletes:      eventum-base < 3.0.3-1.305
97 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
98 Obsoletes:      eventum-route-emails < 3.0.8-1.1
99 Obsoletes:      eventum-route-notes < 3.0.8-1.1
100 Conflicts:      logrotate < 3.8.0
101 BuildArch:      noarch
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
105
106 # exclude optional php dependencies
107 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
108
109 %define         _noautoreq      %{_noautophp}
110
111 %define         _libdir         %{_prefix}/lib/%{name}
112 %define         _appdir         %{_datadir}/%{name}
113 %define         _smartydir      %{php_data_dir}/Smarty
114 %define         _webapps        /etc/webapps
115 %define         _webapp         %{name}
116 %define         _webappdir      %{_webapps}/%{_webapp}
117 %define         _sysconfdir     /etc/%{name}
118
119 %description
120 Eventum is a user-friendly and flexible issue tracking system that can
121 be used by a support department to track incoming technical support
122 requests, or by a software development team to quickly organize tasks
123 and bugs.
124
125 %description -l pl.UTF-8
126 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
127 może być używany przez dział obsługi do śledzenia przychodzących żądań
128 obsługi technicznej albo przez zespół tworzący oprogramowanie do
129 szybkiej organizacji zadań i błędów.
130
131 %package setup
132 Summary:        Eventum setup package
133 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
134 Group:          Applications/WWW
135 Requires:       %{name} = %{version}-%{release}
136
137 %description setup
138 Install this package to configure initial Eventum installation. You
139 should uninstall this package when you're done, as it considered
140 insecure to keep the setup files in place.
141
142 %description setup -l pl.UTF-8
143 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
144 pierwszej instalacji. Potem należy go odinstalować, jako że
145 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
146
147 %package doc
148 Summary:        Eventum documentation and Wiki
149 Group:          Documentation
150
151 %description doc
152 Eventum documentation and copy of Wiki.
153
154 %package mail-queue
155 Summary:        Eventum mail queue process
156 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
157 Group:          Applications/WWW
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       crondaemon
160
161 %description mail-queue
162 Beginning with the first release of Eventum, emails are not directly
163 sent out from the various scripts, but rather added to a mail queue
164 table that is processed by a cron job. If an email cannot be sent, it
165 will be marked as such in the mail queue log, and the cron job script
166 will re-try to send it again the next time it runs.
167
168 This package contains the cron job.
169
170 %description mail-queue -l pl.UTF-8
171 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
172 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
173 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
174 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
175 następnym razem.
176
177 Ten pakiet zawiera zadanie dla crona.
178
179 %package mail-download
180 Summary:        Eventum email download
181 Summary(pl.UTF-8):      Ściąganie poczty Eventum
182 Group:          Applications/WWW
183 Requires:       %{name} = %{version}-%{release}
184 Requires:       crondaemon
185
186 %description mail-download
187 In order for Eventum's email integration feature to work, you need to
188 setup a cron job to run the script every so often.
189
190 This package contains the cron job.
191
192 %description mail-download -l pl.UTF-8
193 Aby integracja poczty elektronicznej w Eventum działała, trzeba
194 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
195 często.
196
197 Ten pakiet zawiera zadanie dla crona.
198
199 %package reminder
200 Summary:        Eventum Reminder System
201 Summary(pl.UTF-8):      System przypominania dla Eventum
202 Group:          Applications/WWW
203 Requires:       %{name} = %{version}-%{release}
204 Requires:       crondaemon
205
206 %description reminder
207 The reminder system was designed with the objective as serving as a
208 safe net for issues that need attention. Depending on what
209 configuration you create, you may have several reminders (or alerts)
210 be sent out whenever an issue needs attention, for whatever parameter
211 you may deem necessary.
212
213 This package contains the cron job.
214
215 %description reminder -l pl.UTF-8
216 System przypominania został zaprojektowany tak, aby służył jako
217 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
218 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
219 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
220 uważać za potrzebny.
221
222 Ten pakiet zawiera zadanie dla crona.
223
224 %package monitor
225 Summary:        Eventum Heartbeat Monitor
226 Summary(pl.UTF-8):      Monitor życia dla Eventum
227 Group:          Applications/WWW
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       crondaemon
230 Requires:       php(posix)
231
232 %description monitor
233 The heartbeat monitor is a feature designed for the administrator that
234 wants to be alerted whenever a common problem in Eventum is detected,
235 like the database server not being available anymore, or maybe when
236 the recommended permissions for certain configuration files are
237 changed.
238
239 Please note that before running the heartbeat monitor, you may need to
240 customize some of the checks to be appropriate for your own system,
241 particularly the permission and file checks on
242 Monitor::checkConfiguration().
243
244 This package contains the cron job.
245
246 %description monitor -l pl.UTF-8
247 Monitor życia to funkcjonalność zaprojektowana dla administratora
248 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
249 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
250 do plików konfiguracyjnych.
251
252 Należy zauważyć, że przed uruchomieniem tego monitora może być
253 konieczne dostosowanie niektórych testów do systemu, w szczególności
254 testów uprawnień i plików w Monitor::checkConfiguration().
255
256 Ten pakiet zawiera zadanie dla crona.
257
258 %package router-postfix
259 Summary:        Eventum Mail Routing - Postfix
260 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
261 Group:          Applications/Mail
262 Requires:       %{name} = %{version}-%{release}
263 Requires:       postfix
264 Provides:       eventum(router)
265 Obsoletes:      eventum(router)
266
267 %description router-postfix
268 This package provides way of routing notes and emails back to Eventum
269 via Postfix.
270
271 The Postfix configuration instructions you can find from
272 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
273
274 %description router-postfix -l pl.UTF-8
275 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
276 przez Postfiksa.
277
278 Opis konfiguracji Postfiksa można znaleźć pod adresem
279 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
280
281 %package irc
282 Summary:        Eventum IRC Notification Bot
283 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
284 Group:          Applications/WWW
285 Requires(post,preun):   /sbin/chkconfig
286 Requires:       %{name} = %{version}-%{release}
287 Requires:       php(pcntl)
288 Requires:       php(sockets)
289 Requires:       php-pear-Net_SmartIRC >= 1.1.9
290 Requires:       rc-scripts >= 0.4.0.18
291
292 %description irc
293 The IRC notification bot is a nice feature for remote teams that want
294 to handle issues and want to have a quick and easy way to get simple
295 notifications. Right now the bot notifies of the following actions:
296 - New Issues
297 - Blocked emails
298 - Issues that got their assignment list changed
299
300 NOTE: You will need to manually edit the bot.php script to set your
301 appropriate preferences, like IRC server and channel that the bot
302 should join.
303
304 %description irc -l pl.UTF-8
305 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
306 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
307 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
308 następujących zdarzeniach:
309 - nowych sprawach
310 - zablokowanych listach
311 - sprawach, dla których zmieniła się lista powiązań
312
313 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
314 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
315
316 %package cli
317 Summary:        Eventum command-line interface
318 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
319 Group:          Applications/WWW
320 Requires:       php(core) >= %{php_min_version}
321 Requires:       php(phar)
322
323 %description cli
324 The Eventum command-line interface allows you to access most of the
325 features of the web interface straight from your command shell.
326
327 %description cli -l pl.UTF-8
328 Interfejs linii poleceń Eventum pozwala na dostęp do większości
329 funkcji interfejsu WWW prosto z linii poleceń powłoki.
330
331 %package sphinx
332 Summary:        Eventum Sphinx Search
333 Group:          Applications/WWW
334 Requires:       %{name} = %{version}-%{release}
335 Requires:       crondaemon
336 Requires:       sphinx
337
338 %description sphinx
339 Sphinx search integration for Eventum.
340
341 This package contains the cron job.
342
343 %prep
344 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
345
346 mv docs/examples .
347
348 # bug fixes / features
349 %{?with_order:%patch2 -p1}
350 #%patch3 -p0
351 #%patch4 -p1
352
353 %{?with_order:cp -p %{SOURCE16} htdocs/images}
354
355 #%patch200 -p1
356
357 # produce default sphinx config
358 # must be run before paths.patch
359 %if 0
360 cat <<'EOF' > config/config.php
361 <?php
362 define('APP_SQL_DBTYPE', 'mysql');
363 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
364 define('APP_SQL_DBPORT', 3306);
365 define('APP_SQL_DBNAME', 'eventum');
366 define('APP_SQL_DBUSER', 'mysql');
367 define('APP_SQL_DBPASS', '');
368 define('APP_TABLE_PREFIX', 'eventum_');
369 EOF
370 php config/sphinx.conf.php > config/sphinx.conf
371 rm config/config.php
372 %endif
373
374 # packaging
375 %patch100 -p1
376 %patch107 -p1
377 %patch108 -p1
378
379 rm htdocs/.htaccess.dist
380
381 mv config/irc_config{.dist.php,.php}
382 rm config/config.dist.php
383
384 # cleanup vendor. keep only needed libraries.
385 # (the rest are packaged with system packages)
386 mv vendor vendor.dist
387 vendor() {
388         local path dir
389         for path; do
390                 dir=$(dirname $path)
391                 test -d vendor/$dir || mkdir -p vendor/$dir
392                 mv vendor.dist/$path vendor/$path
393         done
394 }
395 vendor autoload.php
396 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
397 vendor composer/ClassLoader.php
398 vendor ircmaxell/{random-lib,security-lib}
399 vendor defuse/php-encryption
400 vendor willdurand/email-reply-parser
401 vendor theorchard/monolog-cascade
402 vendor malkusch/lock
403 vendor phpxmlrpc/phpxmlrpc
404 vendor robmorgan/phinx
405 vendor mnapoli/silly
406 vendor psr/container
407 vendor phlib/flysystem-pdo
408 vendor league/flysystem
409 vendor php-di/invoker
410 vendor container-interop/container-interop
411 vendor symfony/config
412 vendor symfony/console
413 vendor symfony/debug
414 vendor symfony/event-dispatcher
415 vendor symfony/filesystem
416 vendor symfony/http-foundation
417 vendor symfony/options-resolver
418 vendor symfony/serializer
419 vendor symfony/yaml
420
421 # remove backups from patching as we use globs to package files to buildroot
422 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
423
424 %build
425 %{__make} -C localization
426
427 %install
428 rm -rf $RPM_BUILD_ROOT
429 install -d \
430         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
431         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
432         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
433         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
434         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
435         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
436
437 %{__make} install-eventum install-cli install-localization \
438         sysconfdir=%{_webappdir} \
439         localedir=%{_localedir} \
440         DESTDIR=$RPM_BUILD_ROOT
441
442 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
443
444 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
445
446 # unsupported locale
447 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
448
449 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
450 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
451
452 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
453
454 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
455 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
456 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
457 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
458
459 install -d $RPM_BUILD_ROOT/etc/sphinx
460 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
461 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
462
463 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
464 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
465 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
466 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
467 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
468
469 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
470 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
471
472 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
473
474 # postfix router
475 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
476
477 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
478
479 %find_lang %{name}
480
481 %clean
482 rm -rf $RPM_BUILD_ROOT
483
484 %pre
485 %groupadd -g 146 %{name}
486 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
487 %addusertogroup http %{name}
488
489 %post
490 # create empty ghost files
491 # these permissions ensure the logs are write only
492 for a in \
493         errors.log login_attempts.log \
494         eventum.log \
495         auth.log cli.log \
496         irc_bot_error.log irc_bot_smartirc.log \
497 ; do
498         test -f /var/log/%{name}/$a && continue
499         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
500 done
501
502 # run database update if configured
503 test -s %{_webappdir}/config.php && \
504 %{_appdir}/bin/upgrade.php || :
505
506 # nuke Smarty templates cache after upgrade
507 rm -f /var/cache/eventum/*.php
508
509 # Restart webserver on upgrade to get .mo translations reloaded.
510 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
511 %php_webserver_restart
512
513 %preun
514 if [ "$1" = "0" ]; then
515         # nuke cache
516         rm -f /var/cache/eventum/*.php 2>/dev/null || :
517 fi
518
519 %postun
520 if [ "$1" = "0" ]; then
521         %userremove %{name}
522         %groupremove %{name}
523 fi
524
525 %post setup
526 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
527 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
528
529 %postun setup
530 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
531         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
532         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
533 fi
534
535 %post irc
536 /sbin/chkconfig --add eventum-irc
537 %service eventum-irc restart "Eventum IRC Bot"
538
539 %preun irc
540 if [ "$1" = 0 ]; then
541         %service eventum-irc stop
542         /sbin/chkconfig --del eventum-irc
543 fi
544
545 %triggerin -- apache1 < 1.3.37-3, apache1-base
546 %webapp_register apache %{_webapp}
547
548 %triggerun -- apache1 < 1.3.37-3, apache1-base
549 %webapp_unregister apache %{_webapp}
550
551 %triggerin -- apache < 2.2.0, apache-base
552 %webapp_register httpd %{_webapp}
553
554 %triggerun -- apache < 2.2.0, apache-base
555 %webapp_unregister httpd %{_webapp}
556
557 %triggerin -- lighttpd
558 %webapp_register lighttpd %{_webapp}
559
560 %triggerun -- lighttpd
561 %webapp_unregister lighttpd %{_webapp}
562
563 %triggerpostun -- %{name} < 3.0.0-0.2
564 for f in /etc/cron.d/eventum-*; do
565         # crontabs moved to bin
566         %{__sed} -i -e '
567                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
568                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
569                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
570                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
571         ' $f
572 done
573
574 %files -f %{name}.lang
575 %defattr(644,root,root,755)
576 %attr(751,root,root) %dir %{_webappdir}
577 %attr(751,root,http) %dir %{_webappdir}/crm
578 %attr(751,root,http) %dir %{_webappdir}/custom_field
579 %attr(751,root,http) %dir %{_webappdir}/partner
580 %attr(751,root,http) %dir %{_webappdir}/templates
581 %attr(751,root,http) %dir %{_webappdir}/workflow
582 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
583 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
584 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
585 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
586 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
587 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
588 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
589 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
590
591 %dir %attr(731,root,http) /var/log/%{name}
592 %attr(620,root,http) %ghost /var/log/%{name}/*
593 %dir %attr(750,root,root) /var/log/archive/%{name}
594 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
595
596 %dir %{_appdir}
597 %{_appdir}/config
598
599 %dir %{_appdir}/bin
600 %attr(755,root,root) %{_appdir}/bin/extension.php
601 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
602 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
603 %attr(755,root,root) %{_appdir}/bin/upgrade.php
604
605 %{_appdir}/autoload.php
606 %{_appdir}/globals.php
607 %{_appdir}/init.php
608 %{_appdir}/phinx.php
609 %dir %{_appdir}/htdocs
610 %{_appdir}/htdocs/*.php
611 %{_appdir}/htdocs/*.ico
612 %{_appdir}/htdocs/ajax
613 %{_appdir}/htdocs/css
614 %{_appdir}/htdocs/customer
615 %{_appdir}/htdocs/images
616 %{_appdir}/htdocs/js
617 %{_appdir}/htdocs/manage
618 %{_appdir}/htdocs/reports
619 %{_appdir}/htdocs/rpc
620 %{_appdir}/htdocs/components
621 %{_appdir}/templates
622
623 %dir %{_appdir}/db
624 %dir %{_appdir}/db/migrations
625 %{_appdir}/db/migrations/*.php
626
627 %{_appdir}/res
628 %{_appdir}/src
629 %{_appdir}/vendor
630 %dir %{_appdir}/lib
631 %{_appdir}/lib/eventum
632 %exclude %{_appdir}/src/Command/MailDownloadCommand.php
633 %exclude %{_appdir}/src/Command/MailQueueProcessCommand.php
634 %exclude %{_appdir}/src/Command/MailQueueTruncateCommand.php
635 %exclude %{_appdir}/src/Command/MonitorCommand.php
636 %exclude %{_appdir}/src/Command/ReminderCheckCommand.php
637
638 %dir %{_libdir}
639
640 %{systemdtmpfilesdir}/%{name}.conf
641
642 %dir /var/lib/%{name}
643 %dir %attr(730,root,http) /var/run/%{name}
644 %dir %attr(730,root,http) /var/cache/%{name}
645
646 # saved mail copies
647 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
648 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
649 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
650 # attachment storage
651 %attr(770,root,http) %dir /var/lib/%{name}/storage
652
653 %files setup
654 %defattr(644,root,root,755)
655 %{_appdir}/htdocs/setup
656
657 %files doc
658 %defattr(644,root,root,755)
659 %doc docs/*
660 %{_examplesdir}/%{name}-%{version}
661
662 %files mail-queue
663 %defattr(644,root,root,755)
664 %{_appdir}/src/Command/MailQueueProcessCommand.php
665 %{_appdir}/src/Command/MailQueueTruncateCommand.php
666 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
667 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
668 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
669
670 %files mail-download
671 %defattr(644,root,root,755)
672 %{_appdir}/src/Command/MailDownloadCommand.php
673 %attr(755,root,root) %{_appdir}/bin/download_emails.php
674 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
675
676 %files reminder
677 %defattr(644,root,root,755)
678 %{_appdir}/src/Command/ReminderCheckCommand.php
679 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
680 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
681
682 %files monitor
683 %defattr(644,root,root,755)
684 %{_appdir}/src/Command/MonitorCommand.php
685 %attr(755,root,root) %{_appdir}/bin/monitor.php
686 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
687
688 %files router-postfix
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/router-postfix
691
692 %files irc
693 %defattr(644,root,root,755)
694 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
695 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
696 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
697 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
698
699 %files cli
700 %defattr(644,root,root,755)
701 %doc cli/eventumrc
702 %attr(755,root,root) %{_bindir}/%{name}
703
704 %files sphinx
705 %defattr(644,root,root,755)
706 %{_webappdir}/sphinx.conf.php
707 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
708 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.071653 seconds and 3 git commands to generate.