]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
4828f5be2e5ddfe3a830dc84035fc3659ad8a3ac
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 #define         subver  7
7 #define         githash f3c41492
8 %define         php_min_version 5.6.0
9 Summary:        Eventum Issue / Bug tracking system
10 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
11 Name:           eventum
12 Version:        3.5.4
13 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
14 License:        GPL v2+
15 Group:          Applications/WWW
16 Source0:        https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
17 # Source0-md5:  47414f0f8e5a1047f4b5478580c11bee
18 #Source0:       https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
19 Source1:        %{name}-apache.conf
20 Source2:        %{name}-mail-queue.cron
21 Source3:        %{name}-mail-download.cron
22 Source4:        %{name}-reminder.cron
23 Source5:        %{name}-monitor.cron
24 Source10:       sphinx.crontab
25 Source13:       %{name}-router-postfix.sh
26 Source14:       %{name}.logrotate
27 Source15:       %{name}-lighttpd.conf
28 Source16:       http://www.isocra.com/images/updown2.gif
29 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
30 Source17:       %{name}.tmpfiles
31 Patch2:         %{name}-order.patch
32 #Patch3:                group-users.patch
33 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
34 # packaging patches that probably never go upstream
35 Patch100:       %{name}-paths.patch
36 Patch107:       %{name}-gettext.patch
37 Patch108:       autoload.patch
38 # some tests
39 Patch200:       %{name}-fixed-nav.patch
40 URL:            https://wiki.github.com/eventum/eventum/
41 BuildRequires:  gettext-tools
42 BuildRequires:  rpmbuild(macros) >= 1.654
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  xz
46 Requires(post): sudo
47 Requires(postun):       /usr/sbin/groupdel
48 Requires(postun):       /usr/sbin/userdel
49 Requires(pre):  /bin/id
50 Requires(pre):  /usr/bin/getgid
51 Requires(pre):  /usr/sbin/groupadd
52 Requires(pre):  /usr/sbin/useradd
53 Requires:       fonts-TTF-RedHat-liberation
54 Requires:       php(core) >= %{php_min_version}
55 Requires:       php(filter)
56 Requires:       php(iconv)
57 Requires:       php(imap)
58 Requires:       php(json)
59 Requires:       php(mbstring)
60 Requires:       php(pcre)
61 Requires:       php(pdo_mysql)
62 Requires:       php(session)
63 Requires:       php-Smarty >= 3.1
64 Requires:       php-Smarty-plugin-gettext
65 Requires:       php-ZendFramework-Config >= 2.4
66 Requires:       php-ZendFramework-Loader >= 2.4
67 Requires:       php-ZendFramework-Mail >= 2.4.13-2
68 Requires:       php-ZendFramework-Mime >= 2.4
69 Requires:       php-ZendFramework-ServiceManager >= 2.4
70 Requires:       php-ZendFramework-Validator >= 2.4
71 Requires:       php-monolog >= 1.17.2
72 Requires:       php-pear-Math_Stats
73 Requires:       php-pear-Net_SMTP
74 Requires:       php-pear-Net_Socket
75 Requires:       php-pear-Net_URL
76 Requires:       php-pear-PEAR-core
77 Requires:       php-pear-Text_Diff
78 Requires:       php-psr-Log >= 1.0.0-2
79 Requires:       phplot >= 5.8.0
80 Requires:       webapps
81 Requires:       webserver(access)
82 Requires:       webserver(alias)
83 Requires:       webserver(indexfile)
84 Requires:       webserver(php) >= 4.2.0
85 Suggests:       localedb
86 Suggests:       php(mcrypt)
87 Suggests:       php(openssl)
88 Suggests:       php-pear-Net_POP3
89 Suggests:       webserver(setenv)
90 Provides:       group(eventum)
91 Provides:       user(eventum)
92 Obsoletes:      eventum-base < 3.0.3-1.305
93 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
94 Obsoletes:      eventum-route-emails < 3.0.8-1.1
95 Obsoletes:      eventum-route-notes < 3.0.8-1.1
96 Conflicts:      logrotate < 3.8.0
97 BuildArch:      noarch
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         _libdir         %{_prefix}/lib/%{name}
101 %define         _appdir         %{_datadir}/%{name}
102 %define         _smartydir      %{php_data_dir}/Smarty
103 %define         _webapps        /etc/webapps
104 %define         _webapp         %{name}
105 %define         _webappdir      %{_webapps}/%{_webapp}
106 %define         _sysconfdir     /etc/%{name}
107
108 %description
109 Eventum is a user-friendly and flexible issue tracking system that can
110 be used by a support department to track incoming technical support
111 requests, or by a software development team to quickly organize tasks
112 and bugs.
113
114 %description -l pl.UTF-8
115 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
116 może być używany przez dział obsługi do śledzenia przychodzących żądań
117 obsługi technicznej albo przez zespół tworzący oprogramowanie do
118 szybkiej organizacji zadań i błędów.
119
120 %package setup
121 Summary:        Eventum setup package
122 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
123 Group:          Applications/WWW
124 Requires:       %{name} = %{version}-%{release}
125
126 %description setup
127 Install this package to configure initial Eventum installation. You
128 should uninstall this package when you're done, as it considered
129 insecure to keep the setup files in place.
130
131 %description setup -l pl.UTF-8
132 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
133 pierwszej instalacji. Potem należy go odinstalować, jako że
134 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
135
136 %package doc
137 Summary:        Eventum documentation and Wiki
138 Group:          Documentation
139
140 %description doc
141 Eventum documentation and copy of Wiki.
142
143 %package mail-queue
144 Summary:        Eventum mail queue process
145 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
146 Group:          Applications/WWW
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       crondaemon
149
150 %description mail-queue
151 Beginning with the first release of Eventum, emails are not directly
152 sent out from the various scripts, but rather added to a mail queue
153 table that is processed by a cron job. If an email cannot be sent, it
154 will be marked as such in the mail queue log, and the cron job script
155 will re-try to send it again the next time it runs.
156
157 This package contains the cron job.
158
159 %description mail-queue -l pl.UTF-8
160 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
161 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
162 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
163 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
164 następnym razem.
165
166 Ten pakiet zawiera zadanie dla crona.
167
168 %package mail-download
169 Summary:        Eventum email download
170 Summary(pl.UTF-8):      Ściąganie poczty Eventum
171 Group:          Applications/WWW
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       crondaemon
174
175 %description mail-download
176 In order for Eventum's email integration feature to work, you need to
177 setup a cron job to run the script every so often.
178
179 This package contains the cron job.
180
181 %description mail-download -l pl.UTF-8
182 Aby integracja poczty elektronicznej w Eventum działała, trzeba
183 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
184 często.
185
186 Ten pakiet zawiera zadanie dla crona.
187
188 %package reminder
189 Summary:        Eventum Reminder System
190 Summary(pl.UTF-8):      System przypominania dla Eventum
191 Group:          Applications/WWW
192 Requires:       %{name} = %{version}-%{release}
193 Requires:       crondaemon
194
195 %description reminder
196 The reminder system was designed with the objective as serving as a
197 safe net for issues that need attention. Depending on what
198 configuration you create, you may have several reminders (or alerts)
199 be sent out whenever an issue needs attention, for whatever parameter
200 you may deem necessary.
201
202 This package contains the cron job.
203
204 %description reminder -l pl.UTF-8
205 System przypominania został zaprojektowany tak, aby służył jako
206 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
207 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
208 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
209 uważać za potrzebny.
210
211 Ten pakiet zawiera zadanie dla crona.
212
213 %package monitor
214 Summary:        Eventum Heartbeat Monitor
215 Summary(pl.UTF-8):      Monitor życia dla Eventum
216 Group:          Applications/WWW
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       crondaemon
219 Requires:       php(posix)
220
221 %description monitor
222 The heartbeat monitor is a feature designed for the administrator that
223 wants to be alerted whenever a common problem in Eventum is detected,
224 like the database server not being available anymore, or maybe when
225 the recommended permissions for certain configuration files are
226 changed.
227
228 Please note that before running the heartbeat monitor, you may need to
229 customize some of the checks to be appropriate for your own system,
230 particularly the permission and file checks on
231 Monitor::checkConfiguration().
232
233 This package contains the cron job.
234
235 %description monitor -l pl.UTF-8
236 Monitor życia to funkcjonalność zaprojektowana dla administratora
237 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
238 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
239 do plików konfiguracyjnych.
240
241 Należy zauważyć, że przed uruchomieniem tego monitora może być
242 konieczne dostosowanie niektórych testów do systemu, w szczególności
243 testów uprawnień i plików w Monitor::checkConfiguration().
244
245 Ten pakiet zawiera zadanie dla crona.
246
247 %package router-postfix
248 Summary:        Eventum Mail Routing - Postfix
249 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
250 Group:          Applications/Mail
251 Requires:       %{name} = %{version}-%{release}
252 Requires:       postfix
253 Provides:       eventum(router)
254 Obsoletes:      eventum(router)
255
256 %description router-postfix
257 This package provides way of routing notes and emails back to Eventum
258 via Postfix.
259
260 The Postfix configuration instructions you can find from
261 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
262
263 %description router-postfix -l pl.UTF-8
264 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
265 przez Postfiksa.
266
267 Opis konfiguracji Postfiksa można znaleźć pod adresem
268 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
269
270 %package cli
271 Summary:        Eventum command-line interface
272 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
273 Group:          Applications/WWW
274 Requires:       php(core) >= %{php_min_version}
275 Requires:       php(phar)
276
277 %description cli
278 The Eventum command-line interface allows you to access most of the
279 features of the web interface straight from your command shell.
280
281 %description cli -l pl.UTF-8
282 Interfejs linii poleceń Eventum pozwala na dostęp do większości
283 funkcji interfejsu WWW prosto z linii poleceń powłoki.
284
285 %package sphinx
286 Summary:        Eventum Sphinx Search
287 Group:          Applications/WWW
288 Requires:       %{name} = %{version}-%{release}
289 Requires:       crondaemon
290 Requires:       sphinx
291
292 %description sphinx
293 Sphinx search integration for Eventum.
294
295 This package contains the cron job.
296
297 %prep
298 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
299
300 mv docs/examples .
301
302 # bug fixes / features
303 %{?with_order:%patch2 -p1}
304 #%patch3 -p0
305 #%patch4 -p1
306
307 %{?with_order:cp -p %{SOURCE16} htdocs/images}
308
309 #%patch200 -p1
310
311 # produce default sphinx config
312 # must be run before paths.patch
313 %if 0
314 cat <<'EOF' > config/config.php
315 <?php
316 define('APP_SQL_DBTYPE', 'mysql');
317 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
318 define('APP_SQL_DBPORT', 3306);
319 define('APP_SQL_DBNAME', 'eventum');
320 define('APP_SQL_DBUSER', 'mysql');
321 define('APP_SQL_DBPASS', '');
322 define('APP_TABLE_PREFIX', 'eventum_');
323 EOF
324 php config/sphinx.conf.php > config/sphinx.conf
325 rm config/config.php
326 %endif
327
328 # packaging
329 %patch100 -p1
330 %patch107 -p1
331 %patch108 -p1
332
333 rm htdocs/.htaccess.dist
334
335 rm config/config.dist.php
336
337 # cleanup vendor. keep only needed libraries.
338 # (the rest are packaged with system packages)
339 mv vendor vendor.dist
340 vendor() {
341         local path dir
342         for path; do
343                 dir=$(dirname $path)
344                 test -d vendor/$dir || mkdir -p vendor/$dir
345                 mv vendor.dist/$path vendor/$path
346         done
347 }
348 vendor autoload.php
349 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
350 vendor composer/ClassLoader.php
351 vendor ircmaxell/{random-lib,security-lib}
352 vendor defuse/php-encryption
353 vendor willdurand/email-reply-parser
354 vendor theorchard/monolog-cascade
355 vendor malkusch/lock
356 vendor phpxmlrpc/phpxmlrpc
357 vendor robmorgan/phinx
358 vendor mnapoli/silly
359 vendor psr/container
360 vendor phlib/flysystem-pdo
361 vendor league/flysystem
362 vendor php-di/invoker
363 vendor container-interop/container-interop
364 vendor symfony/config
365 vendor symfony/console
366 vendor symfony/debug
367 vendor symfony/event-dispatcher
368 vendor symfony/filesystem
369 vendor symfony/http-foundation
370 vendor symfony/options-resolver
371 vendor symfony/serializer
372 vendor symfony/yaml
373 vendor symfony/ldap
374 vendor paragonie/random_compat
375 vendor symfony/polyfill-php70
376 vendor symfony/polyfill-intl-normalizer
377 vendor symfony/security-core
378 vendor symfony/security-csrf
379 vendor glen/filename-normalizer
380 vendor doctrine/annotations
381 vendor doctrine/cache
382 vendor doctrine/collections
383 vendor doctrine/common
384 vendor doctrine/dbal
385 vendor doctrine/inflector
386 vendor doctrine/instantiator
387 vendor doctrine/lexer
388 vendor doctrine/orm
389 vendor cebe/markdown
390 vendor enrise/urihelper
391
392 # remove backups from patching as we use globs to package files to buildroot
393 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
394
395 %build
396 %{__make} -C localization
397
398 %install
399 rm -rf $RPM_BUILD_ROOT
400 install -d \
401         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
402         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
403         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
404         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
405         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
406         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
407
408 %{__make} install-eventum install-cli install-localization \
409         sysconfdir=%{_webappdir} \
410         localedir=%{_localedir} \
411         DESTDIR=$RPM_BUILD_ROOT
412
413 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
414
415 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
416
417 # unsupported locale
418 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
419
420 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
421 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
422
423 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
424
425 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
426 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
427 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
428 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
429
430 install -d $RPM_BUILD_ROOT/etc/sphinx
431 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
432 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
433
434 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
435 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
436 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
437 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
438 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
439
440 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
441
442 # postfix router
443 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
444
445 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
446
447 %find_lang %{name}
448
449 %clean
450 rm -rf $RPM_BUILD_ROOT
451
452 %pre
453 %groupadd -g 146 %{name}
454 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
455 %addusertogroup http %{name}
456
457 %post
458 # create empty ghost files
459 # these permissions ensure the logs are write only
460 for a in \
461         errors.log login_attempts.log \
462         eventum.log \
463         auth.log cli.log \
464 ; do
465         test -f /var/log/%{name}/$a && continue
466         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
467 done
468
469 # run database update if configured
470 test -s %{_webappdir}/config.php && \
471 sudo -H -u http -- %{_appdir}/bin/upgrade.php || :
472
473 # nuke Smarty templates cache after upgrade
474 rm -f /var/cache/eventum/*.php
475
476 # Restart webserver on upgrade to get .mo translations reloaded.
477 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
478 %php_webserver_restart
479
480 %preun
481 if [ "$1" = "0" ]; then
482         # nuke cache
483         rm -f /var/cache/eventum/*.php 2>/dev/null || :
484 fi
485
486 %postun
487 if [ "$1" = "0" ]; then
488         %userremove %{name}
489         %groupremove %{name}
490 fi
491
492 %post setup
493 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
494 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
495
496 %postun setup
497 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
498         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
499         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
500 fi
501
502 %triggerin -- apache1 < 1.3.37-3, apache1-base
503 %webapp_register apache %{_webapp}
504
505 %triggerun -- apache1 < 1.3.37-3, apache1-base
506 %webapp_unregister apache %{_webapp}
507
508 %triggerin -- apache < 2.2.0, apache-base
509 %webapp_register httpd %{_webapp}
510
511 %triggerun -- apache < 2.2.0, apache-base
512 %webapp_unregister httpd %{_webapp}
513
514 %triggerin -- lighttpd
515 %webapp_register lighttpd %{_webapp}
516
517 %triggerun -- lighttpd
518 %webapp_unregister lighttpd %{_webapp}
519
520 %triggerpostun -- %{name} < 3.0.0-0.2
521 for f in /etc/cron.d/eventum-*; do
522         # crontabs moved to bin
523         %{__sed} -i -e '
524                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
525                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
526                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
527                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
528         ' $f
529 done
530
531 %files -f %{name}.lang
532 %defattr(644,root,root,755)
533 %attr(771,root,http) %dir %{_webappdir}
534 %attr(751,root,http) %dir %{_webappdir}/crm
535 %attr(751,root,http) %dir %{_webappdir}/custom_field
536 %attr(751,root,http) %dir %{_webappdir}/partner
537 %attr(751,root,http) %dir %{_webappdir}/templates
538 %attr(751,root,http) %dir %{_webappdir}/workflow
539 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
540 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
541 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
542 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
543 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
544 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
545 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
546 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
547
548 %dir %attr(731,root,http) /var/log/%{name}
549 %attr(620,root,http) %ghost /var/log/%{name}/*
550 %dir %attr(750,root,root) /var/log/archive/%{name}
551 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
552
553 %dir %{_appdir}
554 %{_appdir}/config
555
556 %dir %{_appdir}/bin
557 %attr(755,root,root) %{_appdir}/bin/extension.php
558 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
559 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
560 %attr(755,root,root) %{_appdir}/bin/upgrade.php
561
562 %{_appdir}/autoload.php
563 %{_appdir}/globals.php
564 %{_appdir}/init.php
565 %{_appdir}/phinx.php
566 %dir %{_appdir}/htdocs
567 %{_appdir}/htdocs/*.php
568 %{_appdir}/htdocs/*.ico
569 %{_appdir}/htdocs/ajax
570 %{_appdir}/htdocs/css
571 %{_appdir}/htdocs/customer
572 %{_appdir}/htdocs/images
573 %{_appdir}/htdocs/js
574 %{_appdir}/htdocs/manage
575 %{_appdir}/htdocs/reports
576 %{_appdir}/htdocs/rpc
577 %{_appdir}/htdocs/components
578 %{_appdir}/templates
579
580 %dir %{_appdir}/db
581 %dir %{_appdir}/db/migrations
582 %{_appdir}/db/migrations/*.php
583
584 %{_appdir}/res
585 %{_appdir}/src
586 %{_appdir}/vendor
587 %dir %{_appdir}/lib
588 %{_appdir}/lib/eventum
589 %exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
590 %exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
591 %exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
592 %exclude %{_appdir}/src/Console/Command/MonitorCommand.php
593 %exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
594
595 %dir %{_libdir}
596
597 %{systemdtmpfilesdir}/%{name}.conf
598
599 %dir /var/lib/%{name}
600 %dir %attr(730,root,http) /var/run/%{name}
601 %dir %attr(730,root,http) /var/cache/%{name}
602
603 # saved mail copies
604 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
605 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
606 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
607 # attachment storage
608 %attr(770,root,http) %dir /var/lib/%{name}/storage
609
610 %files setup
611 %defattr(644,root,root,755)
612 %{_appdir}/htdocs/setup
613
614 %files doc
615 %defattr(644,root,root,755)
616 %doc docs/*
617 %{_examplesdir}/%{name}-%{version}
618
619 %files mail-queue
620 %defattr(644,root,root,755)
621 %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
622 %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
623 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
624 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
625 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
626
627 %files mail-download
628 %defattr(644,root,root,755)
629 %{_appdir}/src/Console/Command/MailDownloadCommand.php
630 %attr(755,root,root) %{_appdir}/bin/download_emails.php
631 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
632
633 %files reminder
634 %defattr(644,root,root,755)
635 %{_appdir}/src/Console/Command/ReminderCheckCommand.php
636 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
637 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
638
639 %files monitor
640 %defattr(644,root,root,755)
641 %{_appdir}/src/Console/Command/MonitorCommand.php
642 %attr(755,root,root) %{_appdir}/bin/monitor.php
643 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
644
645 %files router-postfix
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_libdir}/router-postfix
648
649 %files cli
650 %defattr(644,root,root,755)
651 %doc cli/eventumrc
652 %attr(755,root,root) %{_bindir}/%{name}
653
654 %files sphinx
655 %defattr(644,root,root,755)
656 %{_webappdir}/sphinx.conf.php
657 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
658 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.091054 seconds and 2 git commands to generate.