]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
219211798f3bf42a78ffed439291006405b492f1
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 %define         subver  45
7 %define         githash dc8e82f4
8 %define         php_min_version 5.6.0
9 Summary:        Eventum Issue / Bug tracking system
10 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
11 Name:           eventum
12 Version:        3.4.2
13 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
14 License:        GPL v2+
15 Group:          Applications/WWW
16 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
17 Source0:        https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
18 # Source0-md5:  300aef7173ef4aa37dbf58ef03c4c0fb
19 Source1:        %{name}-apache.conf
20 Source2:        %{name}-mail-queue.cron
21 Source3:        %{name}-mail-download.cron
22 Source4:        %{name}-reminder.cron
23 Source5:        %{name}-monitor.cron
24 Source10:       sphinx.crontab
25 Source13:       %{name}-router-postfix.sh
26 Source14:       %{name}.logrotate
27 Source15:       %{name}-lighttpd.conf
28 Source16:       http://www.isocra.com/images/updown2.gif
29 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
30 Source17:       %{name}.tmpfiles
31 Patch2:         %{name}-order.patch
32 #Patch3:                group-users.patch
33 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
34 # packaging patches that probably never go upstream
35 Patch100:       %{name}-paths.patch
36 Patch107:       %{name}-gettext.patch
37 Patch108:       autoload.patch
38 # some tests
39 Patch200:       %{name}-fixed-nav.patch
40 URL:            https://wiki.github.com/eventum/eventum/
41 BuildRequires:  gettext-tools
42 BuildRequires:  rpmbuild(macros) >= 1.654
43 BuildRequires:  sed >= 4.0
44 Requires(post): sudo
45 Requires(postun):       /usr/sbin/groupdel
46 Requires(postun):       /usr/sbin/userdel
47 Requires(pre):  /bin/id
48 Requires(pre):  /usr/bin/getgid
49 Requires(pre):  /usr/sbin/groupadd
50 Requires(pre):  /usr/sbin/useradd
51 Requires:       fonts-TTF-RedHat-liberation
52 Requires:       php(core) >= %{php_min_version}
53 Requires:       php(filter)
54 Requires:       php(iconv)
55 Requires:       php(imap)
56 Requires:       php(json)
57 Requires:       php(mbstring)
58 Requires:       php(pcre)
59 Requires:       php(pdo_mysql)
60 Requires:       php(session)
61 Requires:       php-Smarty >= 3.1
62 Requires:       php-Smarty-plugin-gettext
63 Requires:       php-ZendFramework-Config >= 2.4
64 Requires:       php-ZendFramework-Loader >= 2.4
65 Requires:       php-ZendFramework-Mail >= 2.4.13-2
66 Requires:       php-ZendFramework-Mime >= 2.4
67 Requires:       php-ZendFramework-ServiceManager >= 2.4
68 Requires:       php-ZendFramework-Validator >= 2.4
69 Requires:       php-monolog >= 1.17.2
70 Requires:       php-pear-Math_Stats
71 Requires:       php-pear-Net_SMTP
72 Requires:       php-pear-Net_Socket
73 Requires:       php-pear-Net_URL
74 Requires:       php-pear-PEAR-core
75 Requires:       php-pear-Text_Diff
76 Requires:       php-psr-Log >= 1.0.0-2
77 Requires:       phplot >= 5.8.0
78 Requires:       webapps
79 Requires:       webserver(access)
80 Requires:       webserver(alias)
81 Requires:       webserver(indexfile)
82 Requires:       webserver(php) >= 4.2.0
83 Suggests:       localedb
84 Suggests:       php(mcrypt)
85 Suggests:       php(openssl)
86 Suggests:       php-pear-Net_POP3
87 Suggests:       webserver(setenv)
88 Provides:       group(eventum)
89 Provides:       user(eventum)
90 Obsoletes:      eventum-base < 3.0.3-1.305
91 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
92 Obsoletes:      eventum-route-emails < 3.0.8-1.1
93 Obsoletes:      eventum-route-notes < 3.0.8-1.1
94 Conflicts:      logrotate < 3.8.0
95 BuildArch:      noarch
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %define         _libdir         %{_prefix}/lib/%{name}
99 %define         _appdir         %{_datadir}/%{name}
100 %define         _smartydir      %{php_data_dir}/Smarty
101 %define         _webapps        /etc/webapps
102 %define         _webapp         %{name}
103 %define         _webappdir      %{_webapps}/%{_webapp}
104 %define         _sysconfdir     /etc/%{name}
105
106 %description
107 Eventum is a user-friendly and flexible issue tracking system that can
108 be used by a support department to track incoming technical support
109 requests, or by a software development team to quickly organize tasks
110 and bugs.
111
112 %description -l pl.UTF-8
113 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
114 może być używany przez dział obsługi do śledzenia przychodzących żądań
115 obsługi technicznej albo przez zespół tworzący oprogramowanie do
116 szybkiej organizacji zadań i błędów.
117
118 %package setup
119 Summary:        Eventum setup package
120 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
121 Group:          Applications/WWW
122 Requires:       %{name} = %{version}-%{release}
123
124 %description setup
125 Install this package to configure initial Eventum installation. You
126 should uninstall this package when you're done, as it considered
127 insecure to keep the setup files in place.
128
129 %description setup -l pl.UTF-8
130 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
131 pierwszej instalacji. Potem należy go odinstalować, jako że
132 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
133
134 %package doc
135 Summary:        Eventum documentation and Wiki
136 Group:          Documentation
137
138 %description doc
139 Eventum documentation and copy of Wiki.
140
141 %package mail-queue
142 Summary:        Eventum mail queue process
143 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
144 Group:          Applications/WWW
145 Requires:       %{name} = %{version}-%{release}
146 Requires:       crondaemon
147
148 %description mail-queue
149 Beginning with the first release of Eventum, emails are not directly
150 sent out from the various scripts, but rather added to a mail queue
151 table that is processed by a cron job. If an email cannot be sent, it
152 will be marked as such in the mail queue log, and the cron job script
153 will re-try to send it again the next time it runs.
154
155 This package contains the cron job.
156
157 %description mail-queue -l pl.UTF-8
158 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
159 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
160 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
161 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
162 następnym razem.
163
164 Ten pakiet zawiera zadanie dla crona.
165
166 %package mail-download
167 Summary:        Eventum email download
168 Summary(pl.UTF-8):      Ściąganie poczty Eventum
169 Group:          Applications/WWW
170 Requires:       %{name} = %{version}-%{release}
171 Requires:       crondaemon
172
173 %description mail-download
174 In order for Eventum's email integration feature to work, you need to
175 setup a cron job to run the script every so often.
176
177 This package contains the cron job.
178
179 %description mail-download -l pl.UTF-8
180 Aby integracja poczty elektronicznej w Eventum działała, trzeba
181 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
182 często.
183
184 Ten pakiet zawiera zadanie dla crona.
185
186 %package reminder
187 Summary:        Eventum Reminder System
188 Summary(pl.UTF-8):      System przypominania dla Eventum
189 Group:          Applications/WWW
190 Requires:       %{name} = %{version}-%{release}
191 Requires:       crondaemon
192
193 %description reminder
194 The reminder system was designed with the objective as serving as a
195 safe net for issues that need attention. Depending on what
196 configuration you create, you may have several reminders (or alerts)
197 be sent out whenever an issue needs attention, for whatever parameter
198 you may deem necessary.
199
200 This package contains the cron job.
201
202 %description reminder -l pl.UTF-8
203 System przypominania został zaprojektowany tak, aby służył jako
204 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
205 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
206 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
207 uważać za potrzebny.
208
209 Ten pakiet zawiera zadanie dla crona.
210
211 %package monitor
212 Summary:        Eventum Heartbeat Monitor
213 Summary(pl.UTF-8):      Monitor życia dla Eventum
214 Group:          Applications/WWW
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       crondaemon
217 Requires:       php(posix)
218
219 %description monitor
220 The heartbeat monitor is a feature designed for the administrator that
221 wants to be alerted whenever a common problem in Eventum is detected,
222 like the database server not being available anymore, or maybe when
223 the recommended permissions for certain configuration files are
224 changed.
225
226 Please note that before running the heartbeat monitor, you may need to
227 customize some of the checks to be appropriate for your own system,
228 particularly the permission and file checks on
229 Monitor::checkConfiguration().
230
231 This package contains the cron job.
232
233 %description monitor -l pl.UTF-8
234 Monitor życia to funkcjonalność zaprojektowana dla administratora
235 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
236 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
237 do plików konfiguracyjnych.
238
239 Należy zauważyć, że przed uruchomieniem tego monitora może być
240 konieczne dostosowanie niektórych testów do systemu, w szczególności
241 testów uprawnień i plików w Monitor::checkConfiguration().
242
243 Ten pakiet zawiera zadanie dla crona.
244
245 %package router-postfix
246 Summary:        Eventum Mail Routing - Postfix
247 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
248 Group:          Applications/Mail
249 Requires:       %{name} = %{version}-%{release}
250 Requires:       postfix
251 Provides:       eventum(router)
252 Obsoletes:      eventum(router)
253
254 %description router-postfix
255 This package provides way of routing notes and emails back to Eventum
256 via Postfix.
257
258 The Postfix configuration instructions you can find from
259 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
260
261 %description router-postfix -l pl.UTF-8
262 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
263 przez Postfiksa.
264
265 Opis konfiguracji Postfiksa można znaleźć pod adresem
266 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
267
268 %package cli
269 Summary:        Eventum command-line interface
270 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
271 Group:          Applications/WWW
272 Requires:       php(core) >= %{php_min_version}
273 Requires:       php(phar)
274
275 %description cli
276 The Eventum command-line interface allows you to access most of the
277 features of the web interface straight from your command shell.
278
279 %description cli -l pl.UTF-8
280 Interfejs linii poleceń Eventum pozwala na dostęp do większości
281 funkcji interfejsu WWW prosto z linii poleceń powłoki.
282
283 %package sphinx
284 Summary:        Eventum Sphinx Search
285 Group:          Applications/WWW
286 Requires:       %{name} = %{version}-%{release}
287 Requires:       crondaemon
288 Requires:       sphinx
289
290 %description sphinx
291 Sphinx search integration for Eventum.
292
293 This package contains the cron job.
294
295 %prep
296 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
297
298 mv docs/examples .
299
300 # bug fixes / features
301 %{?with_order:%patch2 -p1}
302 #%patch3 -p0
303 #%patch4 -p1
304
305 %{?with_order:cp -p %{SOURCE16} htdocs/images}
306
307 #%patch200 -p1
308
309 # produce default sphinx config
310 # must be run before paths.patch
311 %if 0
312 cat <<'EOF' > config/config.php
313 <?php
314 define('APP_SQL_DBTYPE', 'mysql');
315 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
316 define('APP_SQL_DBPORT', 3306);
317 define('APP_SQL_DBNAME', 'eventum');
318 define('APP_SQL_DBUSER', 'mysql');
319 define('APP_SQL_DBPASS', '');
320 define('APP_TABLE_PREFIX', 'eventum_');
321 EOF
322 php config/sphinx.conf.php > config/sphinx.conf
323 rm config/config.php
324 %endif
325
326 # packaging
327 %patch100 -p1
328 %patch107 -p1
329 %patch108 -p1
330
331 rm htdocs/.htaccess.dist
332
333 rm config/config.dist.php
334
335 # cleanup vendor. keep only needed libraries.
336 # (the rest are packaged with system packages)
337 mv vendor vendor.dist
338 vendor() {
339         local path dir
340         for path; do
341                 dir=$(dirname $path)
342                 test -d vendor/$dir || mkdir -p vendor/$dir
343                 mv vendor.dist/$path vendor/$path
344         done
345 }
346 vendor autoload.php
347 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
348 vendor composer/ClassLoader.php
349 vendor ircmaxell/{random-lib,security-lib}
350 vendor defuse/php-encryption
351 vendor willdurand/email-reply-parser
352 vendor theorchard/monolog-cascade
353 vendor malkusch/lock
354 vendor phpxmlrpc/phpxmlrpc
355 vendor robmorgan/phinx
356 vendor mnapoli/silly
357 vendor psr/container
358 vendor phlib/flysystem-pdo
359 vendor league/flysystem
360 vendor php-di/invoker
361 vendor container-interop/container-interop
362 vendor symfony/config
363 vendor symfony/console
364 vendor symfony/debug
365 vendor symfony/event-dispatcher
366 vendor symfony/filesystem
367 vendor symfony/http-foundation
368 vendor symfony/options-resolver
369 vendor symfony/serializer
370 vendor symfony/yaml
371 vendor symfony/ldap
372 vendor paragonie/random_compat
373 vendor symfony/polyfill-php70
374 vendor symfony/polyfill-intl-normalizer
375 vendor glen/filename-normalizer
376 vendor doctrine/annotations
377 vendor doctrine/cache
378 vendor doctrine/collections
379 vendor doctrine/common
380 vendor doctrine/dbal
381 vendor doctrine/inflector
382 vendor doctrine/instantiator
383 vendor doctrine/lexer
384 vendor doctrine/orm
385 vendor cebe/markdown
386 vendor enrise/urihelper
387
388 # remove backups from patching as we use globs to package files to buildroot
389 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
390
391 %build
392 %{__make} -C localization
393
394 %install
395 rm -rf $RPM_BUILD_ROOT
396 install -d \
397         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
398         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
399         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
400         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
401         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
402         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
403
404 %{__make} install-eventum install-cli install-localization \
405         sysconfdir=%{_webappdir} \
406         localedir=%{_localedir} \
407         DESTDIR=$RPM_BUILD_ROOT
408
409 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
410
411 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
412
413 # unsupported locale
414 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
415
416 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
417 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
418
419 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
420
421 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
422 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
423 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
424 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
425
426 install -d $RPM_BUILD_ROOT/etc/sphinx
427 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
428 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
429
430 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
431 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
432 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
433 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
434 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
435
436 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
437
438 # postfix router
439 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
440
441 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
442
443 %find_lang %{name}
444
445 %clean
446 rm -rf $RPM_BUILD_ROOT
447
448 %pre
449 %groupadd -g 146 %{name}
450 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
451 %addusertogroup http %{name}
452
453 %post
454 # create empty ghost files
455 # these permissions ensure the logs are write only
456 for a in \
457         errors.log login_attempts.log \
458         eventum.log \
459         auth.log cli.log \
460 ; do
461         test -f /var/log/%{name}/$a && continue
462         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
463 done
464
465 # run database update if configured
466 test -s %{_webappdir}/config.php && \
467 sudo -H -u http -- %{_appdir}/bin/upgrade.php || :
468
469 # nuke Smarty templates cache after upgrade
470 rm -f /var/cache/eventum/*.php
471
472 # Restart webserver on upgrade to get .mo translations reloaded.
473 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
474 %php_webserver_restart
475
476 %preun
477 if [ "$1" = "0" ]; then
478         # nuke cache
479         rm -f /var/cache/eventum/*.php 2>/dev/null || :
480 fi
481
482 %postun
483 if [ "$1" = "0" ]; then
484         %userremove %{name}
485         %groupremove %{name}
486 fi
487
488 %post setup
489 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
490 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
491
492 %postun setup
493 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
494         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
495         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
496 fi
497
498 %triggerin -- apache1 < 1.3.37-3, apache1-base
499 %webapp_register apache %{_webapp}
500
501 %triggerun -- apache1 < 1.3.37-3, apache1-base
502 %webapp_unregister apache %{_webapp}
503
504 %triggerin -- apache < 2.2.0, apache-base
505 %webapp_register httpd %{_webapp}
506
507 %triggerun -- apache < 2.2.0, apache-base
508 %webapp_unregister httpd %{_webapp}
509
510 %triggerin -- lighttpd
511 %webapp_register lighttpd %{_webapp}
512
513 %triggerun -- lighttpd
514 %webapp_unregister lighttpd %{_webapp}
515
516 %triggerpostun -- %{name} < 3.0.0-0.2
517 for f in /etc/cron.d/eventum-*; do
518         # crontabs moved to bin
519         %{__sed} -i -e '
520                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
521                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
522                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
523                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
524         ' $f
525 done
526
527 %files -f %{name}.lang
528 %defattr(644,root,root,755)
529 %attr(771,root,http) %dir %{_webappdir}
530 %attr(751,root,http) %dir %{_webappdir}/crm
531 %attr(751,root,http) %dir %{_webappdir}/custom_field
532 %attr(751,root,http) %dir %{_webappdir}/partner
533 %attr(751,root,http) %dir %{_webappdir}/templates
534 %attr(751,root,http) %dir %{_webappdir}/workflow
535 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
536 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
537 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
538 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
539 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
540 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
541 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
542 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
543
544 %dir %attr(731,root,http) /var/log/%{name}
545 %attr(620,root,http) %ghost /var/log/%{name}/*
546 %dir %attr(750,root,root) /var/log/archive/%{name}
547 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
548
549 %dir %{_appdir}
550 %{_appdir}/config
551
552 %dir %{_appdir}/bin
553 %attr(755,root,root) %{_appdir}/bin/extension.php
554 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
555 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
556 %attr(755,root,root) %{_appdir}/bin/upgrade.php
557
558 %{_appdir}/autoload.php
559 %{_appdir}/globals.php
560 %{_appdir}/init.php
561 %{_appdir}/phinx.php
562 %dir %{_appdir}/htdocs
563 %{_appdir}/htdocs/*.php
564 %{_appdir}/htdocs/*.ico
565 %{_appdir}/htdocs/ajax
566 %{_appdir}/htdocs/css
567 %{_appdir}/htdocs/customer
568 %{_appdir}/htdocs/images
569 %{_appdir}/htdocs/js
570 %{_appdir}/htdocs/manage
571 %{_appdir}/htdocs/reports
572 %{_appdir}/htdocs/rpc
573 %{_appdir}/htdocs/components
574 %{_appdir}/templates
575
576 %dir %{_appdir}/db
577 %dir %{_appdir}/db/migrations
578 %{_appdir}/db/migrations/*.php
579
580 %{_appdir}/res
581 %{_appdir}/src
582 %{_appdir}/vendor
583 %dir %{_appdir}/lib
584 %{_appdir}/lib/eventum
585 %exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
586 %exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
587 %exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
588 %exclude %{_appdir}/src/Console/Command/MonitorCommand.php
589 %exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
590
591 %dir %{_libdir}
592
593 %{systemdtmpfilesdir}/%{name}.conf
594
595 %dir /var/lib/%{name}
596 %dir %attr(730,root,http) /var/run/%{name}
597 %dir %attr(730,root,http) /var/cache/%{name}
598
599 # saved mail copies
600 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
601 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
602 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
603 # attachment storage
604 %attr(770,root,http) %dir /var/lib/%{name}/storage
605
606 %files setup
607 %defattr(644,root,root,755)
608 %{_appdir}/htdocs/setup
609
610 %files doc
611 %defattr(644,root,root,755)
612 %doc docs/*
613 %{_examplesdir}/%{name}-%{version}
614
615 %files mail-queue
616 %defattr(644,root,root,755)
617 %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
618 %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
619 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
620 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
621 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
622
623 %files mail-download
624 %defattr(644,root,root,755)
625 %{_appdir}/src/Console/Command/MailDownloadCommand.php
626 %attr(755,root,root) %{_appdir}/bin/download_emails.php
627 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
628
629 %files reminder
630 %defattr(644,root,root,755)
631 %{_appdir}/src/Console/Command/ReminderCheckCommand.php
632 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
633 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
634
635 %files monitor
636 %defattr(644,root,root,755)
637 %{_appdir}/src/Console/Command/MonitorCommand.php
638 %attr(755,root,root) %{_appdir}/bin/monitor.php
639 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
640
641 %files router-postfix
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/router-postfix
644
645 %files cli
646 %defattr(644,root,root,755)
647 %doc cli/eventumrc
648 %attr(755,root,root) %{_bindir}/%{name}
649
650 %files sphinx
651 %defattr(644,root,root,755)
652 %{_webappdir}/sphinx.conf.php
653 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
654 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.113046 seconds and 2 git commands to generate.