]> git.pld-linux.org Git - packages/eventum.git/blame_incremental - eventum.spec
Up to 3.10.12
[packages/eventum.git] / eventum.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with order # with experimental order patch
4
5%define rel 1
6#define subver 189
7#define githash 7b4eddae
8%define php_min_version 5.6.0
9%include /usr/lib/rpm/macros.php
10Summary: Eventum Issue / Bug tracking system
11Summary(pl.UTF-8): Eventum - system śledzenia spraw/błędów
12Name: eventum
13Version: 3.3.4
14Release: %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15License: GPL v2+
16Group: Applications/WWW
17Source0: https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18# Source0-md5: f2fc7059a2b864000180cf7be00ad3c4
19#Source0: https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.gz
20Source1: %{name}-apache.conf
21Source2: %{name}-mail-queue.cron
22Source3: %{name}-mail-download.cron
23Source4: %{name}-reminder.cron
24Source5: %{name}-monitor.cron
25Source8: %{name}-irc.init
26Source9: %{name}-irc.sysconfig
27Source10: sphinx.crontab
28Source13: %{name}-router-postfix.sh
29Source14: %{name}.logrotate
30Source15: %{name}-lighttpd.conf
31Source16: http://www.isocra.com/images/updown2.gif
32# Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
33Source17: %{name}.tmpfiles
34Patch2: %{name}-order.patch
35#Patch3: group-users.patch
36#Patch4: https://github.com/glensc/eventum/compare/cf_escape.patch
37# packaging patches that probably never go upstream
38Patch100: %{name}-paths.patch
39Patch107: %{name}-gettext.patch
40Patch108: autoload.patch
41# some tests
42Patch200: %{name}-fixed-nav.patch
43URL: https://wiki.github.com/eventum/eventum/
44BuildRequires: gettext-tools
45BuildRequires: rpm-php-pearprov >= 4.0.2-98
46BuildRequires: rpmbuild(macros) >= 1.654
47BuildRequires: sed >= 4.0
48Requires(postun): /usr/sbin/groupdel
49Requires(postun): /usr/sbin/userdel
50Requires(pre): /bin/id
51Requires(pre): /usr/bin/getgid
52Requires(pre): /usr/sbin/groupadd
53Requires(pre): /usr/sbin/useradd
54Requires: fonts-TTF-RedHat-liberation
55Requires: php(core) >= %{php_min_version}
56Requires: php(filter)
57Requires: php(iconv)
58Requires: php(imap)
59Requires: php(json)
60Requires: php(mbstring)
61Requires: php(pcre)
62Requires: php(pdo_mysql)
63Requires: php(session)
64Requires: php-Smarty >= 3.1
65Requires: php-Smarty-plugin-gettext
66Requires: php-ZendFramework-Config >= 2.4
67Requires: php-ZendFramework-Loader >= 2.4
68Requires: php-ZendFramework-Mail >= 2.4.11-4
69Requires: php-ZendFramework-Mime >= 2.4
70Requires: php-ZendFramework-ServiceManager >= 2.4
71Requires: php-ZendFramework-Validator >= 2.4
72Requires: php-monolog >= 1.17.2
73Requires: php-pear-Mail_Mime
74Requires: php-pear-Mail_mimeDecode
75Requires: php-pear-Math_Stats
76Requires: php-pear-Net_SMTP
77Requires: php-pear-Net_Socket
78Requires: php-pear-Net_URL
79Requires: php-pear-PEAR-core
80Requires: php-pear-Text_Diff
81Requires: php-psr-Log >= 1.0.0-2
82Requires: phplot >= 5.8.0
83Requires: webapps
84Requires: webserver(access)
85Requires: webserver(alias)
86Requires: webserver(indexfile)
87Requires: webserver(php) >= 4.2.0
88Suggests: localedb
89Suggests: php(mcrypt)
90Suggests: php(openssl)
91Suggests: php-pear-Net_POP3
92Suggests: webserver(setenv)
93Provides: group(eventum)
94Provides: user(eventum)
95Obsoletes: eventum-base < 3.0.3-1.305
96Obsoletes: eventum-route-drafts < 3.0.8-1.1
97Obsoletes: eventum-route-emails < 3.0.8-1.1
98Obsoletes: eventum-route-notes < 3.0.8-1.1
99Conflicts: logrotate < 3.8.0
100BuildArch: noarch
101BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103%define _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Auth/SASL.* Util.php smarty_internal.*
104
105# exclude optional php dependencies
106%define _noautophp php-gnupg php-hash php-pecl-http php-tk
107
108%define _noautoreq %{_noautophp}
109
110%define _libdir %{_prefix}/lib/%{name}
111%define _appdir %{_datadir}/%{name}
112%define _smartydir %{php_data_dir}/Smarty
113%define _webapps /etc/webapps
114%define _webapp %{name}
115%define _webappdir %{_webapps}/%{_webapp}
116%define _sysconfdir /etc/%{name}
117
118%description
119Eventum is a user-friendly and flexible issue tracking system that can
120be used by a support department to track incoming technical support
121requests, or by a software development team to quickly organize tasks
122and bugs.
123
124%description -l pl.UTF-8
125Eventum to przyjazny dla użytkownika system śledzenia spraw, który
126może być używany przez dział obsługi do śledzenia przychodzących żądań
127obsługi technicznej albo przez zespół tworzący oprogramowanie do
128szybkiej organizacji zadań i błędów.
129
130%package setup
131Summary: Eventum setup package
132Summary(pl.UTF-8): Pakiet do wstępnej konfiguracji Eventum
133Group: Applications/WWW
134Requires: %{name} = %{version}-%{release}
135
136%description setup
137Install this package to configure initial Eventum installation. You
138should uninstall this package when you're done, as it considered
139insecure to keep the setup files in place.
140
141%description setup -l pl.UTF-8
142Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
143pierwszej instalacji. Potem należy go odinstalować, jako że
144pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
145
146%package doc
147Summary: Eventum documentation and Wiki
148Group: Documentation
149
150%description doc
151Eventum documentation and copy of Wiki.
152
153%package mail-queue
154Summary: Eventum mail queue process
155Summary(pl.UTF-8): Przetwarzanie kolejki poczty Eventum
156Group: Applications/WWW
157Requires: %{name} = %{version}-%{release}
158Requires: crondaemon
159
160%description mail-queue
161Beginning with the first release of Eventum, emails are not directly
162sent out from the various scripts, but rather added to a mail queue
163table that is processed by a cron job. If an email cannot be sent, it
164will be marked as such in the mail queue log, and the cron job script
165will re-try to send it again the next time it runs.
166
167This package contains the cron job.
168
169%description mail-queue -l pl.UTF-8
170Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
171różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
172Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
173kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
174następnym razem.
175
176Ten pakiet zawiera zadanie dla crona.
177
178%package mail-download
179Summary: Eventum email download
180Summary(pl.UTF-8): Ściąganie poczty Eventum
181Group: Applications/WWW
182Requires: %{name} = %{version}-%{release}
183Requires: crondaemon
184
185%description mail-download
186In order for Eventum's email integration feature to work, you need to
187setup a cron job to run the script every so often.
188
189This package contains the cron job.
190
191%description mail-download -l pl.UTF-8
192Aby integracja poczty elektronicznej w Eventum działała, trzeba
193ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
194często.
195
196Ten pakiet zawiera zadanie dla crona.
197
198%package reminder
199Summary: Eventum Reminder System
200Summary(pl.UTF-8): System przypominania dla Eventum
201Group: Applications/WWW
202Requires: %{name} = %{version}-%{release}
203Requires: crondaemon
204
205%description reminder
206The reminder system was designed with the objective as serving as a
207safe net for issues that need attention. Depending on what
208configuration you create, you may have several reminders (or alerts)
209be sent out whenever an issue needs attention, for whatever parameter
210you may deem necessary.
211
212This package contains the cron job.
213
214%description reminder -l pl.UTF-8
215System przypominania został zaprojektowany tak, aby służył jako
216bezpieczna sieć dla spraw wymagających uwagi. W zależności od
217konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
218przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
219uważać za potrzebny.
220
221Ten pakiet zawiera zadanie dla crona.
222
223%package monitor
224Summary: Eventum Heartbeat Monitor
225Summary(pl.UTF-8): Monitor życia dla Eventum
226Group: Applications/WWW
227Requires: %{name} = %{version}-%{release}
228Requires: crondaemon
229Requires: php(posix)
230
231%description monitor
232The heartbeat monitor is a feature designed for the administrator that
233wants to be alerted whenever a common problem in Eventum is detected,
234like the database server not being available anymore, or maybe when
235the recommended permissions for certain configuration files are
236changed.
237
238Please note that before running the heartbeat monitor, you may need to
239customize some of the checks to be appropriate for your own system,
240particularly the permission and file checks on
241Monitor::checkConfiguration().
242
243This package contains the cron job.
244
245%description monitor -l pl.UTF-8
246Monitor życia to funkcjonalność zaprojektowana dla administratora
247chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
248Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
249do plików konfiguracyjnych.
250
251Należy zauważyć, że przed uruchomieniem tego monitora może być
252konieczne dostosowanie niektórych testów do systemu, w szczególności
253testów uprawnień i plików w Monitor::checkConfiguration().
254
255Ten pakiet zawiera zadanie dla crona.
256
257%package router-postfix
258Summary: Eventum Mail Routing - Postfix
259Summary(pl.UTF-8): Przekazywanie poczty Eventum - Postfix
260Group: Applications/Mail
261Requires: %{name} = %{version}-%{release}
262Requires: postfix
263Provides: eventum(router)
264Obsoletes: eventum(router)
265
266%description router-postfix
267This package provides way of routing notes and emails back to Eventum
268via Postfix.
269
270The Postfix configuration instructions you can find from
271<https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
272
273%description router-postfix -l pl.UTF-8
274Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
275przez Postfiksa.
276
277Opis konfiguracji Postfiksa można znaleźć pod adresem
278<https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
279
280%package irc
281Summary: Eventum IRC Notification Bot
282Summary(pl.UTF-8): IRC-owy bot powiadamiający dla Eventum
283Group: Applications/WWW
284Requires(post,preun): /sbin/chkconfig
285Requires: %{name} = %{version}-%{release}
286Requires: php(pcntl)
287Requires: php(sockets)
288Requires: php-pear-Net_SmartIRC >= 1.1.9
289Requires: rc-scripts >= 0.4.0.18
290
291%description irc
292The IRC notification bot is a nice feature for remote teams that want
293to handle issues and want to have a quick and easy way to get simple
294notifications. Right now the bot notifies of the following actions:
295- New Issues
296- Blocked emails
297- Issues that got their assignment list changed
298
299NOTE: You will need to manually edit the bot.php script to set your
300appropriate preferences, like IRC server and channel that the bot
301should join.
302
303%description irc -l pl.UTF-8
304IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
305zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
306uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
307następujących zdarzeniach:
308- nowych sprawach
309- zablokowanych listach
310- sprawach, dla których zmieniła się lista powiązań
311
312UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
313kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
314
315%package cli
316Summary: Eventum command-line interface
317Summary(pl.UTF-8): Interfejs linii poleceń dla Eventum
318Group: Applications/WWW
319Requires: php(core) >= %{php_min_version}
320Requires: php(phar)
321
322%description cli
323The Eventum command-line interface allows you to access most of the
324features of the web interface straight from your command shell.
325
326%description cli -l pl.UTF-8
327Interfejs linii poleceń Eventum pozwala na dostęp do większości
328funkcji interfejsu WWW prosto z linii poleceń powłoki.
329
330%package sphinx
331Summary: Eventum Sphinx Search
332Group: Applications/WWW
333Requires: %{name} = %{version}-%{release}
334Requires: crondaemon
335Requires: sphinx
336
337%description sphinx
338Sphinx search integration for Eventum.
339
340This package contains the cron job.
341
342%prep
343%setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
344
345mv docs/examples .
346
347# bug fixes / features
348%{?with_order:%patch2 -p1}
349#%patch3 -p0
350#%patch4 -p1
351
352%{?with_order:cp -p %{SOURCE16} htdocs/images}
353
354#%patch200 -p1
355
356# produce default sphinx config
357# must be run before paths.patch
358%if 0
359cat <<'EOF' > config/config.php
360<?php
361define('APP_SQL_DBTYPE', 'mysql');
362define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
363define('APP_SQL_DBPORT', 3306);
364define('APP_SQL_DBNAME', 'eventum');
365define('APP_SQL_DBUSER', 'mysql');
366define('APP_SQL_DBPASS', '');
367define('APP_TABLE_PREFIX', 'eventum_');
368EOF
369php config/sphinx.conf.php > config/sphinx.conf
370rm config/config.php
371%endif
372
373# packaging
374%patch100 -p1
375%patch107 -p1
376%patch108 -p1
377
378rm htdocs/.htaccess.dist
379
380mv config/irc_config{.dist.php,.php}
381rm config/config.dist.php
382
383# cleanup vendor. keep only needed libraries.
384# (the rest are packaged with system packages)
385mv vendor vendor.dist
386vendor() {
387 local path dir
388 for path; do
389 dir=$(dirname $path)
390 test -d vendor/$dir || mkdir -p vendor/$dir
391 mv vendor.dist/$path vendor/$path
392 done
393}
394vendor autoload.php
395vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
396vendor composer/ClassLoader.php
397vendor ircmaxell/{random-lib,security-lib}
398vendor defuse/php-encryption
399vendor willdurand/email-reply-parser
400vendor theorchard/monolog-cascade
401vendor malkusch/lock
402vendor phpxmlrpc/phpxmlrpc
403vendor robmorgan/phinx
404vendor mnapoli/silly
405vendor psr/container
406vendor phlib/flysystem-pdo
407vendor league/flysystem
408vendor php-di/invoker
409vendor container-interop/container-interop
410vendor symfony/config
411vendor symfony/console
412vendor symfony/debug
413vendor symfony/event-dispatcher
414vendor symfony/filesystem
415vendor symfony/http-foundation
416vendor symfony/options-resolver
417vendor symfony/serializer
418vendor symfony/yaml
419vendor symfony/ldap
420
421# remove backups from patching as we use globs to package files to buildroot
422find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
423
424%build
425%{__make} -C localization
426
427%install
428rm -rf $RPM_BUILD_ROOT
429install -d \
430 $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
431 $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
432 $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
433 $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
434 $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
435 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
436
437%{__make} install-eventum install-cli install-localization \
438 sysconfdir=%{_webappdir} \
439 localedir=%{_localedir} \
440 DESTDIR=$RPM_BUILD_ROOT
441
442ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
443
444cp -a vendor $RPM_BUILD_ROOT%{_appdir}
445
446# unsupported locale
447%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
448
449install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
450cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
451
452%{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
453
454touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
455cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
456cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
457cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
458
459install -d $RPM_BUILD_ROOT/etc/sphinx
460#cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
461cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
462
463cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
464cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
465cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
466cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
467cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
468
469install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
470cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
471
472cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
473
474# postfix router
475install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
476
477cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
478
479%find_lang %{name}
480
481%clean
482rm -rf $RPM_BUILD_ROOT
483
484%pre
485%groupadd -g 146 %{name}
486%useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
487%addusertogroup http %{name}
488
489%post
490# create empty ghost files
491# these permissions ensure the logs are write only
492for a in \
493 errors.log login_attempts.log \
494 eventum.log \
495 auth.log cli.log \
496 irc_bot_error.log irc_bot_smartirc.log \
497; do
498 test -f /var/log/%{name}/$a && continue
499 install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
500done
501
502# run database update if configured
503test -s %{_webappdir}/config.php && \
504%{_appdir}/bin/upgrade.php || :
505
506# nuke Smarty templates cache after upgrade
507rm -f /var/cache/eventum/*.php
508
509# Restart webserver on upgrade to get .mo translations reloaded.
510# actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
511%php_webserver_restart
512
513%preun
514if [ "$1" = "0" ]; then
515 # nuke cache
516 rm -f /var/cache/eventum/*.php 2>/dev/null || :
517fi
518
519%postun
520if [ "$1" = "0" ]; then
521 %userremove %{name}
522 %groupremove %{name}
523fi
524
525%post setup
526chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
527chown root:http %{_webappdir}/{config,private_key,secret_key}.php
528
529%postun setup
530if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
531 chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
532 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
533fi
534
535%post irc
536/sbin/chkconfig --add eventum-irc
537%service eventum-irc restart "Eventum IRC Bot"
538
539%preun irc
540if [ "$1" = 0 ]; then
541 %service eventum-irc stop
542 /sbin/chkconfig --del eventum-irc
543fi
544
545%triggerin -- apache1 < 1.3.37-3, apache1-base
546%webapp_register apache %{_webapp}
547
548%triggerun -- apache1 < 1.3.37-3, apache1-base
549%webapp_unregister apache %{_webapp}
550
551%triggerin -- apache < 2.2.0, apache-base
552%webapp_register httpd %{_webapp}
553
554%triggerun -- apache < 2.2.0, apache-base
555%webapp_unregister httpd %{_webapp}
556
557%triggerin -- lighttpd
558%webapp_register lighttpd %{_webapp}
559
560%triggerun -- lighttpd
561%webapp_unregister lighttpd %{_webapp}
562
563%triggerpostun -- %{name} < 3.0.0-0.2
564for f in /etc/cron.d/eventum-*; do
565 # crontabs moved to bin
566 %{__sed} -i -e '
567 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
568 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
569 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
570 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
571 ' $f
572done
573
574%files -f %{name}.lang
575%defattr(644,root,root,755)
576%attr(751,root,root) %dir %{_webappdir}
577%attr(751,root,http) %dir %{_webappdir}/crm
578%attr(751,root,http) %dir %{_webappdir}/custom_field
579%attr(751,root,http) %dir %{_webappdir}/partner
580%attr(751,root,http) %dir %{_webappdir}/templates
581%attr(751,root,http) %dir %{_webappdir}/workflow
582%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
583%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
584%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
585%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
586%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
587%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
588%attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
589%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
590
591%dir %attr(731,root,http) /var/log/%{name}
592%attr(620,root,http) %ghost /var/log/%{name}/*
593%dir %attr(750,root,root) /var/log/archive/%{name}
594%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
595
596%dir %{_appdir}
597%{_appdir}/config
598
599%dir %{_appdir}/bin
600%attr(755,root,root) %{_appdir}/bin/extension.php
601%attr(755,root,root) %{_appdir}/bin/ldapsync.php
602%attr(755,root,root) %{_appdir}/bin/process_all_emails.php
603%attr(755,root,root) %{_appdir}/bin/upgrade.php
604
605%{_appdir}/autoload.php
606%{_appdir}/globals.php
607%{_appdir}/init.php
608%{_appdir}/phinx.php
609%dir %{_appdir}/htdocs
610%{_appdir}/htdocs/*.php
611%{_appdir}/htdocs/*.ico
612%{_appdir}/htdocs/ajax
613%{_appdir}/htdocs/css
614%{_appdir}/htdocs/customer
615%{_appdir}/htdocs/images
616%{_appdir}/htdocs/js
617%{_appdir}/htdocs/manage
618%{_appdir}/htdocs/reports
619%{_appdir}/htdocs/rpc
620%{_appdir}/htdocs/components
621%{_appdir}/templates
622
623%dir %{_appdir}/db
624%dir %{_appdir}/db/migrations
625%{_appdir}/db/migrations/*.php
626
627%{_appdir}/res
628%{_appdir}/src
629%{_appdir}/vendor
630%dir %{_appdir}/lib
631%{_appdir}/lib/eventum
632%exclude %{_appdir}/src/Command/MailDownloadCommand.php
633%exclude %{_appdir}/src/Command/MailQueueProcessCommand.php
634%exclude %{_appdir}/src/Command/MailQueueTruncateCommand.php
635%exclude %{_appdir}/src/Command/MonitorCommand.php
636%exclude %{_appdir}/src/Command/ReminderCheckCommand.php
637
638%dir %{_libdir}
639
640%{systemdtmpfilesdir}/%{name}.conf
641
642%dir /var/lib/%{name}
643%dir %attr(730,root,http) /var/run/%{name}
644%dir %attr(730,root,http) /var/cache/%{name}
645
646# saved mail copies
647%attr(770,root,http) %dir /var/lib/%{name}/routed_emails
648%attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
649%attr(770,root,http) %dir /var/lib/%{name}/routed_notes
650# attachment storage
651%attr(770,root,http) %dir /var/lib/%{name}/storage
652
653%files setup
654%defattr(644,root,root,755)
655%{_appdir}/htdocs/setup
656
657%files doc
658%defattr(644,root,root,755)
659%doc docs/*
660%{_examplesdir}/%{name}-%{version}
661
662%files mail-queue
663%defattr(644,root,root,755)
664%{_appdir}/src/Command/MailQueueProcessCommand.php
665%{_appdir}/src/Command/MailQueueTruncateCommand.php
666%attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
667%attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
668%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
669
670%files mail-download
671%defattr(644,root,root,755)
672%{_appdir}/src/Command/MailDownloadCommand.php
673%attr(755,root,root) %{_appdir}/bin/download_emails.php
674%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
675
676%files reminder
677%defattr(644,root,root,755)
678%{_appdir}/src/Command/ReminderCheckCommand.php
679%attr(755,root,root) %{_appdir}/bin/check_reminders.php
680%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
681
682%files monitor
683%defattr(644,root,root,755)
684%{_appdir}/src/Command/MonitorCommand.php
685%attr(755,root,root) %{_appdir}/bin/monitor.php
686%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
687
688%files router-postfix
689%defattr(644,root,root,755)
690%attr(755,root,root) %{_libdir}/router-postfix
691
692%files irc
693%defattr(644,root,root,755)
694%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
695%attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
696%attr(755,root,root) %{_appdir}/bin/irc-bot.php
697%attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
698
699%files cli
700%defattr(644,root,root,755)
701%doc cli/eventumrc
702%attr(755,root,root) %{_bindir}/%{name}
703
704%files sphinx
705%defattr(644,root,root,755)
706%{_webappdir}/sphinx.conf.php
707#%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
708%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.071902 seconds and 4 git commands to generate.