]> git.pld-linux.org Git - packages/evas.git/commitdiff
- updated to 1.2.0
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 27 May 2012 18:07:10 +0000 (18:07 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- removed obsolete automake patch
- added wayland patch to fix wayland_egl engine build
- software_sdl engine has been dropped (Obsoletes added to software_16_sdl)
- reintroduced software_16 engine
- added software_16_x11, wayland_egl, wayland_shm engines

Changed files:
    automake.patch -> 1.2
    evas-wayland.patch -> 1.1
    evas.spec -> 1.82

automake.patch [deleted file]
evas-wayland.patch [new file with mode: 0644]
evas.spec

diff --git a/automake.patch b/automake.patch
deleted file mode 100644 (file)
index ddf42dd..0000000
+++ /dev/null
@@ -1,85 +0,0 @@
---- evas-1.1.0/src/examples/Makefile.am~       2011-08-19 01:12:39.000000000 +0200
-+++ evas-1.1.0/src/examples/Makefile.am        2012-01-19 10:15:16.996821486 +0100
-@@ -28,68 +28,68 @@ AM_CPPFLAGS = \
- AM_CFLAGS = @WIN32_CFLAGS@
--pkglib_PROGRAMS =
-+pkglibexec_PROGRAMS =
- if BUILD_ENGINE_BUFFER
- AM_CPPFLAGS += -I$(top_srcdir)/src/modules/engines/buffer
--pkglib_PROGRAMS += evas_buffer_simple
-+pkglibexec_PROGRAMS += evas_buffer_simple
- evas_buffer_simple_SOURCES = evas-buffer-simple.c
- evas_buffer_simple_LDADD = $(top_builddir)/src/lib/libevas.la
- endif
--pkglib_PROGRAMS += evas_init_shutdown
-+pkglibexec_PROGRAMS += evas_init_shutdown
- evas_init_shutdown_SOURCES = evas-init-shutdown.c
- evas_init_shutdown_LDADD = $(top_builddir)/src/lib/libevas.la
- #the ones using ecore_evas follow
- AM_CPPFLAGS += @ECORE_EVAS_CFLAGS@
--pkglib_PROGRAMS += evas_images
-+pkglibexec_PROGRAMS += evas_images
- evas_images_SOURCES = evas-images.c
- evas_images_LDADD = $(top_builddir)/src/lib/libevas.la @ECORE_EVAS_LIBS@
--pkglib_PROGRAMS += evas_events
-+pkglibexec_PROGRAMS += evas_events
- evas_events_SOURCES = evas-events.c
- evas_events_LDADD = $(top_builddir)/src/lib/libevas.la @ECORE_EVAS_LIBS@
--pkglib_PROGRAMS += evas_object_manipulation
-+pkglibexec_PROGRAMS += evas_object_manipulation
- evas_object_manipulation_SOURCES = evas-object-manipulation.c
- evas_object_manipulation_LDADD = $(top_builddir)/src/lib/libevas.la @ECORE_EVAS_LIBS@
--pkglib_PROGRAMS += evas_hints
-+pkglibexec_PROGRAMS += evas_hints
- evas_hints_SOURCES = evas-hints.c
- evas_hints_LDADD = $(top_builddir)/src/lib/libevas.la @ECORE_EVAS_LIBS@
--pkglib_PROGRAMS += evas_stacking
-+pkglibexec_PROGRAMS += evas_stacking
- evas_stacking_SOURCES = evas-stacking.c
- evas_stacking_LDADD = $(top_builddir)/src/lib/libevas.la @ECORE_EVAS_LIBS@
--pkglib_PROGRAMS += evas_images2
-+pkglibexec_PROGRAMS += evas_images2
- evas_images2_SOURCES = evas-images2.c
- evas_images2_LDADD = $(top_builddir)/src/lib/libevas.la @ECORE_EVAS_LIBS@
--pkglib_PROGRAMS += evas_text
-+pkglibexec_PROGRAMS += evas_text
- evas_text_SOURCES = evas-text.c
- evas_text_LDADD = $(top_builddir)/src/lib/libevas.la @ECORE_EVAS_LIBS@
--pkglib_PROGRAMS += evas_smart_object
-+pkglibexec_PROGRAMS += evas_smart_object
- evas_smart_object_SOURCES = evas-smart-object.c
- evas_smart_object_LDADD = $(top_builddir)/src/lib/libevas.la @ECORE_EVAS_LIBS@
--pkglib_PROGRAMS += evas_box
-+pkglibexec_PROGRAMS += evas_box
- evas_box_SOURCES = evas-box.c
- evas_box_LDADD = $(top_builddir)/src/lib/libevas.la @ECORE_EVAS_LIBS@ @EINA_LIBS@
- #the ones using ecore_evas and edje follow
- AM_CPPFLAGS += @EDJE_CFLAGS@
--pkglib_PROGRAMS += evas_aspect_hints
-+pkglibexec_PROGRAMS += evas_aspect_hints
- evas_aspect_hints_DEPS = $(srcdir)/aspect.edc
- evas_aspect_hints_SOURCES = evas-aspect-hints.c
- evas_aspect_hints_LDADD = $(top_builddir)/src/lib/libevas.la @ECORE_EVAS_LIBS@ @EDJE_LIBS@
--pkglib_PROGRAMS += evas_map_utils
-+pkglibexec_PROGRAMS += evas_map_utils
- evas_map_utils_SOURCES = evas-map-utils.c
- evas_map_utils_LDADD = $(top_builddir)/src/lib/libevas.la @ECORE_EVAS_LIBS@
diff --git a/evas-wayland.patch b/evas-wayland.patch
new file mode 100644 (file)
index 0000000..c14a42d
--- /dev/null
@@ -0,0 +1,46 @@
+--- evas-1.2.0/src/modules/engines/wayland_egl/evas_engine.h.orig      2012-01-12 14:07:46.000000000 +0100
++++ evas-1.2.0/src/modules/engines/wayland_egl/evas_engine.h   2012-05-27 17:32:54.658986859 +0200
+@@ -1,6 +1,10 @@
+ #ifndef EVAS_ENGINE_H
+ #define EVAS_ENGINE_H
++#ifndef GLES_WAYLAND
++#define GLES_WAYLAND 1
++#endif
++
+ #include "config.h"
+ #include "evas_common.h"
+ #include "evas_private.h"
+--- evas-1.2.0/src/modules/engines/gl_common/evas_gl_common.h.orig     2012-04-20 15:36:16.000000000 +0200
++++ evas-1.2.0/src/modules/engines/gl_common/evas_gl_common.h  2012-05-27 17:32:34.405654373 +0200
+@@ -26,10 +26,10 @@
+ #   include <SDL/SDL_opengl.h>
+ #  endif
+ # else
+-#  if defined (GLES_VARIETY_S3C6410) || defined (GLES_VARIETY_SGX)
++#  if defined (GLES_VARIETY_S3C6410) || defined (GLES_VARIETY_SGX) || defined (GLES_WAYLAND)
+ #   if defined(GLES_VARIETY_S3C6410)
+ #    include <GLES2/gl2.h>
+-#   elif defined(GLES_VARIETY_SGX)
++#   elif defined(GLES_VARIETY_SGX) || defined (GLES_WAYLAND)
+ #    include <GLES2/gl2.h>
+ #    include <GLES2/gl2ext.h>
+ #   endif
+@@ -341,7 +341,7 @@
+    /* If this is set: Force drawing with a particular filter */
+    GLuint     filter_prog;
+-#if defined (GLES_VARIETY_S3C6410) || defined (GLES_VARIETY_SGX)
++#if defined (GLES_VARIETY_S3C6410) || defined (GLES_VARIETY_SGX) || defined (GLES_WAYLAND)
+ // FIXME: hack. expose egl display to gl core for egl image sec extn.
+    void *egldisp;
+ #endif
+@@ -633,7 +633,7 @@
+ extern void (*glsym_glProgramParameteri)    (GLuint a, GLuint b, GLint d);
+ extern void (*glsym_glReleaseShaderCompiler)(void);
+-#if defined (GLES_VARIETY_S3C6410) || defined (GLES_VARIETY_SGX)
++#if defined (GLES_VARIETY_S3C6410) || defined (GLES_VARIETY_SGX) || defined (GLES_WAYLAND)
+ extern void          *(*secsym_eglCreateImage)               (void *a, void *b, GLenum c, void *d, const int *e);
+ extern unsigned int   (*secsym_eglDestroyImage)              (void *a, void *b);
+ extern void           (*secsym_glEGLImageTargetTexture2DOES) (int a, void *b);
index a7a96612ddae01ac73ab931889d0edc5690ae28b..1a9940e3f09df2d47866c1e9ba773a8278ec3dcb 100644 (file)
--- a/evas.spec
+++ b/evas.spec
@@ -1,3 +1,4 @@
+# TODO: liblinebreak?
 #
 # Conditional build:
 %bcond_without mmx             # MMX and MMX2 support (on x86)
@@ -6,6 +7,7 @@
 %bcond_without fb              # FB engine
 %bcond_without directfb        # DirectFB engine
 %bcond_without sdl             # SDL (OpenGL and software) engines
+%bcond_without wayland         # wayland-egl, wayland-shm engines
 %bcond_with    xcb             # software_x11 engine with XCB support (experimental)
 %bcond_without static_libs     # don't build static library
 #
 %endif
 #
 %define                edb_ver         1.0.5.043
-%define                eet_ver         1.5.0
+%define                eet_ver         1.6.0
 
 Summary:       Multi-platform Canvas Library
 Summary(pl.UTF-8):     Wieloplatformowa biblioteka do rysowania
 Name:          evas
-Version:       1.1.0
-Release:       6
+Version:       1.2.0
+Release:       1
 License:       BSD
 Group:         Libraries
 Source0:       http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: f8d8751be7cfc8124e5af31e2dced792
+# Source0-md5: a245e432695cea1120d43cdbcb94b7f7
 Patch0:                %{name}-harfbuzz.patch
-Patch1:                automake.patch
+Patch1:                %{name}-wayland.patch
 URL:           http://trac.enlightenment.org/e/wiki/Evas
-%{?with_directfb:BuildRequires:        DirectFB-devel}
+%{?with_directfb:BuildRequires:        DirectFB-devel >= 0.9.16}
 BuildRequires: Mesa-libGLU-devel
-%{?with_sdl:BuildRequires:     SDL-devel}
+%{?with_sdl:BuildRequires:     SDL-devel >= 1.2.0}
 BuildRequires: autoconf >= 2.59-9
 BuildRequires: automake >= 1.6
 BuildRequires: edb-devel >= %{edb_ver}
 BuildRequires: eet-devel >= %{eet_ver}
-BuildRequires: eina-devel >= 1.1.0
+BuildRequires: eina-devel >= 1.2.0
 BuildRequires: fontconfig-devel >= 2.5.0
 BuildRequires: freetype-devel >= 1:2.2
 BuildRequires: fribidi-devel >= 0.19.2
@@ -52,22 +54,27 @@ BuildRequires:      libpng-devel >= 1.2
 BuildRequires: librsvg-devel >= 1:2.14.0
 BuildRequires: libtiff-devel
 BuildRequires: libtool
+BuildRequires: pixman-devel
 BuildRequires: pkgconfig
 BuildRequires: readline-devel
 BuildRequires: xorg-lib-libXext-devel
 %if %{with xcb}
 BuildRequires: libxcb-devel
-# --enable-pixman ?
-#BuildRequires:        pixman-devel
 BuildRequires: xcb-util-image-devel >= 0.2.1
 %endif
+%if %{with wayland}
+BuildRequires: OpenGL-devel
+BuildRequires: Mesa-libEGL-devel >= 7.10
+BuildRequires: Mesa-libGLES-devel
+BuildRequires: Mesa-libwayland-egl-devel
+BuildRequires: wayland-devel
+%endif
 Requires:      eet >= %{eet_ver}
-Requires:      eina >= 1.1.0
+Requires:      eina >= 1.2.0
 Requires:      freetype >= 1:2.2
 Requires:      fribidi >= 0.19.2
 Requires:      harfbuzz >= 0.6.0
 Obsoletes:     evas-libs
-Obsoletes:     evas-engine-software_16
 Obsoletes:     evas-engine-software_qtopia
 Obsoletes:     evas-engine-xrender_x11
 Obsoletes:     evas-engine-xrender_xcb
@@ -91,7 +98,8 @@ Summary(pl.UTF-8):    Pliki nagłówkowe Evas
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      eet-devel >= %{eet_ver}
-Requires:      fontconfig-devel
+Requires:      eina-devel >= 1.2.0
+Requires:      fontconfig-devel >= 2.5.0
 Requires:      freetype-devel >= 1:2.2
 Requires:      fribidi-devel >= 0.19.2
 Requires:      harfbuzz-devel >= 0.6.0
@@ -133,6 +141,7 @@ Summary:    DirectFB rendering engine module for Evas
 Summary(pl.UTF-8):     Moduł silnika renderującego na DirectFB dla Evas
 Group:         X11/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      DirectFB >= 0.9.16
 
 %description engine-directfb
 DirectFB rendering engine module for Evas.
@@ -157,6 +166,7 @@ Summary:    SDL OpenGL rendering engine module for Evas
 Summary(pl.UTF-8):     Moduł silnika renderującego na SDL OpenGL dla Evas
 Group:         X11/Libraries
 Requires:      %{name}-engine-software_generic = %{version}-%{release}
+Requires:      SDL >= 1.2.0
 
 %description engine-gl_sdl
 SDL OpenGL rendering engine module for Evas.
@@ -176,11 +186,25 @@ OpenGL under X11 rendering engine module for Evas.
 %description engine-gl_x11 -l pl.UTF-8
 Moduł silnika renderującego na OpenGL pod X11 dla Evas.
 
+%package engine-software_16
+Summary:       16-bit software rendering engine module for Evas
+Summary(pl.UTF-8):     Moduł silnika programowego renderującego 16-bitowego dla Evas
+Group:         X11/Libraries
+Requires:      %{name}-engine-software_generic = %{version}-%{release}
+
+%description engine-software_16
+16-bit software rendering engine module for Evas.
+
+%description engine-software_16 -l pl.UTF-8
+Moduł silnika programowego renderującego 16-bitowego dla Evas.
+
 %package engine-software_16_sdl
 Summary:       16-bit SDL software rendering engine module for Evas
 Summary(pl.UTF-8):     Moduł silnika programowego renderującego 16-bitowego na SDL dla Evas
 Group:         X11/Libraries
 Requires:      %{name}-engine-software_generic = %{version}-%{release}
+Requires:      SDL >= 1.2.0
+Obsoletes:     evas-engine-software_sdl
 
 %description engine-software_16_sdl
 16-bit SDL software rendering engine module for Evas.
@@ -188,6 +212,18 @@ Requires:  %{name}-engine-software_generic = %{version}-%{release}
 %description engine-software_16_sdl -l pl.UTF-8
 Moduł silnika programowego renderującego 16-bitowego na SDL dla Evas.
 
+%package engine-software_16_x11
+Summary:       16-bit X11 software rendering engine module for Evas
+Summary(pl.UTF-8):     Moduł silnika programowego renderującego 16-bitowego na X11 dla Evas
+Group:         X11/Libraries
+Requires:      %{name}-engine-software_generic = %{version}-%{release}
+
+%description engine-software_16_x11
+16-bit X11 software rendering engine module for Evas.
+
+%description engine-software_16_x11 -l pl.UTF-8
+Moduł silnika programowego renderującego 16-bitowego na X11 dla Evas.
+
 %package engine-software_generic
 Summary:               Software rendering common engine module for Evas
 Summary(pl.UTF-8):     Moduł wspólnego programowego silnika renderującego dla Evas
@@ -200,18 +236,6 @@ Software rendering common engine module for Evas.
 %description engine-software_generic -l pl.UTF-8
 Moduł wspólnego programowego silnika renderującego dla Evas.
 
-%package engine-software_sdl
-Summary:       SDL software rendering engine module for Evas
-Summary(pl.UTF-8):     Moduł silnika programowego renderującego na SDL dla Evas
-Group:         X11/Libraries
-Requires:      %{name}-engine-software_generic = %{version}-%{release}
-
-%description engine-software_sdl
-SDL software rendering engine module for Evas.
-
-%description engine-software_sdl -l pl.UTF-8
-Moduł silnika programowego renderującego na SDL dla Evas.
-
 %package engine-software_x11
 Summary:       Software X11 rendering engine module for Evas
 Summary(pl.UTF-8):     Moduł programowego silnika renderującego X11 dla Evas
@@ -225,6 +249,30 @@ Software X11 rendering engine module for Evas.
 %description engine-software_x11 -l pl.UTF-8
 Moduł programowego silnika renderującego X11 dla Evas.
 
+%package engine-wayland_egl
+Summary:       Wayland EGL rendering engine module for Evas
+Summary(pl.UTF-8):     Moduł silnika renderującego Wayland EGL dla Evas
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description engine-wayland_egl
+Wayland EGL rendering engine module for Evas.
+
+%description engine-wayland_egl -l pl.UTF-8
+Moduł silnika renderującego Wayland EGL dla Evas.
+
+%package engine-wayland_shm
+Summary:       Wayland SHM rendering engine module for Evas
+Summary(pl.UTF-8):     Moduł silnika renderującego Wayland SHM dla Evas
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description engine-wayland_shm
+Wayland SHM rendering engine module for Evas.
+
+%description engine-wayland_shm -l pl.UTF-8
+Moduł silnika renderującego Wayland SHM dla Evas.
+
 # loaders:
 %package loader-edb
 Summary:       EDB Image loader module for Evas
@@ -419,6 +467,8 @@ Moduł zapisywania obrazów TIFF dla Evas.
        --enable-fb%{!?with_fb:=no} \
        --enable-font-loader-eet        \
        --enable-gl-sdl%{!?with_sdl:=no} \
+       --enable-gl-xcb%{!?with_xcb:=no} \
+       --enable-gl-xlib \
        --enable-image-loader-edb       \
        --enable-image-loader-eet       \
        --enable-image-loader-gif       \
@@ -428,14 +478,15 @@ Moduł zapisywania obrazów TIFF dla Evas.
        --enable-image-loader-tiff      \
        --enable-image-loader-xpm       \
        --enable-pixman                 \
-       --enable-software-sdl%{!?with_sdl:=no} \
+       --enable-software-16-sdl%{!?with_sdl:=no} \
+       --enable-software-16-x11 \
        --enable-software-xcb%{!?with_xcb:=no} \
        --enable-software-xlib \
-       --enable-gl-xcb%{!?with_xcb:=no} \
-       --enable-gl-xlib \
+       --enable-wayland-egl%{!?with_wayland:=no} \
+       --enable-wayland-shm%{!?with_wayland:=no} \
        --disable-valgrind
 
-%{__make} V=1
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -498,9 +549,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/evas-fb.pc
 %{?with_sdl:%{_pkgconfigdir}/evas-opengl-sdl.pc}
 %{_pkgconfigdir}/evas-opengl-x11.pc
+%{_pkgconfigdir}/evas-software-16-x11.pc
 %{_pkgconfigdir}/evas-software-buffer.pc
 %{?with_sdl:%{_pkgconfigdir}/evas-software-sdl.pc}
 %{_pkgconfigdir}/evas-software-x11.pc
+%if %{with wayland}
+%{_pkgconfigdir}/evas-wayland-egl.pc
+%{_pkgconfigdir}/evas-wayland-shm.pc
+%endif
 %{_examplesdir}/%{name}-%{version}
 
 %if %{with static_libs}
@@ -545,6 +601,18 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/%{name}/modules/engines/gl_x11/linux-gnu-*
 %attr(755,root,root) %{_libdir}/%{name}/modules/engines/gl_x11/linux-gnu-*/module.so
 
+%files engine-software_16
+%defattr(644,root,root,755)
+%dir %{_libdir}/%{name}/modules/engines/software_16
+%dir %{_libdir}/%{name}/modules/engines/software_16/linux-gnu-*
+%attr(755,root,root) %{_libdir}/%{name}/modules/engines/software_16/linux-gnu-*/module.so
+
+%files engine-software_16_x11
+%defattr(644,root,root,755)
+%dir %{_libdir}/%{name}/modules/engines/software_16_x11
+%dir %{_libdir}/%{name}/modules/engines/software_16_x11/linux-gnu-*
+%attr(755,root,root) %{_libdir}/%{name}/modules/engines/software_16_x11/linux-gnu-*/module.so
+
 %if %{with sdl}
 %files engine-software_16_sdl
 %defattr(644,root,root,755)
@@ -559,20 +627,25 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/%{name}/modules/engines/software_generic/linux-gnu-*
 %attr(755,root,root) %{_libdir}/%{name}/modules/engines/software_generic/linux-gnu-*/module.so
 
-%if %{with sdl}
-%files engine-software_sdl
-%defattr(644,root,root,755)
-%dir %{_libdir}/%{name}/modules/engines/software_sdl
-%dir %{_libdir}/%{name}/modules/engines/software_sdl/linux-gnu-*
-%attr(755,root,root) %{_libdir}/%{name}/modules/engines/software_sdl/linux-gnu-*/module.so
-%endif
-
 %files engine-software_x11
 %defattr(644,root,root,755)
 %dir %{_libdir}/%{name}/modules/engines/software_x11
 %dir %{_libdir}/%{name}/modules/engines/software_x11/linux-gnu-*
 %attr(755,root,root) %{_libdir}/%{name}/modules/engines/software_x11/linux-gnu-*/module.so
 
+%if %{with wayland}
+%files engine-wayland_egl
+%defattr(644,root,root,755)
+%dir %{_libdir}/%{name}/modules/engines/wayland_egl
+%dir %{_libdir}/%{name}/modules/engines/wayland_egl/linux-gnu-*
+%attr(755,root,root) %{_libdir}/%{name}/modules/engines/wayland_egl/linux-gnu-*/module.so
+
+%files engine-wayland_shm
+%defattr(644,root,root,755)
+%dir %{_libdir}/%{name}/modules/engines/wayland_shm
+%dir %{_libdir}/%{name}/modules/engines/wayland_shm/linux-gnu-*
+%attr(755,root,root) %{_libdir}/%{name}/modules/engines/wayland_shm/linux-gnu-*/module.so
+
 %files loader-edb
 %defattr(644,root,root,755)
 %dir %{_libdir}/%{name}/modules/loaders/edb
This page took 0.100114 seconds and 4 git commands to generate.