]> git.pld-linux.org Git - packages/evas.git/blob - evas.spec
- up to 0.9.9.023
[packages/evas.git] / evas.spec
1 #
2 # Conditional build:
3 %bcond_without  mmx             # without MMX and MMX2
4 %bcond_without  sse             # without SSE
5 %bcond_without  altivec         # without altivec
6 %bcond_without  static_libs     # don't build static library
7 #
8 %ifnarch i586 i686 athlon %{x8664}
9 %undefine       with_mmx
10 %endif
11 %ifnarch i686 athlon %{x8664}
12 %undefine       with_sse
13 %endif
14 %ifnarch ppc
15 %undefine       with_altivec
16 %endif
17 #
18 Summary:        Multi-platform Canvas Library
19 Summary(pl):    Wieloplatformowa biblioteka do rysowania
20 Name:           evas
21 Version:        0.9.9.023
22 Release:        1
23 License:        BSD
24 Group:          Libraries
25 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
26 # Source0-md5:  ca5528c8894d49cbdf77873f5974c0e8
27 #Patch0:                %{name}-missing_m4.patch
28 URL:            http://enlightenment.org/Libraries/Evas/
29 BuildRequires:  DirectFB-devel
30 BuildRequires:  OpenGL-devel
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  edb-devel
34 BuildRequires:  eet-devel
35 BuildRequires:  freetype-devel
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libtool
39 BuildRequires:  pkgconfig
40 Requires:       %{name}-libs = %{version}-%{release}
41 Requires:       fonts-TTF-bitstream-vera
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %undefine       __cxx
45
46 %description
47 Evas is a clean display canvas API for several target display systems
48 that can draw anti-aliased text, smooth super and sub-sampled scaled
49 images, alpha-blend objects much and more.
50
51 %description -l pl
52 Evas to czyste API "p³ótna obrazu" dla ró¿nych systemów wy¶wietlania,
53 bêd±ce w stanie rysowaæ tekst z antyaliasingiem, wyg³adzane, skalowane
54 obrazy, obiekty z alpha-blendingiem i inne elementy.
55
56 %package libs
57 Summary:        Evas library
58 Summary(pl):    Biblioteka evas
59 Group:          X11/Libraries
60
61 %description libs
62 Evas library.
63
64 %description libs -l pl
65 Biblioteka evas.
66
67 %package devel
68 Summary:        Evas header files
69 Summary(pl):    Pliki nag³ówkowe Evas
70 Group:          Development/Libraries
71 Requires:       %{name}-libs = %{version}-%{release}
72 Requires:       DirectFB-devel
73 Requires:       OpenGL-devel
74 Requires:       edb-devel
75 Requires:       eet-devel
76 Requires:       freetype-devel
77 Requires:       libjpeg-devel
78 Requires:       libpng-devel
79
80 %description devel
81 Header files for Evas.
82
83 %description devel -l pl
84 Pliki nag³ówkowe Evas.
85
86 %package static
87 Summary:        Static Evas library
88 Summary(pl):    Statyczna biblioteka Evas
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91
92 %description static
93 Static Evas library.
94
95 %description static -l pl
96 Statyczna biblioteka Evas.
97
98 %prep
99 %setup -q
100 #%%patch0 -p1
101
102 %build
103 #%%{__libtoolize}
104 #%%{__aclocal}
105 #%%{__autoconf}
106 #%%{__autoheader}
107 #%%{__automake}
108 %configure \
109         %{!?with_static_libs:--disable-static} \
110         --enable-software-x11   \
111         --disable-software-xcb  \
112         --enable-directfb       \
113         --enable-fb             \
114         --enable-buffer         \
115         --disable-software-qtopia \
116         --enable-gl-x11         \
117         --enable-xrender-x11    \
118         --enable-image-loader-png       \
119         --enable-image-loader-jpeg      \
120         --enable-image-loader-eet       \
121         --enable-font-loader-eet        \
122         --enable-image-loader-edb       \
123 %if %{with mmx}
124         --enable-cpu-mmx        \
125 %else
126         --disable-cpu-mmx       \
127 %endif
128 %if %{with sse}
129         --enable-cpu-sse        \
130 %else
131         --disable-cpu-sse       \
132 %endif
133 %if %{with altivec}
134         --enable-cpu-altivec    \
135 %else
136         --disable-cpu-altivec   \
137 %endif
138         --enable-cpu-c          \
139         --disable-valgrind
140
141 %{__make}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 cd $RPM_BUILD_ROOT%{_datadir}/%{name}
150 VERA=$(ls Vera*.ttf)
151 for FONT in $VERA; do
152         rm -f $FONT
153         ln -s %{_fontsdir}/TTF/$FONT .
154 done
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post   libs -p /sbin/ldconfig
160 %postun libs -p /sbin/ldconfig
161
162 %files
163 %defattr(644,root,root,755)
164 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
165 %attr(755,root,root) %{_bindir}/evas_*
166 %{_datadir}/%{name}
167
168 %files libs
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libevas.so.*.*.*
171
172 %files devel
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/evas-config
175 %attr(755,root,root) %{_libdir}/libevas.so
176 %{_libdir}/libevas.la
177 %{_pkgconfigdir}/evas.pc
178 %{_includedir}/Evas*
179
180 %if %{with static_libs}
181 %files static
182 %defattr(644,root,root,755)
183 %{_libdir}/libevas.a
184 %endif
This page took 0.073627 seconds and 4 git commands to generate.