]> git.pld-linux.org Git - packages/evas.git/blob - evas.spec
- cpu extensions default on (runtime detected)
[packages/evas.git] / evas.spec
1 #
2 %bcond_without  mmx             # without MMX and MMX2
3 %bcond_without  sse             # without SSE
4 %bcond_without  altivec         # without altivec
5 #
6 %ifnarch i586 i686 athlon
7 %undefine       with_mmx
8 %endif
9 %ifnarch i686 athlon
10 %undefine       with_sse
11 %endif
12 %ifnarch ppc
13 %undefine       with_altivec
14 %endif
15 #
16 Summary:        Multi-platform Canvas Library
17 Summary(pl):    Wieloplatformowa biblioteka do rysowania
18 Name:           evas
19 Version:        0.9.9
20 %define _snap   20050329
21 Release:        0.%{_snap}.0.1
22 License:        BSD
23 Group:          Libraries
24 #Source0:       http://dl.sourceforge.net/enlightenment/%{name}-%{version}_%{_pre}.tar.gz
25 Source0:        ftp://ftp.sparky.homelinux.org/pub/e17/%{name}-%{_snap}.tar.gz
26 # Source0-md5:  d29b5c91e01c3eda9ff8a940dfe84398
27 URL:            http://enlightenment.org/
28 BuildRequires:  DirectFB-devel
29 BuildRequires:  OpenGL-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  cairo-devel
33 BuildRequires:  edb-devel
34 BuildRequires:  eet-devel
35 BuildRequires:  freetype-devel
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libtool
39 BuildRequires:  pkgconfig
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Evas is a clean display canvas API for several target display systems
44 that can draw anti-aliased text, smooth super and sub-sampled scaled
45 images, alpha-blend objects much and more.
46
47 %description -l pl
48 Evas to czyste API "p³ótna obrazu" dla ró¿nych systemów wy¶wietlania,
49 bêd±ce w stanie rysowaæ tekst z antyaliasingiem, wyg³adzane, skalowane
50 obrazy, obiekty z alpha-blendingiem i inne elementy.
51
52 %package devel
53 Summary:        Evas header files
54 Summary(pl):    Pliki nag³ówkowe Evas
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       DirectFB-devel
58 Requires:       OpenGL-devel
59 Requires:       cairo-devel
60 Requires:       edb-devel
61 Requires:       eet-devel
62 Requires:       freetype-devel
63 Requires:       libjpeg-devel
64 Requires:       libpng-devel
65
66 %description devel
67 Header files for Evas.
68
69 %description devel -l pl
70 Pliki nag³ówkowe Evas.
71
72 %package static
73 Summary:        Static Evas library
74 Summary(pl):    Statyczna biblioteka Evas
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static Evas library.
80
81 %description static -l pl
82 Statyczna biblioteka Evas.
83
84 %prep
85 #%%setup -q -n %{name}-%{version}_%{_pre}
86 %setup -q -n %{name}
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I m4
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --enable-software-x11   \
96         --enable-direct-fb      \
97         --enable-fb             \
98         --enable-buffer         \
99         --disable-software-qtopia \
100         --enable-gl-x11         \
101         --enable-cairo-x11      \
102 %if %{with mmx}
103         --enable-cpu-mmx        \
104 %else
105         --disable-cpu-mmx       \
106 %endif
107 %if %{with sse}
108         --enable-cpu-sse        \
109 %else
110         --disable-cpu-sse       \
111 %endif
112 %if %{with altivec}
113         --enable-cpu-altivec    \
114 %else
115         --disable-cpu-altivec   \
116 %endif
117         --enable-cpu-c
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS README COPYING
136 %attr(755,root,root) %{_bindir}/evas_*
137 %attr(755,root,root) %{_libdir}/libevas.so.*.*.*
138 %{_datadir}/%{name}
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/evas-config
143 %attr(755,root,root) %{_libdir}/libevas.so
144 %{_libdir}/libevas.la
145 %{_pkgconfigdir}/evas.pc
146 %{_includedir}/Evas*
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libevas.a
This page took 0.068232 seconds and 4 git commands to generate.