]> git.pld-linux.org Git - packages/evas.git/blob - evas.spec
- updated to 0.9.9.021
[packages/evas.git] / evas.spec
1 #
2 # Conditional build:
3 %bcond_without  mmx             # without MMX and MMX2
4 %bcond_without  sse             # without SSE
5 %bcond_without  altivec         # without altivec
6 %bcond_without  static_libs     # don't build static library
7 #
8 %ifnarch i586 i686 athlon
9 %undefine       with_mmx
10 %endif
11 %ifnarch i686 athlon
12 %undefine       with_sse
13 %endif
14 %ifnarch ppc
15 %undefine       with_altivec
16 %endif
17 #
18 Summary:        Multi-platform Canvas Library
19 Summary(pl):    Wieloplatformowa biblioteka do rysowania
20 Name:           evas
21 Version:        0.9.9.021
22 Release:        1
23 License:        BSD
24 Group:          Libraries
25 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
26 # Source0-md5:  499e223429b51daeb7d58da21617daba
27 Patch0:         %{name}-missing_m4.patch
28 URL:            http://enlightenment.org/Libraries/Evas/
29 BuildRequires:  DirectFB-devel
30 BuildRequires:  OpenGL-devel
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  edb-devel
34 BuildRequires:  eet-devel
35 BuildRequires:  freetype-devel
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libtool
39 BuildRequires:  pkgconfig
40 Requires:       %{name}-libs = %{version}-%{release}
41 Requires:       fonts-TTF-bitstream-vera
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Evas is a clean display canvas API for several target display systems
46 that can draw anti-aliased text, smooth super and sub-sampled scaled
47 images, alpha-blend objects much and more.
48
49 %description -l pl
50 Evas to czyste API "p³ótna obrazu" dla ró¿nych systemów wy¶wietlania,
51 bêd±ce w stanie rysowaæ tekst z antyaliasingiem, wyg³adzane, skalowane
52 obrazy, obiekty z alpha-blendingiem i inne elementy.
53
54 %package libs
55 Summary:        Evas library
56 Summary(pl):    Biblioteka evas
57 Group:          X11/Libraries
58
59 %description libs
60 Evas library.
61
62 %description libs -l pl
63 Biblioteka evas.
64
65 %package devel
66 Summary:        Evas header files
67 Summary(pl):    Pliki nag³ówkowe Evas
68 Group:          Development/Libraries
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       DirectFB-devel
71 Requires:       OpenGL-devel
72 Requires:       edb-devel
73 Requires:       eet-devel
74 Requires:       freetype-devel
75 Requires:       libjpeg-devel
76 Requires:       libpng-devel
77
78 %description devel
79 Header files for Evas.
80
81 %description devel -l pl
82 Pliki nag³ówkowe Evas.
83
84 %package static
85 Summary:        Static Evas library
86 Summary(pl):    Statyczna biblioteka Evas
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static Evas library.
92
93 %description static -l pl
94 Statyczna biblioteka Evas.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99
100 %build
101 %{__libtoolize}
102 %{__aclocal}
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         %{!?with_static_libs:--disable-static} \
108         --enable-software-x11   \
109         --disable-software-xcb  \
110         --enable-directfb       \
111         --enable-fb             \
112         --enable-buffer         \
113         --disable-software-qtopia \
114         --enable-gl-x11         \
115         --enable-xrender-x11    \
116         --enable-image-loader-png       \
117         --enable-image-loader-jpeg      \
118         --enable-image-loader-eet       \
119         --enable-font-loader-eet        \
120         --enable-image-loader-edb       \
121 %if %{with mmx}
122         --enable-cpu-mmx        \
123 %else
124         --disable-cpu-mmx       \
125 %endif
126 %if %{with sse}
127         --enable-cpu-sse        \
128 %else
129         --disable-cpu-sse       \
130 %endif
131 %if %{with altivec}
132         --enable-cpu-altivec    \
133 %else
134         --disable-cpu-altivec   \
135 %endif
136         --enable-cpu-c          \
137         --disable-valgrind
138
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 cd $RPM_BUILD_ROOT%{_datadir}/%{name}
148 VERA=$(ls Vera*.ttf)
149 for FONT in $VERA; do
150         rm -f $FONT
151         ln -s %{_fontsdir}/TTF/$FONT .
152 done
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post   libs -p /sbin/ldconfig
158 %postun libs -p /sbin/ldconfig
159
160 %files
161 %defattr(644,root,root,755)
162 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
163 %attr(755,root,root) %{_bindir}/evas_*
164 %{_datadir}/%{name}
165
166 %files libs
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libevas.so.*.*.*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_bindir}/evas-config
173 %attr(755,root,root) %{_libdir}/libevas.so
174 %{_libdir}/libevas.la
175 %{_pkgconfigdir}/evas.pc
176 %{_includedir}/Evas*
177
178 %if %{with static_libs}
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/libevas.a
182 %endif
This page took 0.055001 seconds and 4 git commands to generate.