]> git.pld-linux.org Git - packages/evas.git/blob - evas.spec
- separated library to subpackage
[packages/evas.git] / evas.spec
1 #
2 %bcond_without  mmx             # without MMX and MMX2
3 %bcond_without  sse             # without SSE
4 %bcond_without  altivec         # without altivec
5 #
6 %ifnarch i586 i686 athlon
7 %undefine       with_mmx
8 %endif
9 %ifnarch i686 athlon
10 %undefine       with_sse
11 %endif
12 %ifnarch ppc
13 %undefine       with_altivec
14 %endif
15 #
16 Summary:        Multi-platform Canvas Library
17 Summary(pl):    Wieloplatformowa biblioteka do rysowania
18 Name:           evas
19 Version:        0.9.9.019
20 Release:        1
21 License:        BSD
22 Group:          Libraries
23 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
24 # Source0-md5:  1766c37200f2efb37076e302fd07517b
25 Patch0:         %{name}-missing_m4.patch
26 URL:            http://enlightenment.org/Libraries/Evas/
27 BuildRequires:  DirectFB-devel
28 BuildRequires:  OpenGL-devel
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  edb-devel
32 BuildRequires:  eet-devel
33 BuildRequires:  freetype-devel
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libpng-devel
36 BuildRequires:  libtool
37 BuildRequires:  pkgconfig
38 Requires:       %{name}-libs = %{version}-%{release}
39 Requires:       fonts-TTF-bitstream-vera
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Evas is a clean display canvas API for several target display systems
44 that can draw anti-aliased text, smooth super and sub-sampled scaled
45 images, alpha-blend objects much and more.
46
47 %description -l pl
48 Evas to czyste API "p³ótna obrazu" dla ró¿nych systemów wy¶wietlania,
49 bêd±ce w stanie rysowaæ tekst z antyaliasingiem, wyg³adzane, skalowane
50 obrazy, obiekty z alpha-blendingiem i inne elementy.
51
52 %package libs
53 Summary:        Evas library
54 Summary(pl):    Biblioteka evas
55 Group:          X11/Libraries
56
57 %description libs
58 Evas library.
59
60 %description libs -l pl
61 Biblioteka evas.
62
63 %package devel
64 Summary:        Evas header files
65 Summary(pl):    Pliki nag³ówkowe Evas
66 Group:          Development/Libraries
67 Requires:       %{name}-libs = %{version}-%{release}
68 Requires:       DirectFB-devel
69 Requires:       OpenGL-devel
70 Requires:       edb-devel
71 Requires:       eet-devel
72 Requires:       freetype-devel
73 Requires:       libjpeg-devel
74 Requires:       libpng-devel
75
76 %description devel
77 Header files for Evas.
78
79 %description devel -l pl
80 Pliki nag³ówkowe Evas.
81
82 %package static
83 Summary:        Static Evas library
84 Summary(pl):    Statyczna biblioteka Evas
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 Static Evas library.
90
91 %description static -l pl
92 Statyczna biblioteka Evas.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97
98 %build
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 %configure \
105         --enable-software-x11   \
106         --disable-software-xcb  \
107         --enable-direct-fb      \
108         --enable-fb             \
109         --enable-buffer         \
110         --disable-software-qtopia \
111         --enable-gl-x11         \
112         --enable-image-loader-png       \
113         --enable-image-loader-jpeg      \
114         --enable-image-loader-eet       \
115         --enable-font-loader-eet        \
116         --enable-image-loader-edb       \
117 %if %{with mmx}
118         --enable-cpu-mmx        \
119 %else
120         --disable-cpu-mmx       \
121 %endif
122 %if %{with sse}
123         --enable-cpu-sse        \
124 %else
125         --disable-cpu-sse       \
126 %endif
127 %if %{with altivec}
128         --enable-cpu-altivec    \
129 %else
130         --disable-cpu-altivec   \
131 %endif
132         --enable-cpu-c
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 cd $RPM_BUILD_ROOT%{_datadir}/%{name}
143 VERA=$(ls Vera*.ttf)
144 for FONT in $VERA; do
145         rm -f $FONT
146         ln -s %{_fontsdir}/TTF/$FONT .
147 done
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post libs      -p /sbin/ldconfig
153 %postun libs    -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
158 %attr(755,root,root) %{_bindir}/evas_*
159 %{_datadir}/%{name}
160
161 %files libs
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libevas.so.*.*.*
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/evas-config
168 %attr(755,root,root) %{_libdir}/libevas.so
169 %{_libdir}/libevas.la
170 %{_pkgconfigdir}/evas.pc
171 %{_includedir}/Evas*
172
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/libevas.a
This page took 0.071428 seconds and 4 git commands to generate.