]> git.pld-linux.org Git - packages/evas.git/blob - evas.spec
- new snap
[packages/evas.git] / evas.spec
1 #
2 %bcond_without  mmx             # without MMX and MMX2
3 %bcond_without  sse             # without SSE
4 %bcond_without  altivec         # without altivec
5 #
6 %ifnarch i586 i686 athlon
7 %undefine       with_mmx
8 %endif
9 %ifnarch i686 athlon
10 %undefine       with_sse
11 %endif
12 %ifnarch ppc
13 %undefine       with_altivec
14 %endif
15 #
16 Summary:        Multi-platform Canvas Library
17 Summary(pl):    Wieloplatformowa biblioteka do rysowania
18 Name:           evas
19 Version:        0.9.9.010
20 %define _snap   20050706
21 Release:        0.%{_snap}.0.1
22 License:        BSD
23 Group:          Libraries
24 #Source0:       http://dl.sourceforge.net/enlightenment/%{name}-%{version}_%{_pre}.tar.gz
25 Source0:        ftp://ftp.sparky.homelinux.org/snaps/enli/e17/libs/%{name}-%{_snap}.tar.gz
26 # Source0-md5:  a798480eacc9437d84ed12d64f789fc5
27 URL:            http://enlightenment.org/
28 BuildRequires:  DirectFB-devel
29 BuildRequires:  OpenGL-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  edb-devel
33 BuildRequires:  eet-devel
34 BuildRequires:  freetype-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libpng-devel
37 BuildRequires:  libtool
38 BuildRequires:  pkgconfig
39 Requires:       fonts-TTF-bitstream-vera
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Evas is a clean display canvas API for several target display systems
44 that can draw anti-aliased text, smooth super and sub-sampled scaled
45 images, alpha-blend objects much and more.
46
47 %description -l pl
48 Evas to czyste API "p³ótna obrazu" dla ró¿nych systemów wy¶wietlania,
49 bêd±ce w stanie rysowaæ tekst z antyaliasingiem, wyg³adzane, skalowane
50 obrazy, obiekty z alpha-blendingiem i inne elementy.
51
52 %package devel
53 Summary:        Evas header files
54 Summary(pl):    Pliki nag³ówkowe Evas
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       DirectFB-devel
58 Requires:       OpenGL-devel
59 Requires:       edb-devel
60 Requires:       eet-devel
61 Requires:       freetype-devel
62 Requires:       libjpeg-devel
63 Requires:       libpng-devel
64
65 %description devel
66 Header files for Evas.
67
68 %description devel -l pl
69 Pliki nag³ówkowe Evas.
70
71 %package static
72 Summary:        Static Evas library
73 Summary(pl):    Statyczna biblioteka Evas
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static Evas library.
79
80 %description static -l pl
81 Statyczna biblioteka Evas.
82
83 %prep
84 #%%setup -q -n %{name}-%{version}_%{_pre}
85 %setup -q -n %{name}
86
87 %build
88 %{__libtoolize}
89 %{__aclocal} -I m4
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         --enable-software-x11   \
95         --disable-software-xcb  \
96         --enable-direct-fb      \
97         --enable-fb             \
98         --enable-buffer         \
99         --disable-software-qtopia \
100         --enable-gl-x11         \
101         --enable-image-loader-png       \
102         --enable-image-loader-jpeg      \
103         --enable-image-loader-eet       \
104         --enable-font-loader-eet        \
105         --enable-image-loader-edb       \
106 %if %{with mmx}
107         --enable-cpu-mmx        \
108 %else
109         --disable-cpu-mmx       \
110 %endif
111 %if %{with sse}
112         --enable-cpu-sse        \
113 %else
114         --disable-cpu-sse       \
115 %endif
116 %if %{with altivec}
117         --enable-cpu-altivec    \
118 %else
119         --disable-cpu-altivec   \
120 %endif
121         --enable-cpu-c
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 cd $RPM_BUILD_ROOT%{_datadir}/%{name}
132 VERA=$(ls Vera*.ttf)
133 for FONT in $VERA; do
134         rm -f $FONT
135         ln -s %{_fontsdir}/TTF/$FONT .
136 done
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files
145 %defattr(644,root,root,755)
146 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
147 %attr(755,root,root) %{_bindir}/evas_*
148 %attr(755,root,root) %{_libdir}/libevas.so.*.*.*
149 %{_datadir}/%{name}
150
151 %files devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/evas-config
154 %attr(755,root,root) %{_libdir}/libevas.so
155 %{_libdir}/libevas.la
156 %{_pkgconfigdir}/evas.pc
157 %{_includedir}/Evas*
158
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/libevas.a
This page took 0.037174 seconds and 3 git commands to generate.