]> git.pld-linux.org Git - packages/evas.git/blob - evas.spec
845ff13aacf6ff9c4c9b60329239952cdfab24fe
[packages/evas.git] / evas.spec
1 #
2 # Conditional build:
3 %bcond_without  mmx             # without MMX and MMX2
4 %bcond_without  sse             # without SSE
5 %bcond_without  altivec         # without altivec
6 %bcond_without  directfb        # build without DirectFB support
7 %bcond_without  static_libs     # don't build static library
8 #
9 %ifnarch i586 i686 athlon %{x8664}
10 %undefine       with_mmx
11 %endif
12 %ifnarch i686 athlon %{x8664}
13 %undefine       with_sse
14 %endif
15 %ifnarch ppc
16 %undefine       with_altivec
17 %endif
18 #
19 Summary:        Multi-platform Canvas Library
20 Summary(pl):    Wieloplatformowa biblioteka do rysowania
21 Name:           evas
22 Version:        0.9.9.024
23 Release:        1
24 License:        BSD
25 Group:          Libraries
26 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
27 # Source0-md5:  e363ee32718b209b66a3e0bcb4215e14
28 URL:            http://enlightenment.org/Libraries/Evas/
29 %{?with_directfb:BuildRequires: DirectFB-devel}
30 BuildRequires:  OpenGL-devel
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  edb-devel
34 BuildRequires:  eet-devel
35 BuildRequires:  freetype-devel
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libtool
39 BuildRequires:  pkgconfig
40 Requires:       %{name}-libs = %{version}-%{release}
41 Requires:       fonts-TTF-bitstream-vera
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %undefine       __cxx
45
46 %description
47 Evas is a clean display canvas API for several target display systems
48 that can draw anti-aliased text, smooth super and sub-sampled scaled
49 images, alpha-blend objects much and more.
50
51 %description -l pl
52 Evas to czyste API "p³ótna obrazu" dla ró¿nych systemów wy¶wietlania,
53 bêd±ce w stanie rysowaæ tekst z antyaliasingiem, wyg³adzane, skalowane
54 obrazy, obiekty z alpha-blendingiem i inne elementy.
55
56 %package libs
57 Summary:        Evas library
58 Summary(pl):    Biblioteka evas
59 Group:          X11/Libraries
60
61 %description libs
62 Evas library.
63
64 %description libs -l pl
65 Biblioteka evas.
66
67 %package devel
68 Summary:        Evas header files
69 Summary(pl):    Pliki nag³ówkowe Evas
70 Group:          Development/Libraries
71 Requires:       %{name}-libs = %{version}-%{release}
72 %{?with_directfb:Requires:      DirectFB-devel}
73 Requires:       OpenGL-devel
74 Requires:       edb-devel
75 Requires:       eet-devel
76 Requires:       freetype-devel
77 Requires:       libjpeg-devel
78 Requires:       libpng-devel
79
80 %description devel
81 Header files for Evas.
82
83 %description devel -l pl
84 Pliki nag³ówkowe Evas.
85
86 %package static
87 Summary:        Static Evas library
88 Summary(pl):    Statyczna biblioteka Evas
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91
92 %description static
93 Static Evas library.
94
95 %description static -l pl
96 Statyczna biblioteka Evas.
97
98 %prep
99 %setup -q
100
101 %build
102 %configure \
103         %{!?with_static_libs:--disable-static} \
104         --enable-software-x11   \
105         --disable-software-xcb  \
106         --%{?with_directfb:en}%{!?with_directfb:dis}able-directfb       \
107         --enable-fb             \
108         --enable-buffer         \
109         --disable-software-qtopia \
110         --enable-gl-x11         \
111         --enable-xrender-x11    \
112         --enable-image-loader-png       \
113         --enable-image-loader-jpeg      \
114         --enable-image-loader-eet       \
115         --enable-font-loader-eet        \
116         --enable-image-loader-edb       \
117 %if %{with mmx}
118         --enable-cpu-mmx        \
119 %else
120         --disable-cpu-mmx       \
121 %endif
122 %if %{with sse}
123         --enable-cpu-sse        \
124 %else
125         --disable-cpu-sse       \
126 %endif
127 %if %{with altivec}
128         --enable-cpu-altivec    \
129 %else
130         --disable-cpu-altivec   \
131 %endif
132         --enable-cpu-c          \
133         --disable-valgrind
134
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 cd $RPM_BUILD_ROOT%{_datadir}/%{name}
144 VERA=$(ls Vera*.ttf)
145 for FONT in $VERA; do
146         rm -f $FONT
147         ln -s %{_fontsdir}/TTF/$FONT .
148 done
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   libs -p /sbin/ldconfig
154 %postun libs -p /sbin/ldconfig
155
156 %files
157 %defattr(644,root,root,755)
158 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
159 %attr(755,root,root) %{_bindir}/evas_*
160 %{_datadir}/%{name}
161
162 %files libs
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libevas.so.*.*.*
165 %dir %{_libdir}/%{name}
166 %dir %{_libdir}/%{name}/modules
167 %dir %{_libdir}/%{name}/modules/*
168 %dir %{_libdir}/%{name}/modules/*/*
169 %dir %{_libdir}/%{name}/modules/*/*/linux-gnu-*
170 %attr(755,root,root) %{_libdir}/%{name}/modules/*/*/linux-gnu-*/module.so
171
172 %files devel
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/evas-config
175 %attr(755,root,root) %{_libdir}/libevas.so
176 %{_libdir}/libevas.la
177 %{_pkgconfigdir}/evas.pc
178 %{_includedir}/Evas*
179
180 %if %{with static_libs}
181 %files static
182 %defattr(644,root,root,755)
183 %{_libdir}/libevas.a
184 %endif
This page took 0.028245 seconds and 2 git commands to generate.