]> git.pld-linux.org Git - packages/evas.git/blob - evas.spec
83fbc2c90223016396944eafb56dcae8575dcf1a
[packages/evas.git] / evas.spec
1 #
2 %bcond_with     mmx
3 %bcond_with     sse
4 %bcond_with     altivec
5 #
6 %ifarch i686 athlon
7 %define with_mmx        1
8 %endif
9 Summary:        Multi-platform Canvas Library
10 Summary(pl):    Wieloplatformowa biblioteka do rysowania
11 Name:           evas
12 Version:        0.9.9
13 %define _snap   20050329
14 Release:        0.%{_snap}.0.1
15 License:        BSD
16 Group:          Libraries
17 #Source0:       http://dl.sourceforge.net/enlightenment/%{name}-%{version}_%{_pre}.tar.gz
18 Source0:        ftp://ftp.sparky.homelinux.org/pub/e17/%{name}-%{_snap}.tar.gz
19 # Source0-md5:  d29b5c91e01c3eda9ff8a940dfe84398
20 URL:            http://enlightenment.org/
21 BuildRequires:  DirectFB-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 #BuildRequires: cairo-devel
26 BuildRequires:  edb-devel
27 BuildRequires:  eet-devel
28 BuildRequires:  freetype-devel
29 BuildRequires:  libjpeg-devel
30 BuildRequires:  libpng-devel
31 BuildRequires:  libtool
32 BuildRequires:  pkgconfig
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Evas is a clean display canvas API for several target display systems
37 that can draw anti-aliased text, smooth super and sub-sampled scaled
38 images, alpha-blend objects much and more.
39
40 %description -l pl
41 Evas to czyste API "p³ótna obrazu" dla ró¿nych systemów wy¶wietlania,
42 bêd±ce w stanie rysowaæ tekst z antyaliasingiem, wyg³adzane, skalowane
43 obrazy, obiekty z alpha-blendingiem i inne elementy.
44
45 %package devel
46 Summary:        Evas header files
47 Summary(pl):    Pliki nag³ówkowe Evas
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       DirectFB-devel
51 Requires:       OpenGL-devel
52 #Requires:      cairo-devel
53 Requires:       edb-devel
54 Requires:       eet-devel
55 Requires:       freetype-devel
56 Requires:       libjpeg-devel
57 Requires:       libpng-devel
58
59 %description devel
60 Header files for Evas.
61
62 %description devel -l pl
63 Pliki nag³ówkowe Evas.
64
65 %package static
66 Summary:        Static Evas library
67 Summary(pl):    Statyczna biblioteka Evas
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static Evas library.
73
74 %description static -l pl
75 Statyczna biblioteka Evas.
76
77 %prep
78 #%%setup -q -n %{name}-%{version}_%{_pre}
79 %setup -q -n %{name}
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I m4
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure \
88         --enable-software-x11   \
89         --enable-direct-fb      \
90         --enable-fb             \
91         --enable-buffer         \
92         --disable-software-qtopia \
93         --enable-gl-x11         \
94         --enable-cairo-x11      \
95 %if %{with mmx}
96         --enable-cpu-mmx        \
97 %else
98         --disable-cpu-mmx       \
99 %endif
100 %if %{with sse}
101         --enable-cpu-sse        \
102 %else
103         --disable-cpu-sse       \
104 %endif
105 %if %{with altivec}
106         --enable-cpu-altivec    \
107 %else
108         --disable-cpu-altivec   \
109 %endif
110         --enable-cpu-c
111 #/usr/lib/libcairo.so: undefined reference to `pixman_image_get_format'
112 #/usr/lib/libcairo.so: undefined reference to `pixman_format_get_masks'
113 # -- it looks like cairo problem, not evas; too  old libpixman?
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS README COPYING
131 %attr(755,root,root) %{_bindir}/evas_*
132 %attr(755,root,root) %{_libdir}/libevas.so.*.*.*
133 %{_datadir}/%{name}
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/evas-config
138 %attr(755,root,root) %{_libdir}/libevas.so
139 %{_libdir}/libevas.la
140 %{_pkgconfigdir}/evas.pc
141 %{_includedir}/Evas*
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libevas.a
This page took 0.145259 seconds and 2 git commands to generate.