]> git.pld-linux.org Git - packages/evas.git/blob - evas.spec
- without directfb bcond
[packages/evas.git] / evas.spec
1 #
2 # Conditional build:
3 %bcond_without  mmx             # without MMX and MMX2
4 %bcond_without  sse             # without SSE
5 %bcond_without  altivec         # without altivec
6 %bcond_without  directfb        # build without DirectFB support
7 %bcond_without  static_libs     # don't build static library
8 #
9 %ifnarch i586 i686 athlon %{x8664}
10 %undefine       with_mmx
11 %endif
12 %ifnarch i686 athlon %{x8664}
13 %undefine       with_sse
14 %endif
15 %ifnarch ppc
16 %undefine       with_altivec
17 %endif
18 #
19 Summary:        Multi-platform Canvas Library
20 Summary(pl):    Wieloplatformowa biblioteka do rysowania
21 Name:           evas
22 Version:        0.9.9.023
23 Release:        1
24 License:        BSD
25 Group:          Libraries
26 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
27 # Source0-md5:  ca5528c8894d49cbdf77873f5974c0e8
28 #Patch0:                %{name}-missing_m4.patch
29 URL:            http://enlightenment.org/Libraries/Evas/
30 %{?with_directfb:BuildRequires: DirectFB-devel}
31 BuildRequires:  OpenGL-devel
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  edb-devel
35 BuildRequires:  eet-devel
36 BuildRequires:  freetype-devel
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libtool
40 BuildRequires:  pkgconfig
41 Requires:       %{name}-libs = %{version}-%{release}
42 Requires:       fonts-TTF-bitstream-vera
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %undefine       __cxx
46
47 %description
48 Evas is a clean display canvas API for several target display systems
49 that can draw anti-aliased text, smooth super and sub-sampled scaled
50 images, alpha-blend objects much and more.
51
52 %description -l pl
53 Evas to czyste API "p³ótna obrazu" dla ró¿nych systemów wy¶wietlania,
54 bêd±ce w stanie rysowaæ tekst z antyaliasingiem, wyg³adzane, skalowane
55 obrazy, obiekty z alpha-blendingiem i inne elementy.
56
57 %package libs
58 Summary:        Evas library
59 Summary(pl):    Biblioteka evas
60 Group:          X11/Libraries
61
62 %description libs
63 Evas library.
64
65 %description libs -l pl
66 Biblioteka evas.
67
68 %package devel
69 Summary:        Evas header files
70 Summary(pl):    Pliki nag³ówkowe Evas
71 Group:          Development/Libraries
72 Requires:       %{name}-libs = %{version}-%{release}
73 Requires:       DirectFB-devel
74 Requires:       OpenGL-devel
75 Requires:       edb-devel
76 Requires:       eet-devel
77 Requires:       freetype-devel
78 Requires:       libjpeg-devel
79 Requires:       libpng-devel
80
81 %description devel
82 Header files for Evas.
83
84 %description devel -l pl
85 Pliki nag³ówkowe Evas.
86
87 %package static
88 Summary:        Static Evas library
89 Summary(pl):    Statyczna biblioteka Evas
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Static Evas library.
95
96 %description static -l pl
97 Statyczna biblioteka Evas.
98
99 %prep
100 %setup -q
101 #%%patch0 -p1
102
103 %build
104 #%%{__libtoolize}
105 #%%{__aclocal}
106 #%%{__autoconf}
107 #%%{__autoheader}
108 #%%{__automake}
109 %configure \
110         %{!?with_static_libs:--disable-static} \
111         --enable-software-x11   \
112         --disable-software-xcb  \
113         --%{?with_directfb:en}%{!?with_directfb:dis}able-directfb       \
114         --enable-fb             \
115         --enable-buffer         \
116         --disable-software-qtopia \
117         --enable-gl-x11         \
118         --enable-xrender-x11    \
119         --enable-image-loader-png       \
120         --enable-image-loader-jpeg      \
121         --enable-image-loader-eet       \
122         --enable-font-loader-eet        \
123         --enable-image-loader-edb       \
124 %if %{with mmx}
125         --enable-cpu-mmx        \
126 %else
127         --disable-cpu-mmx       \
128 %endif
129 %if %{with sse}
130         --enable-cpu-sse        \
131 %else
132         --disable-cpu-sse       \
133 %endif
134 %if %{with altivec}
135         --enable-cpu-altivec    \
136 %else
137         --disable-cpu-altivec   \
138 %endif
139         --enable-cpu-c          \
140         --disable-valgrind
141
142 %{__make}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 cd $RPM_BUILD_ROOT%{_datadir}/%{name}
151 VERA=$(ls Vera*.ttf)
152 for FONT in $VERA; do
153         rm -f $FONT
154         ln -s %{_fontsdir}/TTF/$FONT .
155 done
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   libs -p /sbin/ldconfig
161 %postun libs -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
166 %attr(755,root,root) %{_bindir}/evas_*
167 %{_datadir}/%{name}
168
169 %files libs
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/libevas.so.*.*.*
172
173 %files devel
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_bindir}/evas-config
176 %attr(755,root,root) %{_libdir}/libevas.so
177 %{_libdir}/libevas.la
178 %{_pkgconfigdir}/evas.pc
179 %{_includedir}/Evas*
180
181 %if %{with static_libs}
182 %files static
183 %defattr(644,root,root,755)
184 %{_libdir}/libevas.a
185 %endif
This page took 0.07654 seconds and 3 git commands to generate.