]> git.pld-linux.org Git - packages/ettercap.git/blame - ettercap.spec
rebuild with openssl 3.0.0
[packages/ettercap.git] / ettercap.spec
CommitLineData
3f3d70e0
AG
1#
2# Conditional build:
f8c47986
JB
3%bcond_without geoip # GeoIP support
4%bcond_without gtk # gtk-based frontend
5%bcond_with gtk2 # use GTK+ 2.x instead of 3.x
6%bcond_with lua # experimental Lua support
7a769489 7#
26f54874 8Summary: ettercap - a ncurses-based sniffer/interceptor utility
09b437f4
ER
9Summary(pl.UTF-8): ettercap - oparte o ncurses narzędzie do sniffowania/przechwytywania
10Summary(pt_BR.UTF-8): ettercap e um interceptador/sniffer paseado em ncurses
0e21442b 11Name: ettercap
f8c47986 12Version: 0.8.3
474a6274 13Release: 2
65c513b5 14Epoch: 1
f8c47986 15License: GPL v2+ with OpenSSL exception
0e21442b 16Group: Networking/Utilities
f8c47986
JB
17#Source0Download: https://github.com/Ettercap/ettercap/releases
18Source0: https://github.com/Ettercap/ettercap/releases/download/v%{version}/%{name}-%{version}.tar.gz
19# Source0-md5: 6b27d329a509e65fef9044c95a2dde35
20Patch0: %{name}-buildtype.patch
21Patch1: %{name}-gtk3.patch
22Patch2: %{name}-link.patch
87d4c0bd 23Patch3: %{name}-no-common.patch
f8c47986
JB
24URL: https://www.ettercap-project.org/
25%{?with_geoip:BuildRequires: GeoIP-devel}
26BuildRequires: bison
27BuildRequires: cmake >= 2.8
28BuildRequires: curl-devel >= 7.26.0
29BuildRequires: flex
30%if %{with gtk}
31%{?with_gtk2:BuildRequires: gtk+2-devel >= 2:2.10}
32%{!?with_gtk2:BuildRequires: gtk+3-devel >= 3.12.0}
33%endif
34BuildRequires: libbsd-devel
35BuildRequires: libnet-devel >= 1:1.1.5
7a769489 36BuildRequires: libpcap-devel
f8c47986 37%{?with_lua:BuildRequires: luajit-devel >= 2.0.0}
9fb25dec
ER
38BuildRequires: ncurses-ext-devel
39BuildRequires: openssl-devel >= 0.9.7d
7a769489 40BuildRequires: pcre-devel
597fc980 41BuildRequires: pkgconfig
f8c47986
JB
42BuildRequires: zlib-devel
43Requires: curl-libs >= 7.26.0
44%if %{with gtk}
45%{?with_gtk2:Requires: gtk+2 >= 2:2.10}
46%{!?with_gtk2:Requires: gtk+3 >= 3.12.0}
47%endif
48Requires: libnet >= 1:1.1.5
2d753dd0 49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0e21442b 50
2183bd99
TP
51%define specflags -fomit-frame-pointer
52
0e21442b 53%description
36a3928d 54ettercap is a network sniffer/interceptor/logger for ethernet LANs
55(both switched or not). It supports active and passive dissection of
56many protocols (even ciphered ones, like SSH and HTTPS). Data
57injection in an established connection and filtering (substitute or
58drop a packet) on the fly is also possible, keeping the connection
26f54874 59synchronized. Many sniffing modes were implemented to give you a
36a3928d 60powerful and complete sniffing suite. Plugins are supported. It has
61the ability to check whether you are in a switched LAN or not, and to
62use OS fingerprints (active or passive) to let you know the geometry
26f54874
JB
63of the LAN. The passive scan of the LAN retrieves infos about: hosts
64in the lan, open ports, services version, type of the host (gateway,
36a3928d 65router or simple host) and extimated distance in hop.
0e21442b 66
aa81fd7c
JR
67%description -l pl.UTF-8
68ettercap jest wieloczynnościowym snifferem/przechwytywaczem/loggerem
69dla sieci LAN (opartych na switchach lub hubach). Obsługuje aktywną i
70pasywną analizę wielu protokołów (nawet szyfrowanych, jak SSH czy
71HTTPS). Możliwe jest także wstrzykiwanie lub filtrowanie danych
72(podmiana lub usunięcie pakietu) w locie, przy podtrzymaniu
73synchronizacji połączenia. Program ma zaimplementowane wiele trybów
74sniffowania, aby dać potężne i kompletne narzędzie. Obsługiwane są
75wtyczki. Program ma możliwość sprawdzania, czy pracuje w sieci ze
76switchami oraz używania odcisków systemów (aktywnego lub pasywnego) do
3f3d70e0 77poznania geometrii sieci. Pasywne skanowanie sieci uzyskuje informacje
aa81fd7c
JR
78o: hostach w sieci, otwartych portach, wersjach usług, rodzajach
79hostów (bramki, routery lub zwykłe komputery) oraz przybliżonych
80odległościach (w hopach).
d2dd519f 81
aa81fd7c
JR
82%description -l pt_BR.UTF-8
83ettercap é um sniffer/interceptor/logger de rede para redes locais
84(com uso de switches ou não). Suporta operações ativas e passivas de
85vários protocolos (mesmo os criptografados, como SSH e HTTPS). Também
86é possível injeção de dados em uma conexão estabelecida e filtragem
87(substituição ou descarte de um pacote) em tempo real mantendo a
88conexão sincronizada. Muitos modos de sniffing foram implementadas
89para proporcionar a você um completo conjunto de sniffing. Plugins são
90suportados. Tem a habilidade de verificar se você está em uma rede
91local com switches ou não. Utiliza fingerprints do Sistema Operacional
92(ativo ou passivo) para permitir que você conheça a geometria da rede
93local. A varredura passiva da rede local obtém informações sobre:
94hosts na rede local, portas abertas, versão de serviços, tipo de host
95(gateway, router ou um computador) e a distância estimada no hop.
36a3928d 96
0e21442b 97%prep
f8c47986
JB
98%setup -q
99%patch0 -p1
cfaadd6a 100%patch1 -p1
101%patch2 -p1
87d4c0bd 102%patch3 -p1
0e21442b
GS
103
104%build
f8c47986
JB
105install -d build
106cd build
107%cmake .. \
108 -DBUNDLED_LIBS=OFF \
109 %{!?with_geoip:-DENABLE_GEOIP=OFF} \
110 %{!?with_gtk:-DENABLE_GTK=OFF} \
111 -DENABLE_IPV6=ON
112 %{?with_lua:-DENABLE_LUA=ON} \
113 %{?with_gtk2:-DGTK_BUILD_TYPE=GTK2}
114
0e21442b 115%{__make}
0e21442b
GS
116
117%install
118rm -rf $RPM_BUILD_ROOT
0663f6ee 119
f8c47986 120%{__make} -C build install \
45d6bacc 121 DESTDIR=$RPM_BUILD_ROOT
0e21442b 122
f8c47986
JB
123# API not exported
124%{__rm} $RPM_BUILD_ROOT%{_libdir}/libettercap*.so
125
0e21442b
GS
126%clean
127rm -rf $RPM_BUILD_ROOT
128
f8c47986
JB
129%post -p /sbin/ldconfig
130%postun -p /sbin/ldconfig
131
0e21442b
GS
132%files
133%defattr(644,root,root,755)
f8c47986
JB
134%doc AUTHORS CHANGELOG LICENSE.OPENSSL README README.{BINARIES,BUGS} THANKS TODO doc/*
135%attr(755,root,root) %{_bindir}/ettercap
136%attr(755,root,root) %{_bindir}/ettercap-pkexec
137%attr(755,root,root) %{_bindir}/etterfilter
138%attr(755,root,root) %{_bindir}/etterlog
139%attr(755,root,root) %{_libdir}/libettercap.so.*.*.*
140%attr(755,root,root) %ghost %{_libdir}/libettercap.so.0
141%attr(755,root,root) %{_libdir}/libettercap-ui.so.*.*.*
142%attr(755,root,root) %ghost %{_libdir}/libettercap-ui.so.0
9fb25dec 143%dir %{_libdir}/ettercap
f8c47986
JB
144%attr(755,root,root) %{_libdir}/ettercap/ec_*.so
145%dir %{_sysconfdir}/ettercap
146%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.conf
147%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.dns
148%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.mdns
149%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ettercap/etter.nbns
150%{_datadir}/appdata/ettercap.appdata.xml
7658ab6d 151%{_datadir}/ettercap
f8c47986
JB
152%{_datadir}/polkit-1/actions/org.pkexec.ettercap.policy
153%{_desktopdir}/ettercap.desktop
154%{_pixmapsdir}/ettercap.svg
155%{_mandir}/man5/etter.conf.5*
156%{_mandir}/man8/ettercap.8*
157%{_mandir}/man8/ettercap-pkexec.8*
158%{_mandir}/man8/ettercap_curses.8*
159%{_mandir}/man8/ettercap_plugins.8*
160%{_mandir}/man8/etterfilter.8*
161%{_mandir}/man8/etterlog.8*
This page took 0.09677 seconds and 4 git commands to generate.