]> git.pld-linux.org Git - packages/etckeeper.git/commitdiff
up to 1.18.8 auto/th/etckeeper-1.18.8-1
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 22 Aug 2018 12:47:40 +0000 (15:47 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Wed, 22 Aug 2018 12:51:24 +0000 (15:51 +0300)
etckeeper.spec
use-libdir.patch

index a77b39f7f5344a029949d96c24462282404b29d9..ea5b0a986538e1d418d53fefaa8479dd6d4519ef 100644 (file)
@@ -3,12 +3,12 @@
 # - Subpackages for backends (darcs, git, hg)
 Summary:       Store /etc in a SCM system (git, mercurial, bzr or darcs)
 Name:          etckeeper
-Version:       1.18.5
+Version:       1.18.8
 Release:       1
 License:       GPL v2+
 Group:         Applications/System
-Source0:       https://github.com/joeyh/etckeeper/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: c06a5f69cc6d53da6e280e7d9ddafb11
+Source0:       https://git.joeyh.name/index.cgi/etckeeper.git/snapshot/%{name}-%{version}.tar.gz
+# Source0-md5: d3ce4568868324af81ed8c46f9a5d3eb
 Source1:       pre-install.sh
 Source2:       post-install.sh
 Patch1:                use-libdir.patch
index fb7c5afe8210b9b674adee378c1abd8da6284371..022dd600a3220c8cc255bdfb28cdf46ba167426e 100644 (file)
@@ -1,5 +1,5 @@
---- etckeeper/etckeeper.orig   2015-03-14 18:24:26.000000000 +0100
-+++ etckeeper/etckeeper        2015-04-07 00:54:26.014557154 +0200
+--- etckeeper-1.18.8/etckeeper~        2018-08-22 15:47:48.000000000 +0300
++++ etckeeper-1.18.8/etckeeper 2018-08-22 15:49:36.932110437 +0300
 @@ -1,6 +1,10 @@
  #!/bin/sh
  set -e
        exit 1
  fi
  
-@@ -122,13 +126,14 @@
+@@ -132,19 +132,20 @@
+ if [ "$(which perl 2>/dev/null)" != "" ]; then
+       lsscripts() {
+               LANG=C perl -e '
+-                      $dir=shift;
++                      for $dir (@ARGV) {
+                       print join "\n", grep { ! -d $_ && -x $_ }
+                               grep /^\Q$dir\/\E[-a-zA-Z0-9]+$/,
+                               glob "$dir/*";
+-              ' "$1"
++                      }
++              ' "$@"
+       }
  
- lsscripts() {
-       LANG=C perl -e '
--              $dir=shift;
-+              for $dir (@ARGV) {
-               print join "\n", grep { ! -d $_ && -x $_ }
-                       grep /^\Q$dir\/\E[-a-zA-Z0-9]+$/,
-                       glob "$dir/*";
--      ' "$1"
-+              }
-+      ' "$@"
- }
--for script in $(lsscripts "$ETCKEEPER_CONF_DIR/$command.d"); do
-+for script in $(lsscripts "$ETCKEEPER_LIB_DIR/$command.d" "$ETCKEEPER_CONF_DIR/$command.d"); do
-       "$script" "$@"
- done
+-      for script in $(lsscripts "$ETCKEEPER_CONF_DIR/$command.d"); do
++      for script in $(lsscripts "$ETCKEEPER_LIB_DIR/$command.d" "$ETCKEEPER_CONF_DIR/$command.d"); do
+               "$script" "$@"
+       done
+ else
+       # fallback if perl isn't present
+-      for script in $ETCKEEPER_CONF_DIR/$command.d/*; do
++      for script in "$ETCKEEPER_LIB_DIR/$command.d/"* "$ETCKEEPER_CONF_DIR/$command.d/"*; do
+               if [ ! -d "$script" -a -x "$script" ]; then
+                       echo "$script" | egrep -q "/[-a-zA-Z0-9]+$"
+                       [ $? -eq 0 ] && "$script" "$@"
 --- etckeeper-1.18.4/debian/cron.daily~        2016-06-20 08:06:01.000000000 +0300
 +++ etckeeper-1.18.4/debian/cron.daily 2016-06-29 23:41:40.939927867 +0300
 @@ -3,6 +3,6 @@
This page took 0.097896 seconds and 4 git commands to generate.