]> git.pld-linux.org Git - packages/espeak.git/blob - espeak.spec
- add ac/am stuff to the source package
[packages/espeak.git] / espeak.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4 #
5 Summary:        eSpeak - speech synthesizer for English and other languages
6 Summary(pl):    eSpeak - syntezator mowy dla jêzyka angielskiego i innych
7 Name:           speak
8 Version:        1.14
9 Release:        0.1
10 License:        GPL v2
11 Group:          Applications
12 Source0:        http://dl.sourceforge.net/espeak/%{name}-%{version}-source.zip
13 # Source0-md5:  9a52e2a00354474334adc36fe2fdd4c6
14 Patch0:         %{name}-ac_am.patch
15 Patch1:         %{name}-sys_includes.patch
16 URL:            http://espeak.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool
21 BuildRequires:  portaudio-devel >= 19
22 BuildRequires:  unzip
23 Requires:       %{name}-libs = %{version}-%{release}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 eSpeak is a software speech synthesizer for English and other
28 languages. eSpeak produces good quality English speech. It uses a
29 different synthesis method from other open source TTS engines, and
30 sounds quite different. It's perhaps not as natural or "smooth", but I
31 find the articulation clearer and easier to listen to for long
32 periods.
33 - It can run as a command line program to speak text from a file or
34   from stdin. A library version is also available (isn't available in
35   this package).
36 - Includes different Voices, whose characteristics can be altered.
37 - Can produce speech output as a WAV file.
38 - SSML (Speech Synthesis Markup Language) is supported (not complete),
39   and also HTML.
40 - Compact size. The program and its data, including several languages,
41   totals about 420 kbytes.
42 - Can translate text to phoneme codes, so it could be adapted as a
43   front end for another speech synthesis engine.
44 - Potential for other languages. Several are included (e.g. Polish
45   language) in varying stages of progress. Help from native speakers
46   for these or other languages is welcomed.
47 - Development tools available for producing and tuning phoneme data.
48 - Written in C++.
49
50 It works well as a "Talker" with the KDE text to speech system (KTTS),
51 as an alternative to Festival for example. As such, it can speak text
52 which has been selected into the clipboard, or directly from the
53 Konquerer browser or the Kate editor.
54
55 %description -l pl
56 eSpeak to programowy syntezator mowy dla angielskiego i innych
57 jêzyków. Odtwarza angielsk± mowê dobrej jako¶ci. U¿ywa innej metody
58 syntezy ni¿ inne silniki TTS o otwartych ¼ród³ach i brzmi trochê
59 inaczej. Nie jest mo¿e tak naturalny czy "g³adki", ale autor uwa¿a tê
60 wymowê za czystsz± i ³atwiejsz± w s³uchaniu na d³u¿sz± metê.
61
62 - Mo¿e dzia³aæ jako program z linii poleceñ do wymawiania tekstu z
63   pliku lub standardowego wej¶cia; dostêpna jest tak¿e wersja w
64   postaci biblioteki (nie w tym pakiecie).
65 - Zawiera ró¿ne g³osy, a ich charakterystykê mo¿na zmieniaæ.
66 - Potrafi tworzyæ pliki WAV z mow±.
67 - Obs³ugiwany (ale nie w pe³ni) jest SSML (Speech Synthesis Markup
68   Language)  oraz HTML.
69 - Ma³y rozmiar - program i jego dane, wraz z kilkoma jêzykami,
70   mieszcz± siê w oko³o 420kB.
71 - Potrafi t³umaczyæ tekst na kody fonemów, wiêc mo¿e byæ zaadaptowany
72   jako frontend dla innych silników syntezy mowy.
73 - Potencjalnie mo¿e nadawaæ siê dla innych jêzyków; kilka jest
74   do³±czonych (na przyk³ad j.polski) w ró¿nym stadium zaawansowania.
75   Mile widziana jest pomoc od osób, dla których s± to jêzyki ojczyste.
76 - Dostêpne s± narzêdzia programistyczne do tworzenia i dostrajania
77   danych dla fonemów.
78 - Napisany w C++.
79
80 Dobrze pracuje jako "mówca" z systemem przetwarzania tekstu na mowê
81 KDE (KTTS), na przyk³ad, jako alternatywa dla Festivala. Jako taki,
82 mo¿e czytaæ na g³os tekst zaznaczony uprzednio do schowka lub
83 bezpo¶rednio z przegl±darki Konqueror i edytora Kate.
84
85 %package libs
86 Summary: eSpeak shared libraries
87 Summary(pl): eSpeak - biblioteki
88 Group:  Libraries
89
90 %description libs
91 eSpeak shared libraries.
92
93 %description libs -l pl
94 eSpeak - biblioteki dzielone.
95
96 %package devel
97 Summary:        eSpeak - development files
98 Summary(pl):    eSpeak - pliki dla programistów
99 Group:  Development/Libraries
100 Requires:       %{name}-libs = %{version}-%{release}
101
102 %description devel
103 eSpeak - development files.
104
105 %description devel -l pl
106 eSpeak - pliki dla programistów.
107
108 %package static
109 Summary:        eSpeak - static libraries
110 Summary(pl):    eSpeak - biblioteki statyczne
111 Group:  Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description static
115 eSpeak - static libraries.
116
117 %description static -l pl
118 eSpeak - biblioteki statyczne.
119
120 %prep
121 %setup -q -n %{name}-%{version}-source
122 %patch0 -p1
123 %patch1 -p1
124 # remove pernicious headers to avoid using them during build instead of /usr/include/portaudio.h system header
125 rm -f src/portaudio{18,19,}.h
126
127 %build
128 %{__libtoolize}
129 %{__aclocal}
130 %{__autoconf}
131 %{__autoheader}
132 %{__automake}
133 %configure \
134         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post libs -p /sbin/ldconfig
147 %postun libs -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc ChangeLog ReadMe docs
152 %attr(755,root,root) %{_bindir}/*
153 %dir %{_datadir}/e%{name}-data
154 %dir %{_datadir}/e%{name}-data/voices
155 %dir %{_datadir}/e%{name}-data/voices/en
156 %{_datadir}/e%{name}-data/voices/af
157 %{_datadir}/e%{name}-data/voices/cy
158 %{_datadir}/e%{name}-data/voices/de
159 %{_datadir}/e%{name}-data/voices/default
160 %{_datadir}/e%{name}-data/voices/el
161 %{_datadir}/e%{name}-data/voices/en/en-rp-f
162 %{_datadir}/e%{name}-data/voices/en/en-wm-f
163 %{_datadir}/e%{name}-data/voices/en/en-n
164 %{_datadir}/e%{name}-data/voices/en/en
165 %{_datadir}/e%{name}-data/voices/en/en1
166 %{_datadir}/e%{name}-data/voices/en/en2
167 %{_datadir}/e%{name}-data/voices/en/en3
168 %{_datadir}/e%{name}-data/voices/en/en4
169 %{_datadir}/e%{name}-data/voices/en/en6
170 %{_datadir}/e%{name}-data/voices/en/en7
171 %{_datadir}/e%{name}-data/voices/en/en8
172 %{_datadir}/e%{name}-data/voices/en/en-croak
173 %{_datadir}/e%{name}-data/voices/en/en-f
174 %{_datadir}/e%{name}-data/voices/en/en-rp
175 %{_datadir}/e%{name}-data/voices/en/en-n-f
176 %{_datadir}/e%{name}-data/voices/en/en-wm
177 %{_datadir}/e%{name}-data/voices/eo
178 %{_datadir}/e%{name}-data/voices/es
179 %{_datadir}/e%{name}-data/voices/it
180 %{_datadir}/e%{name}-data/voices/pl
181 %{_datadir}/e%{name}-data/voices/ru
182 %dir %{_datadir}/e%{name}-data/soundicons
183 %{_datadir}/e%{name}-data/af_dict
184 %{_datadir}/e%{name}-data/config
185 %{_datadir}/e%{name}-data/cy_dict
186 %{_datadir}/e%{name}-data/de_dict
187 %{_datadir}/e%{name}-data/en_dict
188 %{_datadir}/e%{name}-data/eo_dict
189 %{_datadir}/e%{name}-data/el_dict
190 %{_datadir}/e%{name}-data/es_dict
191 %{_datadir}/e%{name}-data/it_dict
192 %{_datadir}/e%{name}-data/phondata
193 %{_datadir}/e%{name}-data/phonindex
194 %{_datadir}/e%{name}-data/phontab
195 %{_datadir}/e%{name}-data/pl_dict
196 %{_datadir}/e%{name}-data/ru_dict
197
198 %files libs
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
201
202 %files devel
203 %defattr(644,root,root,755)
204 %{_includedir}/*
205 %attr(755,root,root) %{_libdir}/lib*.so
206 %{_libdir}/lib*.la
207
208 %if %{with static_libs}
209 %files static
210 %defattr(644,root,root,755)
211 %{_libdir}/lib*.a
212 %endif
This page took 0.079538 seconds and 4 git commands to generate.