]> git.pld-linux.org Git - packages/espeak.git/blob - espeak.spec
89fafacc606f547665812d0dc2f62b70fcb0c20d
[packages/espeak.git] / espeak.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4 #
5 Summary:        eSpeak - speech synthesizer for English and other languages
6 Summary(pl):    eSpeak - syntezator mowy dla jêzyka angielskiego i innych
7 Name:           espeak
8 Version:        1.16
9 Release:        0.1
10 License:        GPL v2
11 Group:          Applications
12 Source0:        http://dl.sourceforge.net/espeak/%{name}-%{version}-source.zip
13 # Source0-md5:  c376ea94cddda90b093f231926f7ba44
14 Patch0:         %{name}-ac_am.patch
15 URL:            http://espeak.sourceforge.net/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool
20 BuildRequires:  portaudio-devel >= 19
21 BuildRequires:  unzip
22 Requires:       %{name}-libs = %{version}-%{release}
23 Obsoletes:      speak
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 eSpeak is a software speech synthesizer for English and other
28 languages. eSpeak produces good quality English speech. It uses a
29 different synthesis method from other open source TTS engines, and
30 sounds quite different. It's perhaps not as natural or "smooth", but I
31 find the articulation clearer and easier to listen to for long
32 periods.
33 - It can run as a command line program to speak text from a file or
34   from stdin. A library version is also available (isn't available in
35   this package).
36 - Includes different Voices, whose characteristics can be altered.
37 - Can produce speech output as a WAV file.
38 - SSML (Speech Synthesis Markup Language) is supported (not complete),
39   and also HTML.
40 - Compact size. The program and its data, including several languages,
41   totals about 420 kbytes.
42 - Can translate text to phoneme codes, so it could be adapted as a
43   front end for another speech synthesis engine.
44 - Potential for other languages. Several are included (e.g. Polish
45   language) in varying stages of progress. Help from native speakers
46   for these or other languages is welcomed.
47 - Development tools available for producing and tuning phoneme data.
48 - Written in C++.
49
50 It works well as a "Talker" with the KDE text to speech system (KTTS),
51 as an alternative to Festival for example. As such, it can speak text
52 which has been selected into the clipboard, or directly from the
53 Konquerer browser or the Kate editor.
54
55 %description -l pl
56 eSpeak to programowy syntezator mowy dla angielskiego i innych
57 jêzyków. Odtwarza angielsk± mowê dobrej jako¶ci. U¿ywa innej metody
58 syntezy ni¿ inne silniki TTS o otwartych ¼ród³ach i brzmi trochê
59 inaczej. Nie jest mo¿e tak naturalny czy "g³adki", ale autor uwa¿a tê
60 wymowê za czystsz± i ³atwiejsz± w s³uchaniu na d³u¿sz± metê.
61
62 - Mo¿e dzia³aæ jako program z linii poleceñ do wymawiania tekstu z
63   pliku lub standardowego wej¶cia; dostêpna jest tak¿e wersja w
64   postaci biblioteki (nie w tym pakiecie).
65 - Zawiera ró¿ne g³osy, a ich charakterystykê mo¿na zmieniaæ.
66 - Potrafi tworzyæ pliki WAV z mow±.
67 - Obs³ugiwany (ale nie w pe³ni) jest SSML (Speech Synthesis Markup
68   Language)  oraz HTML.
69 - Ma³y rozmiar - program i jego dane, wraz z kilkoma jêzykami,
70   mieszcz± siê w oko³o 420kB.
71 - Potrafi t³umaczyæ tekst na kody fonemów, wiêc mo¿e byæ zaadaptowany
72   jako frontend dla innych silników syntezy mowy.
73 - Potencjalnie mo¿e nadawaæ siê dla innych jêzyków; kilka jest
74   do³±czonych (na przyk³ad j.polski) w ró¿nym stadium zaawansowania.
75   Mile widziana jest pomoc od osób, dla których s± to jêzyki ojczyste.
76 - Dostêpne s± narzêdzia programistyczne do tworzenia i dostrajania
77   danych dla fonemów.
78 - Napisany w C++.
79
80 Dobrze pracuje jako "mówca" z systemem przetwarzania tekstu na mowê
81 KDE (KTTS), na przyk³ad, jako alternatywa dla Festivala. Jako taki,
82 mo¿e czytaæ na g³os tekst zaznaczony uprzednio do schowka lub
83 bezpo¶rednio z przegl±darki Konqueror i edytora Kate.
84
85 %package libs
86 Summary:        eSpeak shared libraries
87 Summary(pl):    eSpeak - biblioteki
88 Group:          Libraries
89 Obsoletes:      speak-libs
90
91 %description libs
92 eSpeak shared libraries.
93
94 %description libs -l pl
95 eSpeak - biblioteki dzielone.
96
97 %package devel
98 Summary:        eSpeak - development files
99 Summary(pl):    eSpeak - pliki dla programistów
100 Group:          Development/Libraries
101 Requires:       %{name}-libs = %{version}-%{release}
102
103 %description devel
104 eSpeak - development files.
105
106 %description devel -l pl
107 eSpeak - pliki dla programistów.
108
109 %package static
110 Summary:        eSpeak - static libraries
111 Summary(pl):    eSpeak - biblioteki statyczne
112 Group:          Development/Libraries
113 Requires:       %{name}-devel = %{version}-%{release}
114
115 %description static
116 eSpeak - static libraries.
117
118 %description static -l pl
119 eSpeak - biblioteki statyczne.
120
121 %prep
122 %setup -q -n %{name}-%{version}-source
123 %patch0 -p1
124 # remove pernicious headers to avoid using them during build instead of /usr/include/portaudio.h system header
125 rm -f src/portaudio{18,19,}.h
126
127 %build
128 %{__libtoolize}
129 %{__aclocal}
130 %{__autoconf}
131 %{__autoheader}
132 %{__automake}
133 %configure \
134         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post libs -p /sbin/ldconfig
147 %postun libs -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc ChangeLog ReadMe docs
152 %attr(755,root,root) %{_bindir}/*
153 %dir %{_datadir}/%{name}-data
154 %dir %{_datadir}/%{name}-data/voices
155 %dir %{_datadir}/%{name}-data/voices/en
156 %{_datadir}/%{name}-data/voices/af
157 %{_datadir}/%{name}-data/voices/cy
158 %{_datadir}/%{name}-data/voices/de
159 %{_datadir}/%{name}-data/voices/default
160 %{_datadir}/%{name}-data/voices/el
161 %{_datadir}/%{name}-data/voices/en/en-rp-f
162 %{_datadir}/%{name}-data/voices/en/en-wm-f
163 %{_datadir}/%{name}-data/voices/en/en-n
164 %{_datadir}/%{name}-data/voices/en/en
165 %{_datadir}/%{name}-data/voices/en/en1
166 %{_datadir}/%{name}-data/voices/en/en2
167 %{_datadir}/%{name}-data/voices/en/en3
168 %{_datadir}/%{name}-data/voices/en/en4
169 %{_datadir}/%{name}-data/voices/en/en6
170 %{_datadir}/%{name}-data/voices/en/en7
171 %{_datadir}/%{name}-data/voices/en/en8
172 %{_datadir}/%{name}-data/voices/en/en-croak
173 %{_datadir}/%{name}-data/voices/en/en-f
174 %{_datadir}/%{name}-data/voices/en/en-rp
175 %{_datadir}/%{name}-data/voices/en/en-n-f
176 %{_datadir}/%{name}-data/voices/en/en-wm
177 %{_datadir}/%{name}-data/voices/eo
178 %{_datadir}/%{name}-data/voices/es
179 %{_datadir}/%{name}-data/voices/fi
180 %{_datadir}/%{name}-data/voices/it
181 %{_datadir}/%{name}-data/voices/pl
182 %{_datadir}/%{name}-data/voices/ru
183 %dir %{_datadir}/%{name}-data/soundicons
184 %{_datadir}/%{name}-data/af_dict
185 %{_datadir}/%{name}-data/config
186 %{_datadir}/%{name}-data/cy_dict
187 %{_datadir}/%{name}-data/de_dict
188 %{_datadir}/%{name}-data/en_dict
189 %{_datadir}/%{name}-data/eo_dict
190 %{_datadir}/%{name}-data/el_dict
191 %{_datadir}/%{name}-data/es_dict
192 %{_datadir}/%{name}-data/fi_dict
193 %{_datadir}/%{name}-data/it_dict
194 %{_datadir}/%{name}-data/phondata
195 %{_datadir}/%{name}-data/phonindex
196 %{_datadir}/%{name}-data/phontab
197 %{_datadir}/%{name}-data/pl_dict
198 %{_datadir}/%{name}-data/ru_dict
199
200 %files libs
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
203
204 %files devel
205 %defattr(644,root,root,755)
206 %{_includedir}/*
207 %attr(755,root,root) %{_libdir}/lib*.so
208 %{_libdir}/lib*.la
209
210 %if %{with static_libs}
211 %files static
212 %defattr(644,root,root,755)
213 %{_libdir}/lib*.a
214 %endif
This page took 0.094592 seconds and 2 git commands to generate.