]> git.pld-linux.org Git - packages/espeak.git/blob - espeak.spec
106c3d6c41cbd56e67b85aa64740f4f347f5691c
[packages/espeak.git] / espeak.spec
1 # NOTES:
2 #       - maybe espeak is better name for spec
3 #       - in the absence of data files in expected location (/usr/share/espeak-data or $HOME/espeak-data) program segfaults
4 #       
5 Summary:        eSpeak - speech synthesizer for English and other languages
6 Summary(pl):    eSpeak - syntezator mowy dla jêzyka angielskiego i innych
7 Name:           speak
8 Version:        1.13
9 Release:        0.1
10 License:        GPL v2
11 Group:          Applications
12 Source0:        http://dl.sourceforge.net/espeak/%{name}-%{version}-source.zip
13 # Source0-md5:  1cd76ad278fa134eced57b865b72175b
14 Patch0:         %{name}-ac_am.patch
15 URL:            http://espeak.sourceforge.net/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  portaudio-devel >= 19
20 BuildRequires:  unzip
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 eSpeak is a software speech synthesizer for English and other
25 languages. eSpeak produces good quality English speech. It uses a
26 different synthesis method from other open source TTS engines, and
27 sounds quite different. It's perhaps not as natural or "smooth", but I
28 find the articulation clearer and easier to listen to for long
29 periods.
30 - It can run as a command line program to speak text from a file or
31   from stdin. A library version is also available (isn't available in
32   this package).
33 - Includes different Voices, whose characteristics can be altered.
34 - Can produce speech output as a WAV file.
35 - SSML (Speech Synthesis Markup Language) is supported (not complete),
36   and also HTML.
37 - Compact size. The program and its data, including several languages,
38   totals about 420 kbytes.
39 - Can translate text to phoneme codes, so it could be adapted as a
40   front end for another speech synthesis engine.
41 - Potential for other languages. Several are included in varying
42   stages of progress. Help from native speakers for these or other
43   languages is welcomed.
44 - Development tools available for producing and tuning phoneme data.
45 - Written in C++.
46
47 It works well as a "Talker" with the KDE text to speech system (KTTS),
48 as an alternative to Festival for example. As such, it can speak text
49 which has been selected into the clipboard, or directly from the
50 Konquerer browser or the Kate editor.
51
52 %description -l pl
53 eSpeak to programowy syntezator mowy dla angielskiego i innych
54 jêzyków. Odtwarza angielsk± mowê dobrej jako¶ci. U¿ywa innej metody
55 syntezy ni¿ inne silniki TTS o otwartych ¼ród³ach i brzmi trochê
56 inaczej. Nie jest mo¿e tak naturalny czy "g³adki", ale autor uwa¿a tê
57 wymowê za czystsz± i ³atwiejsz± w s³uchaniu na d³u¿sz± metê.
58
59 - Mo¿e dzia³aæ jako program z linii poleceñ do wymawiania tekstu z
60   pliku lub standardowego wej¶cia; dostêpna jest tak¿e wersja w
61   postaci biblioteki (nie w tym pakiecie).
62 - Zawiera ró¿ne g³osy, a ich charakterystykê mo¿na zmieniaæ.
63 - Potrafi tworzyæ pliki WAV z mow±.
64 - Obs³ugiwany (ale nie w pe³ni) jest SSML (Speech Synthesis Markup
65   Language)  oraz HTML.
66 - Ma³y rozmiar - program i jego dane, wraz z kilkoma jêzykami,
67   mieszcz± siê w oko³o 420kB.
68 - Potrafi t³umaczyæ tekst na kody fonemów, wiêc mo¿e byæ zaadaptowany
69   jako frontend dla innych silników syntezy mowy.
70 - Potencjalnie mo¿e nadawaæ siê dla innych jêzyków; kilka jest
71   do³±czonych w ró¿nym stadium zaawansowania. Mile widziana jest pomoc
72   od osób, dla których s± to jêzyki ojczyste.
73 - Dostêpne s± narzêdzia programistyczne do tworzenia i dostrajania
74   danych dla fonemów.
75 - Napisany w C++.
76
77 %prep
78 %setup -q -n %{name}-%{version}-source
79 %patch -p1
80 # remove pernicious headers to avoid using them during build instead of /usr/include/portaudio.h system header
81 rm -f src/portaudio{18,19,}.h
82
83 %build
84 %{__aclocal}
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files
101 %defattr(644,root,root,755)
102 %doc ChangeLog ReadMe docs
103 %attr(755,root,root) %{_bindir}/*
104 %dir %{_datadir}/e%{name}-data
105 %dir %{_datadir}/e%{name}-data/voices
106 %dir %{_datadir}/e%{name}-data/voices/en
107 %{_datadir}/e%{name}-data/voices/en/en-rp-f
108 %{_datadir}/e%{name}-data/voices/en/en-wm-f
109 %{_datadir}/e%{name}-data/voices/en/en-n
110 %{_datadir}/e%{name}-data/voices/en/en
111 %{_datadir}/e%{name}-data/voices/en/en1
112 %{_datadir}/e%{name}-data/voices/en/en2
113 %{_datadir}/e%{name}-data/voices/en/en3
114 %{_datadir}/e%{name}-data/voices/en/en4
115 %{_datadir}/e%{name}-data/voices/en/en6
116 %{_datadir}/e%{name}-data/voices/en/en7
117 %{_datadir}/e%{name}-data/voices/en/en8
118 %{_datadir}/e%{name}-data/voices/en/en-croak
119 %{_datadir}/e%{name}-data/voices/en/en-f
120 %{_datadir}/e%{name}-data/voices/en/en-rp
121 %{_datadir}/e%{name}-data/voices/en/en-n-f
122 %{_datadir}/e%{name}-data/voices/en/en-wm
123 %{_datadir}/e%{name}-data/voices/es
124 %{_datadir}/e%{name}-data/voices/it
125 %{_datadir}/e%{name}-data/voices/pl
126 %{_datadir}/e%{name}-data/voices/af
127 %{_datadir}/e%{name}-data/voices/default
128 %{_datadir}/e%{name}-data/voices/eo
129 %{_datadir}/e%{name}-data/voices/de
130 %{_datadir}/e%{name}-data/voices/el
131 %dir %{_datadir}/e%{name}-data/soundicons
132 %{_datadir}/e%{name}-data/af_dict
133 %{_datadir}/e%{name}-data/de_dict
134 %{_datadir}/e%{name}-data/en_dict
135 %{_datadir}/e%{name}-data/eo_dict
136 %{_datadir}/e%{name}-data/es_dict
137 %{_datadir}/e%{name}-data/it_dict
138 %{_datadir}/e%{name}-data/phondata
139 %{_datadir}/e%{name}-data/phonindex
140 %{_datadir}/e%{name}-data/phontab
141 %{_datadir}/e%{name}-data/config
142 %{_datadir}/e%{name}-data/pl_dict
143 %{_datadir}/e%{name}-data/el_dict
This page took 0.080955 seconds and 3 git commands to generate.