]> git.pld-linux.org Git - packages/espeak.git/blob - espeak.spec
054e0f093d3fc11a47b334d022f27bcf97d170f7
[packages/espeak.git] / espeak.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4 #
5 Summary:        eSpeak - speech synthesizer for English and other languages
6 Summary(pl):    eSpeak - syntezator mowy dla jêzyka angielskiego i innych
7 Name:           speak
8 Version:        1.14
9 Release:        1
10 License:        GPL v2
11 Group:          Applications
12 Source0:        http://dl.sourceforge.net/espeak/%{name}-%{version}-source.zip
13 # Source0-md5:  9a52e2a00354474334adc36fe2fdd4c6
14 Patch0:         %{name}-ac_am.patch
15 URL:            http://espeak.sourceforge.net/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool
20 BuildRequires:  portaudio-devel >= 19
21 BuildRequires:  unzip
22 Requires:       %{name}-libs = %{version}-%{release}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 eSpeak is a software speech synthesizer for English and other
27 languages. eSpeak produces good quality English speech. It uses a
28 different synthesis method from other open source TTS engines, and
29 sounds quite different. It's perhaps not as natural or "smooth", but I
30 find the articulation clearer and easier to listen to for long
31 periods.
32 - It can run as a command line program to speak text from a file or
33   from stdin. A library version is also available (isn't available in
34   this package).
35 - Includes different Voices, whose characteristics can be altered.
36 - Can produce speech output as a WAV file.
37 - SSML (Speech Synthesis Markup Language) is supported (not complete),
38   and also HTML.
39 - Compact size. The program and its data, including several languages,
40   totals about 420 kbytes.
41 - Can translate text to phoneme codes, so it could be adapted as a
42   front end for another speech synthesis engine.
43 - Potential for other languages. Several are included (e.g. Polish
44   language) in varying stages of progress. Help from native speakers
45   for these or other languages is welcomed.
46 - Development tools available for producing and tuning phoneme data.
47 - Written in C++.
48
49 It works well as a "Talker" with the KDE text to speech system (KTTS),
50 as an alternative to Festival for example. As such, it can speak text
51 which has been selected into the clipboard, or directly from the
52 Konquerer browser or the Kate editor.
53
54 %description -l pl
55 eSpeak to programowy syntezator mowy dla angielskiego i innych
56 jêzyków. Odtwarza angielsk± mowê dobrej jako¶ci. U¿ywa innej metody
57 syntezy ni¿ inne silniki TTS o otwartych ¼ród³ach i brzmi trochê
58 inaczej. Nie jest mo¿e tak naturalny czy "g³adki", ale autor uwa¿a tê
59 wymowê za czystsz± i ³atwiejsz± w s³uchaniu na d³u¿sz± metê.
60
61 - Mo¿e dzia³aæ jako program z linii poleceñ do wymawiania tekstu z
62   pliku lub standardowego wej¶cia; dostêpna jest tak¿e wersja w
63   postaci biblioteki (nie w tym pakiecie).
64 - Zawiera ró¿ne g³osy, a ich charakterystykê mo¿na zmieniaæ.
65 - Potrafi tworzyæ pliki WAV z mow±.
66 - Obs³ugiwany (ale nie w pe³ni) jest SSML (Speech Synthesis Markup
67   Language)  oraz HTML.
68 - Ma³y rozmiar - program i jego dane, wraz z kilkoma jêzykami,
69   mieszcz± siê w oko³o 420kB.
70 - Potrafi t³umaczyæ tekst na kody fonemów, wiêc mo¿e byæ zaadaptowany
71   jako frontend dla innych silników syntezy mowy.
72 - Potencjalnie mo¿e nadawaæ siê dla innych jêzyków; kilka jest
73   do³±czonych (na przyk³ad j.polski) w ró¿nym stadium zaawansowania.
74   Mile widziana jest pomoc od osób, dla których s± to jêzyki ojczyste.
75 - Dostêpne s± narzêdzia programistyczne do tworzenia i dostrajania
76   danych dla fonemów.
77 - Napisany w C++.
78
79 Dobrze pracuje jako "mówca" z systemem przetwarzania tekstu na mowê
80 KDE (KTTS), na przyk³ad, jako alternatywa dla Festivala. Jako taki,
81 mo¿e czytaæ na g³os tekst zaznaczony uprzednio do schowka lub
82 bezpo¶rednio z przegl±darki Konqueror i edytora Kate.
83
84 %package libs
85 Summary: eSpeak shared libraries
86 Summary(pl): eSpeak - biblioteki
87 Group:  Libraries
88
89 %description libs
90 eSpeak shared libraries.
91
92 %description libs -l pl
93 eSpeak - biblioteki dzielone.
94
95 %package devel
96 Summary:        eSpeak - development files
97 Summary(pl):    eSpeak - pliki dla programistów
98 Group:  Development/Libraries
99 Requires:       %{name}-libs = %{version}-%{release}
100
101 %description devel
102 eSpeak - development files.
103
104 %description devel -l pl
105 eSpeak - pliki dla programistów.
106
107 %package static
108 Summary:        eSpeak - static libraries
109 Summary(pl):    eSpeak - biblioteki statyczne
110 Group:  Development/Libraries
111 Requires:       %{name}-devel = %{version}-%{release}
112
113 %description static
114 eSpeak - static libraries.
115
116 %description static -l pl
117 eSpeak - biblioteki statyczne.
118
119 %prep
120 %setup -q -n %{name}-%{version}-source
121 %patch -p1
122 # remove pernicious headers to avoid using them during build instead of /usr/include/portaudio.h system header
123 rm -f src/portaudio{18,19,}.h
124
125 %build
126 %{__libtoolize}
127 %{__aclocal}
128 %{__autoconf}
129 %{__autoheader}
130 %{__automake}
131 %configure \
132         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post libs -p /sbin/ldconfig
145 %postun libs -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc ChangeLog ReadMe docs
150 %attr(755,root,root) %{_bindir}/*
151 %dir %{_datadir}/e%{name}-data
152 %dir %{_datadir}/e%{name}-data/voices
153 %dir %{_datadir}/e%{name}-data/voices/en
154 %{_datadir}/e%{name}-data/voices/af
155 %{_datadir}/e%{name}-data/voices/cy
156 %{_datadir}/e%{name}-data/voices/de
157 %{_datadir}/e%{name}-data/voices/default
158 %{_datadir}/e%{name}-data/voices/el
159 %{_datadir}/e%{name}-data/voices/en/en-rp-f
160 %{_datadir}/e%{name}-data/voices/en/en-wm-f
161 %{_datadir}/e%{name}-data/voices/en/en-n
162 %{_datadir}/e%{name}-data/voices/en/en
163 %{_datadir}/e%{name}-data/voices/en/en1
164 %{_datadir}/e%{name}-data/voices/en/en2
165 %{_datadir}/e%{name}-data/voices/en/en3
166 %{_datadir}/e%{name}-data/voices/en/en4
167 %{_datadir}/e%{name}-data/voices/en/en6
168 %{_datadir}/e%{name}-data/voices/en/en7
169 %{_datadir}/e%{name}-data/voices/en/en8
170 %{_datadir}/e%{name}-data/voices/en/en-croak
171 %{_datadir}/e%{name}-data/voices/en/en-f
172 %{_datadir}/e%{name}-data/voices/en/en-rp
173 %{_datadir}/e%{name}-data/voices/en/en-n-f
174 %{_datadir}/e%{name}-data/voices/en/en-wm
175 %{_datadir}/e%{name}-data/voices/eo
176 %{_datadir}/e%{name}-data/voices/es
177 %{_datadir}/e%{name}-data/voices/it
178 %{_datadir}/e%{name}-data/voices/pl
179 %{_datadir}/e%{name}-data/voices/ru
180 %dir %{_datadir}/e%{name}-data/soundicons
181 %{_datadir}/e%{name}-data/af_dict
182 %{_datadir}/e%{name}-data/config
183 %{_datadir}/e%{name}-data/cy_dict
184 %{_datadir}/e%{name}-data/de_dict
185 %{_datadir}/e%{name}-data/en_dict
186 %{_datadir}/e%{name}-data/eo_dict
187 %{_datadir}/e%{name}-data/el_dict
188 %{_datadir}/e%{name}-data/es_dict
189 %{_datadir}/e%{name}-data/it_dict
190 %{_datadir}/e%{name}-data/phondata
191 %{_datadir}/e%{name}-data/phonindex
192 %{_datadir}/e%{name}-data/phontab
193 %{_datadir}/e%{name}-data/pl_dict
194 %{_datadir}/e%{name}-data/ru_dict
195
196 %files libs
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
199
200 %files devel
201 %defattr(644,root,root,755)
202 %{_includedir}/*
203 %attr(755,root,root) %{_libdir}/lib*.so
204 %{_libdir}/lib*.la
205
206 %if %{with static_libs}
207 %files static
208 %defattr(644,root,root,755)
209 %{_libdir}/lib*.a
210 %endif
This page took 0.065567 seconds and 2 git commands to generate.