]> git.pld-linux.org Git - packages/erlang.git/commitdiff
- up to R13B04 auto/th/erlang-R13B04-1 auto/ti/erlang-R13B04-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 1 Mar 2010 08:09:40 +0000 (08:09 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    erlang-optional_java.patch -> 1.2
    erlang.spec -> 1.56

erlang-optional_java.patch [deleted file]
erlang.spec

diff --git a/erlang-optional_java.patch b/erlang-optional_java.patch
deleted file mode 100644 (file)
index c8d01db..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -dur otp_src_R9C-2.orig/erts/configure.in otp_src_R9C-2/erts/configure.in
---- otp_src_R9C-2.orig/erts/configure.in       2004-05-24 08:05:38.000000000 +0200
-+++ otp_src_R9C-2/erts/configure.in    2004-10-10 23:11:12.516218543 +0200
-@@ -1262,7 +1262,13 @@
-   /bin/rm -f $ERL_TOP/lib/$a/SKIP
- done
--AC_CHECK_PROGS(JAVAC, javac.sh javac guavac gcj jikes bock)
-+JAVAC=""
-+AC_ARG_WITH([java],AS_HELP_STRING([--with-java],[use Java (default is auto)]),
-+  [],[with_java=auto])
-+
-+if test "x$with_java" != "xno" ; then
-+ AC_CHECK_PROGS(JAVAC, javac.sh javac guavac gcj jikes bock)
-+fi
- if test -n "$JAVAC"; then
-   dnl Make sure it's at least JDK 1.2
-   AC_CACHE_CHECK(for JDK version 1.2, 
-@@ -1274,7 +1280,13 @@
-   fi
- fi
- if test -z "$JAVAC"; then
--  AC_MSG_WARN([Could not find any usable java compiler, will skip: jinterface])
-+  if test "x$with_java" = "xyes" ; then
-+    AC_MSG_ERROR([could not find any usable java compiler])
-+  elif test "x$with_java" != "xno" ; then
-+    AC_MSG_WARN([Could not find any usable java compiler, will skip: jinterface])
-+  else
-+    AC_MSG_WARN([Java support disabled, will skip: jinterface])
-+  fi
-   for a in $need_java ; do
-       echo "No Java compiler found" > $ERL_TOP/lib/$a/SKIP
-Only in otp_src_R9C-2/erts: configure.in~
index 63cf742157808d45683752d5472c818844a32592..1aee4c55b70dd28a852e47155da4e1c9d609a6b0 100644 (file)
 Summary:       OpenSource Erlang/OTP
 Summary(pl.UTF-8):     Erlang/OTP z otwartymi źródłami
 Name:          erlang
-# keep stable line, currently R12
-Version:       R12B_5
+# keep stable line, currently R13
+Version:       R13B04
 Release:       1
 Epoch:         1
 %define                _version        %(echo %{version} | tr _ -)
 License:       distributable
 Group:         Development/Languages
 Source0:       http://www.erlang.org/download/otp_src_%{_version}.tar.gz
-# Source0-md5: 3751ea3fea669d2b25c67eeb883734bb
+# Source0-md5: ca6da4921e438891967900aa6a084341
 Source1:       http://www.erlang.org/download/otp_doc_man_%{_version}.tar.gz
-# Source1-md5: 6231cb172847040395cc34b20781aa3b
+# Source1-md5: 681aaef70affc64743f4e8c0675034af
 Patch0:                %{name}-fPIC.patch
-Patch1:                %{name}-optional_java.patch
-Patch2:                %{name}-tinfo.patch
+Patch1:                %{name}-tinfo.patch
 URL:           http://www.erlang.org/
 %{?with_java:BuildRequires:    /usr/bin/jar}
 BuildRequires: xorg-lib-libX11-devel
@@ -46,7 +45,7 @@ BuildConflicts:       unixODBC-devel
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define _erl_target %(echo %{_build} | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
+%define _erl_target %(echo %{_build}-gnu | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
 
 %description
 Erlang is a programming language designed at the Ericsson Computer
@@ -63,7 +62,6 @@ rozpowszechnianiu Erlanga poza Ericssonem.
 %{__tar} xzf %{SOURCE1} man/ COPYRIGHT
 #%patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
 find . -name config.sub | xargs -n 1 cp -f /usr/share/automake/config.sub
@@ -87,7 +85,7 @@ cd ..
 %ifarch sparc
        CFLAGS="%{rpmcflags} -mv8plus" \
 %endif
-       --with%{!?with_java:out}-java
+       --with%{!?with_java:out}-javac
 rm -f lib/ssl/SKIP
 ERL_TOP=`pwd`; export ERL_TOP
  %{__make} -j1 \
@@ -135,7 +133,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f lib.list
 %defattr(644,root,root,755)
-%doc AUTHORS EPLICENCE README COPYRIGHT
+%doc AUTHORS EPLICENCE COPYRIGHT
 %attr(755,root,root) %{_bindir}/*
 %dir %{_libdir}/erlang
 %dir %{_libdir}/%{name}/bin
@@ -160,6 +158,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/child*
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dialyzer
+%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dyn_erl
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/e*
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/heart*
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/inet_gethost
This page took 0.226213 seconds and 4 git commands to generate.