]> git.pld-linux.org Git - packages/erlang.git/commitdiff
Up to 25.1.2. master auto/th/erlang-25.1.2-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 31 Oct 2022 22:19:47 +0000 (23:19 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 31 Oct 2022 22:19:47 +0000 (23:19 +0100)
erlang-ac.patch [new file with mode: 0644]
erlang-no-fop.patch
erlang.spec
ssl.patch [new file with mode: 0644]
x32.patch

diff --git a/erlang-ac.patch b/erlang-ac.patch
new file mode 100644 (file)
index 0000000..9744f44
--- /dev/null
@@ -0,0 +1,25 @@
+--- otp-OTP-24.1.2/otp_build.orig      2021-10-04 17:12:13.000000000 +0200
++++ otp-OTP-24.1.2/otp_build   2021-10-25 21:32:32.099541733 +0200
+@@ -197,21 +197,6 @@ do_update_configure ()
+ {
+     get_do_commit $1
+-    export AUTOCONF_VERSION="$USE_AUTOCONF_VERSION"
+-    ac_ver_blob=`autoconf --version`
+-    if [ $? -ne 0 ]; then
+-      echo "ERROR: Failed to check autoconf version! You need to have autoconf of version $USE_AUTOCONF_VERSION in path." 1>&2
+-      exit 1
+-    fi
+-    ac_ver=`echo $ac_ver_blob | sed "s|[^0-9]*\([0-9][^ \t\n]*\).*|\1|"`
+-    case $ac_ver in
+-      $USE_AUTOCONF_VERSION)
+-          ;;
+-      *)
+-          echo "ERROR: autoconf of version $ac_ver found in path! You need to have autoconf of version $USE_AUTOCONF_VERSION in path." 1>&2
+-          exit 1;;
+-    esac
+-    
+     out_files=
+     install_sh=`basename $install_sh_master`
+
index 960d69a1903f15bfd3e1b656e3b1ad263a6560cf..c6f0adbc8c013eabc6db7fb6ea3b0e87884dc1d7 100644 (file)
@@ -1,6 +1,6 @@
---- otp-OTP-21.3.8.6/erts/configure.in.orig    2019-07-11 17:18:55.000000000 +0200
-+++ otp-OTP-21.3.8.6/erts/configure.in 2019-09-09 17:44:05.368217526 +0200
-@@ -855,7 +855,8 @@
+--- otp-OTP-21.3.8.6/erts/configure.ac.orig    2019-07-11 17:18:55.000000000 +0200
++++ otp-OTP-21.3.8.6/erts/configure.ac 2019-09-09 17:44:05.368217526 +0200
+@@ -459,7 +459,8 @@ if test -z "$XSLTPROC"; then
    AC_MSG_WARN([No 'xsltproc' command found: the documentation cannot be built])
  fi
  
@@ -10,3 +10,4 @@
  if test -z "$FOP"; then
    FOP="$ERL_TOP/make/fakefop"
    echo "fop" >> doc/CONF_INFO
+
index a495f090eff50d152f30e3808d128617d0b5e272..6a14f8e5603c2fcd9d64ff073f291b38e4fef87f 100644 (file)
 %bcond_with    java            # with Java support
 %bcond_without odbc            # without unixODBC support
 #
+
+%define                erts_version    13.1.2
+
 Summary:       OpenSource Erlang/OTP
 Summary(pl.UTF-8):     Erlang/OTP z otwartymi źródłami
 Name:          erlang
-Version:       22.2.4
+Version:       25.1.2
 Release:       1
 Epoch:         2
 %define                _version        %(echo %{version} | tr _ -)
 License:       APLv2
 Group:         Development/Languages
 Source0:       https://github.com/erlang/otp/archive/OTP-%{version}.tar.gz
-# Source0-md5: ab584b0235f1f41284b026d9a8f35426
+# Source0-md5: ac654a239f8e9c3514b183c657bca4bf
 Source2:       epmd.service
 Source3:       epmd.socket
 Source4:       epmd@.service
@@ -30,9 +33,11 @@ Patch0:              %{name}-fPIC.patch
 Patch1:                x32.patch
 # disable pdf docs (require libxslt-progs and fop > 1.0, with -cache option)
 Patch2:                %{name}-no-fop.patch
+
+Patch4:                %{name}-ac.patch
 URL:           http://www.erlang.org/
 %{?with_java:BuildRequires:    /usr/bin/jar}
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.69
 BuildRequires: automake
 BuildRequires: flex
 %{?with_java:BuildRequires:    jdk >= 1.2}
@@ -40,6 +45,8 @@ BuildRequires:        ncurses-devel
 BuildRequires: openssl-devel >= 0.9.7
 BuildRequires: openssl-tools
 BuildRequires: perl-base
+BuildRequires: rpm-build >= 4.6
+BuildRequires: rpmbuild(macros) >= 1.752
 BuildRequires: xorg-lib-libX11-devel
 %if %{with odbc}
 BuildRequires: unixODBC-devel
@@ -62,14 +69,29 @@ Erlang to język programowania opracowany w Ericsson Computer Science
 Laboratory. Open-source Erlang został wydany, aby pomóc w
 rozpowszechnianiu Erlanga poza Ericssonem.
 
+%package doc
+Summary:       Erlang documentation
+Summary(pl.UTF-8):     Dokumentacja do Erlanga
+Group:         Documentation
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+BuildArch:     noarch
+
+%description doc
+Erlang documentation.
+
+%description doc -l pl.UTF-8
+Dokumentacja do Erlanga.
+
 %prep
 %setup -q -n otp-OTP-%{_version}
 #%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 
+%patch4 -p1
+
 %build
-./otp_build autoconf
+./otp_build update_configure --no-commit
 
 %configure \
 %ifarch sparc
@@ -80,7 +102,9 @@ rozpowszechnianiu Erlanga poza Ericssonem.
 %endif
        --disable-silent-rules \
        --enable-smp-support \
-       --with-javac%{!?with_java:=no}
+       --with-javac%{!?with_java:=no} \
+       --with-ssl-lib-subdir=%{_lib}
+
 rm -f lib/ssl/SKIP
 ERL_TOP=`pwd`; export ERL_TOP
  %{__make} -j1 \
@@ -110,6 +134,7 @@ install -D -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/epmd@.socket
 
 %{__sed} -i -e '1s,/usr/bin/env escript,/usr/bin/escript,' \
        $RPM_BUILD_ROOT%{_libdir}/%{name}/lib/diameter-*/bin/diameterc \
+       $RPM_BUILD_ROOT%{_libdir}/%{name}/lib/edoc-*/bin/edoc \
        $RPM_BUILD_ROOT%{_libdir}/%{name}/lib/erl_docgen-*/priv/bin/{codeline_preprocessing,xml_from_edoc}.escript \
        $RPM_BUILD_ROOT%{_libdir}/%{name}/lib/reltool-*/examples/{display_args,mnesia_core_dump_viewer} \
        $RPM_BUILD_ROOT%{_libdir}/%{name}/lib/snmp-*/bin/snmpc \
@@ -127,8 +152,12 @@ find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f -perm -500 \
 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f '!' -perm -500 \
        | %{__sed} -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%{_libdir}/%%{name}/#" >> lib.list
 
-%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/lib
-%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/include/internal
+# Move noarch docs to _datadir
+install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/erts-%{erts_version}
+%{__mv} $RPM_BUILD_ROOT{%{_libdir},%{_datadir}}/%{name}/doc
+%{__ln} -s %{_datadir}/%{name}/doc $RPM_BUILD_ROOT%{_libdir}/%{name}/doc
+%{__mv} $RPM_BUILD_ROOT{%{_libdir},%{_datadir}}/%{name}/erts-%{erts_version}/doc
+%{__ln} -s %{_datadir}/%{name}/erts-%{erts_version}/doc $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-%{erts_version}/doc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -162,6 +191,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/bin/dialyzer
 %attr(755,root,root) %{_libdir}/%{name}/bin/epmd
 %attr(755,root,root) %{_libdir}/%{name}/bin/erl
+%attr(755,root,root) %{_libdir}/%{name}/bin/erl_call
 %attr(755,root,root) %{_libdir}/%{name}/bin/erlc
 %attr(755,root,root) %{_libdir}/%{name}/bin/escript
 %attr(755,root,root) %{_libdir}/%{name}/bin/no_dot_erlang.boot
@@ -171,25 +201,30 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
 %attr(755,root,root) %{_libdir}/%{name}/bin/typer
 %{_libdir}/%{name}/bin/start*.*
-%dir %{_libdir}/%{name}/erts-*
-%{_libdir}/%{name}/erts-*/doc
-%{_libdir}/%{name}/erts-*/man
-%{_libdir}/%{name}/erts-*/src
-%{_libdir}/%{name}/erts-*/include
-#%{_libdir}/%{name}/erts-*/*.ear
-%dir %{_libdir}/%{name}/erts-*/bin
-%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
-%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/ct_run
-%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dialyzer
-%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dyn_erl
-%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/e*
-%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/heart*
-%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/inet_gethost
-%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/run_erl
-%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/start
-%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/to_erl
-%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/typer
-%{_libdir}/%{name}/erts-*/bin/start*.*
+%dir %{_libdir}/%{name}/erts-%{erts_version}
+%{_libdir}/%{name}/erts-%{erts_version}/info
+%{_libdir}/%{name}/erts-%{erts_version}/man
+%{_libdir}/%{name}/erts-%{erts_version}/src
+%{_libdir}/%{name}/erts-%{erts_version}/include
+%dir %{_libdir}/%{name}/erts-%{erts_version}/lib
+%dir %{_libdir}/%{name}/erts-%{erts_version}/lib/internal
+%{_libdir}/%{name}/erts-%{erts_version}/lib/internal/liberts_internal*.a
+%{_libdir}/%{name}/erts-%{erts_version}/lib/internal/libethread.a
+#%{_libdir}/%{name}/erts-%{erts_version}/*.ear
+%dir %{_libdir}/%{name}/erts-%{erts_version}/bin
+%attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/beam*
+%attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/ct_run
+%attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/dialyzer
+%attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/dyn_erl
+%attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/e*
+%attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/heart*
+%attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/inet_gethost
+%attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/run_erl
+%attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/start
+%attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/to_erl
+%attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/typer
+%attr(755,root,root) %{_libdir}/%{name}/erts-%{erts_version}/bin/yielding_c_fun
+%{_libdir}/%{name}/erts-%{erts_version}/bin/start*.*
 # (file list dynamically generated) %{_libdir}/%{name}/lib
 %dir %{_libdir}/%{name}/misc
 %attr(755,root,root) %{_libdir}/%{name}/misc/*
@@ -198,7 +233,17 @@ rm -rf $RPM_BUILD_ROOT
 %doc %{_libdir}/%{name}/man
 %attr(755,root,root) %{_libdir}/%{name}/Install
 
+%{_libdir}/%{name}/doc
+%{_libdir}/%{name}/erts-%{erts_version}/doc
+
 %{systemdunitdir}/epmd.service
 %{systemdunitdir}/epmd.socket
 %{systemdunitdir}/epmd@.service
 %{systemdunitdir}/epmd@.socket
+
+%files doc
+%defattr(644,root,root,755)
+%dir %{_datadir}/%{name}
+%dir %{_datadir}/%{name}/erts-%{erts_version}
+%{_datadir}/%{name}/doc
+%{_datadir}/%{name}/erts-%{erts_version}/doc
diff --git a/ssl.patch b/ssl.patch
new file mode 100644 (file)
index 0000000..e0b0efe
--- /dev/null
+++ b/ssl.patch
@@ -0,0 +1,35 @@
+--- otp-OTP-24.1.2/lib/crypto/c_src/openssl_config.h~  2021-10-23 23:10:12.000000000 +0200
++++ otp-OTP-24.1.2/lib/crypto/c_src/openssl_config.h   2021-10-23 23:12:25.743124654 +0200
+@@ -53,8 +53,18 @@
+ /* Helper macro to construct a OPENSSL_VERSION_NUMBER.
+  * See openssl/opensslv.h
+  */
+-#define PACKED_OPENSSL_VERSION(MAJ, MIN, FIX, P)      \
+-    ((((((((MAJ << 8) | MIN) << 8 ) | FIX) << 8) | (P-'a'+1)) << 4) | 0xf)
++#if defined(OPENSSL_VERSION_MAJOR) && \
++    (OPENSSL_VERSION_MAJOR >= 3)
++
++# define PACKED_OPENSSL_VERSION(MAJ, MIN, PATCH, VOID)   \
++         (((((MAJ << 8) | MIN) << 16 ) | PATCH) << 4)
++#else
++/* Pre 3.0.0 */
++#  define PACKED_OPENSSL_VERSION(MAJ, MIN, FIX, P)                        \
++          ((((((((MAJ << 8) | MIN) << 8 ) | FIX) << 8) | (P-'a'+1)) << 4) | 0xf)
++
++/* End Pre 3.0.0 */
++#endif
+ #define PACKED_OPENSSL_VERSION_PLAIN(MAJ, MIN, FIX) \
+     PACKED_OPENSSL_VERSION(MAJ,MIN,FIX,('a'-1))
+@@ -437,6 +437,11 @@ do {
+ # undef FIPS_SUPPORT
+ #endif
++/* Disable FIPS until erlang properly supports it with new openssl */
++#if OPENSSL_VERSION_NUMBER >= PACKED_OPENSSL_VERSION_PLAIN(3,0,0)
++# undef FIPS_SUPPORT
++# define FIPS_mode() 0
++#endif
+ #ifdef FIPS_SUPPORT
+ /* In FIPS mode non-FIPS algorithms are disabled and return badarg. */
index 602a4e031f387881e4fad6a0fdecaa47f4cd84ff..38a5dd4902fc5025520629f5d70a1b7ec2753b4f 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -15,12 +15,12 @@ Last-Modified: Sun, 27 Dec 2015 12:39:07 +0300
      int have_cpuid;
      /*
       * If it is possible to toggle eflags bit 21,
-@@ -219,7 +219,7 @@
+@@ -217,7 +217,7 @@ ethr_x86_cpuid__(int *eax, int *ebx, int
        return;
      }
  #endif
 -#if ETHR_SIZEOF_PTR == 4 && defined(__PIC__) && __PIC__
 +#if ETHR_SIZEOF_PTR == 4 && (!defined(__x86_64__) || !(__x86_64__ && __ILP32__)) && defined(__PIC__) && __PIC__
      /*
-      * When position independet code is used in 32-bit mode, the B register
+      * When position independent code is used in 32-bit mode, the B register
       * is used for storage of global offset table address, and we may not
This page took 0.105127 seconds and 4 git commands to generate.