]> git.pld-linux.org Git - packages/erlang.git/commitdiff
- rel 2; fix build on x32 (hive disabled because doesn't work on x32 according to... auto/th/erlang-21.1-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 5 Dec 2018 11:06:20 +0000 (12:06 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 5 Dec 2018 11:06:20 +0000 (12:06 +0100)
erlang.spec
x32.patch [new file with mode: 0644]

index 161f2fd313f9cde431030b51172b1ab560508c4f..f1eae761aacfa96ab8ed25f370f0f7edbb828255 100644 (file)
@@ -15,7 +15,7 @@ Summary:      OpenSource Erlang/OTP
 Summary(pl.UTF-8):     Erlang/OTP z otwartymi źródłami
 Name:          erlang
 Version:       21.1
-Release:       1
+Release:       2
 Epoch:         2
 %define                _version        %(echo %{version} | tr _ -)
 License:       APLv2
@@ -29,6 +29,7 @@ Source3:      epmd.socket
 Source4:       epmd@.service
 Source5:       epmd@.socket
 Patch0:                %{name}-fPIC.patch
+Patch1:                x32.patch
 URL:           http://www.erlang.org/
 %{?with_java:BuildRequires:    /usr/bin/jar}
 BuildRequires: autoconf
@@ -49,7 +50,7 @@ Requires:     systemd-units >= 38
 Requires(post,preun,postun):   systemd-units >= 38
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define _erl_target %(echo %{_build}-gnu | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
+%define _erl_target %(echo %{_build}%{?_gnu} | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/;s/x32/x86_64/')
 
 %description
 Erlang is a programming language designed at the Ericsson Computer
@@ -65,6 +66,7 @@ rozpowszechnianiu Erlanga poza Ericssonem.
 %setup -q -n otp_src_%{_version}
 %{__tar} xzf %{SOURCE1} man/ COPYRIGHT
 #%patch0 -p1
+%patch1 -p1
 
 %build
 find . -name config.sub | xargs -n 1 cp -f /usr/share/automake/config.sub
@@ -77,6 +79,9 @@ done
 %configure \
 %ifarch sparc
        CFLAGS="%{rpmcflags} -mv8plus" \
+%endif
+%ifarch x32
+       --disable-hipe \
 %endif
        --disable-silent-rules \
        --enable-smp-support \
diff --git a/x32.patch b/x32.patch
new file mode 100644 (file)
index 0000000..602a4e0
--- /dev/null
+++ b/x32.patch
@@ -0,0 +1,26 @@
+Author: Sergei Golovan
+Description: This patch fixes FTBFS for x86_x32 architecture (x86_64
+ with 32-bit integers, longs and pointers). HiPE still doesn't work
+ and probably never will.
+Last-Modified: Sun, 27 Dec 2015 12:39:07 +0300
+
+--- a/erts/lib_src/pthread/ethread.c
++++ b/erts/lib_src/pthread/ethread.c
+@@ -192,7 +192,7 @@
+ void
+ ethr_x86_cpuid__(int *eax, int *ebx, int *ecx, int *edx)
+ {
+-#if ETHR_SIZEOF_PTR == 4
++#if ETHR_SIZEOF_PTR == 4 && (!defined(__x86_64__) || !(__x86_64__ && __ILP32__))
+     int have_cpuid;
+     /*
+      * If it is possible to toggle eflags bit 21,
+@@ -219,7 +219,7 @@
+       return;
+     }
+ #endif
+-#if ETHR_SIZEOF_PTR == 4 && defined(__PIC__) && __PIC__
++#if ETHR_SIZEOF_PTR == 4 && (!defined(__x86_64__) || !(__x86_64__ && __ILP32__)) && defined(__PIC__) && __PIC__
+     /*
+      * When position independet code is used in 32-bit mode, the B register
+      * is used for storage of global offset table address, and we may not
This page took 0.062403 seconds and 4 git commands to generate.