]> git.pld-linux.org Git - packages/erlang.git/blobdiff - erlang.spec
- up to R11B_5
[packages/erlang.git] / erlang.spec
index 97ffb425fedc24685eaa35e29243b36a81a0c9a3..f0735839ae62ecc9b2902088c2fdbf46caf2bdf6 100644 (file)
@@ -5,24 +5,25 @@
 # - separate -devel (at least header files!)
 # - modularize (odbc, etc)
 # - manuals to %{_mandir}
+# - investigate fPIC.patch
 #
 # Conditional build:
 %bcond_with    java            # with Java support
 %bcond_without odbc            # without unixODBC support
 #
 Summary:       OpenSource Erlang/OTP
-Summary(pl):   Erlang/OTP z otwartymi ¼ród³ami
+Summary(pl.UTF-8):     Erlang/OTP z otwartymi źródłami
 Name:          erlang
-Version:       R11B_0
-Release:       3
+Version:       R11B_5
+Release:       1
 Epoch:         1
 %define                _version        %(echo %{version} | tr _ -)
 License:       distributable
 Group:         Development/Languages
 Source0:       http://www.erlang.org/download/otp_src_%{_version}.tar.gz
-# Source0-md5: 367d9d3ba979cd278b78d6d0393982ba
-Source1:       http://www.erlang.org/download/otp_doc_man_R11B-0.tar.gz
-# Source1-md5: 172591538db42e81b814a77f30da4fa4
+# Source0-md5: 96acec41da87d6ee0ef18e1aab36ffdd
+Source1:       http://www.erlang.org/download/otp_doc_man_R11B-3.tar.gz
+# Source1-md5: 645ef1ded84b470e9c05a4757dce88cf
 Patch0:                %{name}-fPIC.patch
 Patch1:                %{name}-optional_java.patch
 Patch2:                %{name}-hipe_optimistic_regalloc_once_only.patch
@@ -52,9 +53,9 @@ Erlang is a programming language designed at the Ericsson Computer
 Science Laboratory. Open-source Erlang is being released to help
 encourage the spread of Erlang outside Ericsson.
 
-%description -l pl
-Erlang to jêzyk programowania opracowany w Ericsson Computer Science
-Laboratory. Open-source Erlang zosta³ wydany, aby pomóc w
+%description -l pl.UTF-8
+Erlang to język programowania opracowany w Ericsson Computer Science
+Laboratory. Open-source Erlang został wydany, aby pomóc w
 rozpowszechnianiu Erlanga poza Ericssonem.
 
 %prep
@@ -86,7 +87,7 @@ cd ..
 %configure \
        --with%{!?with_java:out}-java
 ERL_TOP=`pwd`; export ERL_TOP
- %{__make} \
+ %{__make} -j1 \
        TARGET="%{_erl_target}" \
        || { find . -name erl_crash.dump | xargs cat ; exit 1 ; }
 
@@ -102,11 +103,11 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/*.html
 sed -i -e"s#$RPM_BUILD_ROOT##" \
        $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/{erl,start,start_erl}
 
-for l in erl erlc dialyzer epmd run_erl to_erl ; do
+for l in erl erlc escript dialyzer epmd run_erl to_erl typer; do
        ln -sf %{_libdir}/%{name}/bin/$l $RPM_BUILD_ROOT%{_bindir}
 done
 ERTSDIR=`echo $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-* | sed -e"s#^$RPM_BUILD_ROOT##"`
-for l in ear ecc elink escript ; do
+for l in epmd ; do
        ln -sf $ERTSDIR/bin/$l $RPM_BUILD_ROOT%{_bindir}
 done
 ln -sf $ERTSDIR/bin/epmd $RPM_BUILD_ROOT%{_libdir}/%{name}/bin
@@ -139,10 +140,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/bin/epmd
 %attr(755,root,root) %{_libdir}/%{name}/bin/erl
 %attr(755,root,root) %{_libdir}/%{name}/bin/erlc
+%attr(755,root,root) %{_libdir}/%{name}/bin/escript
 %attr(755,root,root) %{_libdir}/%{name}/bin/run_erl
 %attr(755,root,root) %{_libdir}/%{name}/bin/start
 %attr(755,root,root) %{_libdir}/%{name}/bin/start_erl
 %attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
+%attr(755,root,root) %{_libdir}/%{name}/bin/typer
 %{_libdir}/%{name}/bin/start*.*
 %dir %{_libdir}/%{name}/erts-*
 %{_libdir}/%{name}/erts-*/doc
@@ -160,6 +163,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/run_erl
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/start
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/to_erl
+%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/typer
 %{_libdir}/%{name}/erts-*/bin/start*.*
 # (file list dynamically generated) %{_libdir}/%{name}/lib
 %dir %{_libdir}/%{name}/misc
This page took 0.099956 seconds and 4 git commands to generate.