]> git.pld-linux.org Git - packages/erlang.git/blobdiff - erlang.spec
- updated to R15B02
[packages/erlang.git] / erlang.spec
index 3e0ab5dbf5895500126dd22355065be1584c684f..a6bd9e13fb68da15459c09ca7904aa9159501ef5 100644 (file)
@@ -4,27 +4,29 @@
 # TODO
 # - separate -devel (at least header files!)
 # - modularize (odbc, etc)
+# - manuals to %{_mandir}
+# - investigate fPIC.patch
 #
 # Conditional build:
 %bcond_with    java            # with Java support
 %bcond_without odbc            # without unixODBC support
 #
 Summary:       OpenSource Erlang/OTP
-Summary(pl):   Erlang/OTP z otwartymi ¼ród³ami
+Summary(pl.UTF-8):     Erlang/OTP z otwartymi źródłami
 Name:          erlang
-Version:       R11B_0
+# A - unstable, B - stable line, keep stable
+Version:       R15B02
 Release:       1
 Epoch:         1
 %define                _version        %(echo %{version} | tr _ -)
 License:       distributable
 Group:         Development/Languages
 Source0:       http://www.erlang.org/download/otp_src_%{_version}.tar.gz
-# Source0-md5: 367d9d3ba979cd278b78d6d0393982ba
-Source1:       http://www.erlang.org/download/otp_doc_man_R11B-0.tar.gz
-# Source1-md5: 172591538db42e81b814a77f30da4fa4
+# Source0-md5: ccbe5e032a2afe2390de8913bfe737a1
+Source1:       http://www.erlang.org/download/otp_doc_man_%{_version}.tar.gz
+# Source1-md5: 974020ba533242fca759a7f5eaf628e5
 Patch0:                %{name}-fPIC.patch
-Patch1:                %{name}-optional_java.patch
-Patch2:                %{name}-hipe_optimistic_regalloc_once_only.patch
+Patch1:                %{name}-tinfo.patch
 URL:           http://www.erlang.org/
 %{?with_java:BuildRequires:    /usr/bin/jar}
 BuildRequires: xorg-lib-libX11-devel
@@ -34,7 +36,7 @@ BuildRequires:        flex
 %{?with_java:BuildRequires:    jdk >= 1.2}
 BuildRequires: ncurses-devel
 BuildRequires: openssl-devel >= 0.9.7
-Buildrequires: openssl-tools
+BuildRequires: openssl-tools
 BuildRequires: perl-base
 %if %{with odbc}
 BuildRequires: unixODBC-devel
@@ -43,16 +45,16 @@ BuildConflicts:     unixODBC-devel
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define _erl_target %(echo %{_build} | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
+%define _erl_target %(echo %{_build}-gnu | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
 
 %description
 Erlang is a programming language designed at the Ericsson Computer
 Science Laboratory. Open-source Erlang is being released to help
 encourage the spread of Erlang outside Ericsson.
 
-%description -l pl
-Erlang to jêzyk programowania opracowany w Ericsson Computer Science
-Laboratory. Open-source Erlang zosta³ wydany, aby pomóc w
+%description -l pl.UTF-8
+Erlang to język programowania opracowany w Ericsson Computer Science
+Laboratory. Open-source Erlang został wydany, aby pomóc w
 rozpowszechnianiu Erlanga poza Ericssonem.
 
 %prep
@@ -60,54 +62,36 @@ rozpowszechnianiu Erlanga poza Ericssonem.
 %{__tar} xzf %{SOURCE1} man/ COPYRIGHT
 #%patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
 find . -name config.sub | xargs -n 1 cp -f /usr/share/automake/config.sub
-%{__autoconf}
-cd lib
-%{__autoconf}
-cd erl_interface
-%{__autoconf}
-cd ../gs
-%{__autoconf}
-cd ../megaco
-%{__autoconf}
-cd ../odbc
-%{__autoconf}
-cd ../snmp
-%{__autoconf}
-cd ../../erts/
-%{__autoconf}
-cd ..
+curd=$(pwd)
+for i in $(find . -type f -name configure.in); do
+       cd $(dirname $i)
+       %{__autoconf}
+       cd $curd
+done
 %configure \
-       --with%{!?with_java:out}-java
+%ifarch sparc
+       CFLAGS="%{rpmcflags} -mv8plus" \
+%endif
+       --with-javac%{!?with_java:=no}
+rm -f lib/ssl/SKIP
 ERL_TOP=`pwd`; export ERL_TOP
- %{__make} \
+ %{__make} -j1 \
        TARGET="%{_erl_target}" \
        || { find . -name erl_crash.dump | xargs cat ; exit 1 ; }
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
+%{__make} -j1 install \
        TARGET="%{_erl_target}" \
        INSTALL_PREFIX=$RPM_BUILD_ROOT
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/*.html
-
 sed -i -e"s#$RPM_BUILD_ROOT##" \
        $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/{erl,start,start_erl}
 
-for l in erl erlc dialyzer epmd run_erl to_erl ; do
-       ln -sf %{_libdir}/%{name}/bin/$l $RPM_BUILD_ROOT%{_bindir}
-done
-ERTSDIR=`echo $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-* | sed -e"s#^$RPM_BUILD_ROOT##"`
-for l in ear ecc elink escript ; do
-       ln -sf $ERTSDIR/bin/$l $RPM_BUILD_ROOT%{_bindir}
-done
-ln -sf $ERTSDIR/bin/epmd $RPM_BUILD_ROOT%{_libdir}/%{name}/bin
-
 cp -r man $RPM_BUILD_ROOT%{_libdir}/%{name}
 find $RPM_BUILD_ROOT%{_libdir}/%{name}/man -type f | xargs gzip -9
 
@@ -120,26 +104,39 @@ find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f -perm -500 \
 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f '!' -perm -500 \
        | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%{_libdir}/%%{name}/#" >> lib.list
 
-rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/lib
-rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/include/internal
+%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/lib
+%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/include/internal
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files -f lib.list
 %defattr(644,root,root,755)
-%doc AUTHORS EPLICENCE README COPYRIGHT
-%attr(755,root,root) %{_bindir}/*
+%doc AUTHORS EPLICENCE COPYRIGHT
+%attr(755,root,root) %{_bindir}/ct_run
+%attr(755,root,root) %{_bindir}/dialyzer
+%attr(755,root,root) %{_bindir}/epmd
+%attr(755,root,root) %{_bindir}/erl
+%attr(755,root,root) %{_bindir}/erlc
+%attr(755,root,root) %{_bindir}/escript
+%attr(755,root,root) %{_bindir}/run_erl
+%attr(755,root,root) %{_bindir}/run_test
+%attr(755,root,root) %{_bindir}/to_erl
+%attr(755,root,root) %{_bindir}/typer
 %dir %{_libdir}/erlang
 %dir %{_libdir}/%{name}/bin
+%attr(755,root,root) %{_libdir}/%{name}/bin/ct_run
 %attr(755,root,root) %{_libdir}/%{name}/bin/dialyzer
 %attr(755,root,root) %{_libdir}/%{name}/bin/epmd
 %attr(755,root,root) %{_libdir}/%{name}/bin/erl
 %attr(755,root,root) %{_libdir}/%{name}/bin/erlc
+%attr(755,root,root) %{_libdir}/%{name}/bin/escript
 %attr(755,root,root) %{_libdir}/%{name}/bin/run_erl
+%attr(755,root,root) %{_libdir}/%{name}/bin/run_test
 %attr(755,root,root) %{_libdir}/%{name}/bin/start
 %attr(755,root,root) %{_libdir}/%{name}/bin/start_erl
 %attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
+%attr(755,root,root) %{_libdir}/%{name}/bin/typer
 %{_libdir}/%{name}/bin/start*.*
 %dir %{_libdir}/%{name}/erts-*
 %{_libdir}/%{name}/erts-*/doc
@@ -150,13 +147,16 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/%{name}/erts-*/bin
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/child*
+%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/ct_run
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dialyzer
+%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dyn_erl
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/e*
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/heart*
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/inet_gethost
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/run_erl
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/start
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/to_erl
+%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/typer
 %{_libdir}/%{name}/erts-*/bin/start*.*
 # (file list dynamically generated) %{_libdir}/%{name}/lib
 %dir %{_libdir}/%{name}/misc
This page took 0.050603 seconds and 4 git commands to generate.