]> git.pld-linux.org Git - packages/erlang.git/blobdiff - erlang.spec
- up to R10B-5
[packages/erlang.git] / erlang.spec
index 66d58c2e004e90e1ee862311c5760f5ea3192422..853103701c0345bfc89d2970bf531f685d76adb6 100644 (file)
@@ -1,28 +1,35 @@
+#
+# Conditional build:
+%bcond_with    java            # with Java support
+# 
 Summary:       OpenSource Erlang/OTP
 Summary(pl):   Erlang/OTP z otwartymi ¼ród³ami
 Name:          erlang
-Version:       R9C_2
-Release:       2
+Version:       R10B_5
+Release:       0.1
 Epoch:         1
 License:       distributable
 Group:         Development/Languages
 %define                _version        %(echo %{version} | tr _ -)
 Source0:       http://www.erlang.org/download/otp_src_%{_version}.tar.gz
-# Source0-md5: 3cdb1c58671995d6b334e0f8da414816
-Source1:       http://www.erlang.org/download/otp_man_R9C-0.tar.gz
-# Source1-md5: f94bbaba800cc73e67704b92df5aab60
+# Source0-md5: fa6c4ba8291e1d11ae412e4d6f0fa392
+Source1:       http://www.erlang.org/download/otp_doc_man_R10B-5.tar.gz
+# Source1-md5: a64d7797ce0f98363f8bd59608a35a58
 Patch0:                %{name}-fPIC.patch
 Patch1:                %{name}-ssl_timeout.patch
+Patch2:                %{name}-optional_java.patch
 URL:           http://www.erlang.org/
 BuildRequires: XFree86-devel
 BuildRequires: autoconf
 BuildRequires: automake
+%{?with_java:BuildRequires:    jdk >= 1.2}
+%{?with_java:BuildRequires:    /usr/bin/jar}
 BuildRequires: flex
 BuildRequires: ncurses-devel
 BuildRequires: perl-base
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
        
-%define _erl_target %(echo %{_build} | sed -e's/amd64/x86_64/;s/athlon/i686/;s/powerpc/ppc/')
+%define _erl_target %(echo %{_build} | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
 
 %description
 Erlang is a programming language designed at the Ericsson Computer
@@ -37,8 +44,9 @@ rozpowszechnianiu Erlanga poza Ericssonem.
 %prep
 %setup -q -n otp_src_%{_version}
 %{__tar} xzf %{SOURCE1} man/ COPYRIGHT
-%patch0 -p1
-%patch1 -p1
+#%patch0 -p1
+#%patch1 -p1
+%patch2 -p1
 
 %build
 find . -name config.sub | xargs -n 1 cp -f /usr/share/automake/config.sub
@@ -51,12 +59,15 @@ cd ../gs
 %{__autoconf}
 cd ../megaco
 %{__autoconf}
+cd ../odbc
+%{__autoconf}
 cd ../snmp
 %{__autoconf}
 cd ../../erts/
 %{__autoconf}
 cd ..
-%configure
+%configure \
+       --with%{!?with_java:out}-java
 ERL_TOP=`pwd`; export ERL_TOP
 %{__make} \
        TARGET="%{_erl_target}"
@@ -94,12 +105,15 @@ find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f -perm -500 \
 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f '!' -perm -500 \
        | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%{_libdir}/%%{name}/#" >> lib.list
 
+rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/lib/internal
+rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/include/internal
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files -f lib.list
 %defattr(644,root,root,755)
-%doc AUTHORS EPLICENCE README erts/notes.html COPYRIGHT
+%doc AUTHORS EPLICENCE README COPYRIGHT
 %attr(755,root,root) %{_bindir}/*
 %dir %{_libdir}/erlang
 %dir %{_libdir}/%{name}/bin
@@ -115,7 +129,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/erts-*/doc
 %{_libdir}/%{name}/erts-*/man
 %{_libdir}/%{name}/erts-*/src
-%{_libdir}/%{name}/erts-*/*.ear
+%{_libdir}/%{name}/erts-*/include
+#%{_libdir}/%{name}/erts-*/*.ear
 %dir %{_libdir}/%{name}/erts-*/bin
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/child*
This page took 0.171337 seconds and 4 git commands to generate.