]> git.pld-linux.org Git - packages/erlang.git/blobdiff - erlang.spec
- release 3
[packages/erlang.git] / erlang.spec
index 63cf742157808d45683752d5472c818844a32592..4be3f1c2f3784cdb6a396dfdfb2d2c537ae33ad6 100644 (file)
 Summary:       OpenSource Erlang/OTP
 Summary(pl.UTF-8):     Erlang/OTP z otwartymi źródłami
 Name:          erlang
-# keep stable line, currently R12
-Version:       R12B_5
-Release:       1
+# A - unstable, B - stable line, keep stable
+Version:       R14B03
+Release:       3
 Epoch:         1
 %define                _version        %(echo %{version} | tr _ -)
 License:       distributable
 Group:         Development/Languages
 Source0:       http://www.erlang.org/download/otp_src_%{_version}.tar.gz
-# Source0-md5: 3751ea3fea669d2b25c67eeb883734bb
+# Source0-md5: 7979e662d11476b97c462feb7c132fb7
 Source1:       http://www.erlang.org/download/otp_doc_man_%{_version}.tar.gz
-# Source1-md5: 6231cb172847040395cc34b20781aa3b
+# Source1-md5: 357f54b174bb29d41fee97c063a47e8f
 Patch0:                %{name}-fPIC.patch
-Patch1:                %{name}-optional_java.patch
-Patch2:                %{name}-tinfo.patch
+Patch1:                %{name}-tinfo.patch
+Patch2:                %{name}-link.patch
 URL:           http://www.erlang.org/
 %{?with_java:BuildRequires:    /usr/bin/jar}
 BuildRequires: xorg-lib-libX11-devel
@@ -46,7 +46,7 @@ BuildConflicts:       unixODBC-devel
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define _erl_target %(echo %{_build} | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
+%define _erl_target %(echo %{_build}-gnu | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
 
 %description
 Erlang is a programming language designed at the Ericsson Computer
@@ -67,27 +67,17 @@ rozpowszechnianiu Erlanga poza Ericssonem.
 
 %build
 find . -name config.sub | xargs -n 1 cp -f /usr/share/automake/config.sub
-%{__autoconf}
-cd lib
-%{__autoconf}
-cd erl_interface
-%{__autoconf}
-cd ../gs
-%{__autoconf}
-cd ../megaco
-%{__autoconf}
-cd ../odbc
-%{__autoconf}
-cd ../snmp
-%{__autoconf}
-cd ../../erts/
-%{__autoconf}
-cd ..
+curd=$(pwd)
+for i in $(find . -type f -name configure.in); do
+       cd $(dirname $i)
+       %{__autoconf}
+       cd $curd
+done
 %configure \
 %ifarch sparc
        CFLAGS="%{rpmcflags} -mv8plus" \
 %endif
-       --with%{!?with_java:out}-java
+       --with%{!?with_java:out}-javac
 rm -f lib/ssl/SKIP
 ERL_TOP=`pwd`; export ERL_TOP
  %{__make} -j1 \
@@ -135,16 +125,18 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f lib.list
 %defattr(644,root,root,755)
-%doc AUTHORS EPLICENCE README COPYRIGHT
+%doc AUTHORS EPLICENCE COPYRIGHT
 %attr(755,root,root) %{_bindir}/*
 %dir %{_libdir}/erlang
 %dir %{_libdir}/%{name}/bin
+%attr(755,root,root) %{_libdir}/%{name}/bin/ct_run
 %attr(755,root,root) %{_libdir}/%{name}/bin/dialyzer
 %attr(755,root,root) %{_libdir}/%{name}/bin/epmd
 %attr(755,root,root) %{_libdir}/%{name}/bin/erl
 %attr(755,root,root) %{_libdir}/%{name}/bin/erlc
 %attr(755,root,root) %{_libdir}/%{name}/bin/escript
 %attr(755,root,root) %{_libdir}/%{name}/bin/run_erl
+%attr(755,root,root) %{_libdir}/%{name}/bin/run_test
 %attr(755,root,root) %{_libdir}/%{name}/bin/start
 %attr(755,root,root) %{_libdir}/%{name}/bin/start_erl
 %attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
@@ -159,7 +151,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/%{name}/erts-*/bin
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/child*
+%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/ct_run
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dialyzer
+%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dyn_erl
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/e*
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/heart*
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/inet_gethost
This page took 0.037878 seconds and 4 git commands to generate.