]> git.pld-linux.org Git - packages/erlang.git/blobdiff - erlang.spec
- version R10_B10
[packages/erlang.git] / erlang.spec
index 8d31b08bb52bdecc865baceca3f2d44f039902ad..3f4affc8fdd71a380e39fffa77ed9fbbbee60179 100644 (file)
@@ -1,34 +1,45 @@
+# NOTE: Building requires working DNS setup. Build may hang
+#       even if _only_ first dns specified in resolv.conf
+#       is unreachable.
 #
 # Conditional build:
 %bcond_with    java            # with Java support
-# 
+%bcond_without odbc            # without unixODBC support
+#
 Summary:       OpenSource Erlang/OTP
 Summary(pl):   Erlang/OTP z otwartymi ¼ród³ami
 Name:          erlang
-Version:       R10B_2
-Release:       0.1
+Version:       R10B_10
+Release:       1
 Epoch:         1
+%define                _version        %(echo %{version} | tr _ -)
 License:       distributable
 Group:         Development/Languages
-%define                _version        %(echo %{version} | tr _ -)
 Source0:       http://www.erlang.org/download/otp_src_%{_version}.tar.gz
-# Source0-md5: 318f5e61872035290c5939c47631cd83
-Source1:       http://www.erlang.org/download/otp_doc_man_R10B-2.tar.gz
-# Source1-md5: c073820c7e97988aa9483618fe67aaf0
+# Source0-md5: c1405c885f07d661b7362b822d571586
+Source1:       http://www.erlang.org/download/otp_doc_man_R10B-10.tar.gz
+# Source1-md5: 207e00bcaf5a9428bd86e3973f9b699f
 Patch0:                %{name}-fPIC.patch
-Patch1:                %{name}-ssl_timeout.patch
-Patch2:                %{name}-optional_java.patch
+Patch1:                %{name}-optional_java.patch
+Patch2:                %{name}-hipe_optimistic_regalloc_once_only.patch
 URL:           http://www.erlang.org/
+%{?with_java:BuildRequires:    /usr/bin/jar}
 BuildRequires: XFree86-devel
 BuildRequires: autoconf
 BuildRequires: automake
-%{?with_java:BuildRequires:    jdk >= 1.2}
-%{?with_java:BuildRequires:    /usr/bin/jar}
 BuildRequires: flex
+%{?with_java:BuildRequires:    jdk >= 1.2}
 BuildRequires: ncurses-devel
+BuildRequires: openssl-devel >= 0.9.7
+Buildrequires: openssl-tools
 BuildRequires: perl-base
+%if %{with odbc}
+BuildRequires: unixODBC-devel
+%else
+BuildConflicts:        unixODBC-devel
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-       
+
 %define _erl_target %(echo %{_build} | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
 
 %description
@@ -45,7 +56,7 @@ rozpowszechnianiu Erlanga poza Ericssonem.
 %setup -q -n otp_src_%{_version}
 %{__tar} xzf %{SOURCE1} man/ COPYRIGHT
 #%patch0 -p1
-#%patch1 -p1
+%patch1 -p1
 %patch2 -p1
 
 %build
@@ -59,6 +70,8 @@ cd ../gs
 %{__autoconf}
 cd ../megaco
 %{__autoconf}
+cd ../odbc
+%{__autoconf}
 cd ../snmp
 %{__autoconf}
 cd ../../erts/
@@ -67,8 +80,9 @@ cd ..
 %configure \
        --with%{!?with_java:out}-java
 ERL_TOP=`pwd`; export ERL_TOP
-%{__make} \
-       TARGET="%{_erl_target}"
+LD_ASSUME_KERNEL=2.4.19 %{__make} \
+       TARGET="%{_erl_target}" \
+       || { find . -name erl_crash.dump | xargs cat ; exit 1 ; }
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.125025 seconds and 4 git commands to generate.