]> git.pld-linux.org Git - packages/erlang.git/blobdiff - erlang.spec
- rel 1, builds
[packages/erlang.git] / erlang.spec
index 15d238567ae55707d5ad718d8b5ace97c446a51d..22a748db8ef2b73c00645561ec654c5cdc742dd7 100644 (file)
 %bcond_without odbc            # without unixODBC support
 #
 Summary:       OpenSource Erlang/OTP
-Summary(pl):   Erlang/OTP z otwartymi ¼ród³ami
+Summary(pl.UTF-8):     Erlang/OTP z otwartymi źródłami
 Name:          erlang
-Version:       R11B_2
-Release:       1
+Version:       R12B_2
+iRelease:      1
 Epoch:         1
 %define                _version        %(echo %{version} | tr _ -)
 License:       distributable
 Group:         Development/Languages
 Source0:       http://www.erlang.org/download/otp_src_%{_version}.tar.gz
-# Source0-md5: 7d7cca1d2f392a8a317cb4c0bd904726
-Source1:       http://www.erlang.org/download/otp_doc_man_R11B-2.tar.gz
-# Source1-md5: c81023f591c1bace836de3aa874f3c2a
+# Source0-md5: 05861c7f75d7b2ed5af42c93cebe5801
+Source1:       http://www.erlang.org/download/otp_doc_man_%{_version}.tar.gz
+# Source1-md5: 645a4486f02338a5cf22be7563b862f9
 Patch0:                %{name}-fPIC.patch
 Patch1:                %{name}-optional_java.patch
-Patch2:                %{name}-hipe_optimistic_regalloc_once_only.patch
-Patch3:                %{name}-tinfo.patch
+Patch2:                %{name}-tinfo.patch
+Patch3:                %{name}-new_glibc.patch
 URL:           http://www.erlang.org/
 %{?with_java:BuildRequires:    /usr/bin/jar}
 BuildRequires: xorg-lib-libX11-devel
@@ -53,9 +53,9 @@ Erlang is a programming language designed at the Ericsson Computer
 Science Laboratory. Open-source Erlang is being released to help
 encourage the spread of Erlang outside Ericsson.
 
-%description -l pl
-Erlang to jêzyk programowania opracowany w Ericsson Computer Science
-Laboratory. Open-source Erlang zosta³ wydany, aby pomóc w
+%description -l pl.UTF-8
+Erlang to język programowania opracowany w Ericsson Computer Science
+Laboratory. Open-source Erlang został wydany, aby pomóc w
 rozpowszechnianiu Erlanga poza Ericssonem.
 
 %prep
@@ -85,16 +85,20 @@ cd ../../erts/
 %{__autoconf}
 cd ..
 %configure \
+%ifarch sparc
+       CFLAGS="%{rpmcflags} -mv8plus" \
+%endif
        --with%{!?with_java:out}-java
+rm -f lib/ssl/SKIP
 ERL_TOP=`pwd`; export ERL_TOP
- %{__make} \
+ %{__make} -j1 \
        TARGET="%{_erl_target}" \
        || { find . -name erl_crash.dump | xargs cat ; exit 1 ; }
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
+%{__make} -j1 install \
        TARGET="%{_erl_target}" \
        INSTALL_PREFIX=$RPM_BUILD_ROOT
 
@@ -103,11 +107,11 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/*.html
 sed -i -e"s#$RPM_BUILD_ROOT##" \
        $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/{erl,start,start_erl}
 
-for l in erl erlc dialyzer epmd run_erl to_erl ; do
+for l in erl erlc escript dialyzer epmd run_erl to_erl typer; do
        ln -sf %{_libdir}/%{name}/bin/$l $RPM_BUILD_ROOT%{_bindir}
 done
 ERTSDIR=`echo $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-* | sed -e"s#^$RPM_BUILD_ROOT##"`
-for l in ear ecc elink escript ; do
+for l in epmd ; do
        ln -sf $ERTSDIR/bin/$l $RPM_BUILD_ROOT%{_bindir}
 done
 ln -sf $ERTSDIR/bin/epmd $RPM_BUILD_ROOT%{_libdir}/%{name}/bin
@@ -140,10 +144,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/bin/epmd
 %attr(755,root,root) %{_libdir}/%{name}/bin/erl
 %attr(755,root,root) %{_libdir}/%{name}/bin/erlc
+%attr(755,root,root) %{_libdir}/%{name}/bin/escript
 %attr(755,root,root) %{_libdir}/%{name}/bin/run_erl
 %attr(755,root,root) %{_libdir}/%{name}/bin/start
 %attr(755,root,root) %{_libdir}/%{name}/bin/start_erl
 %attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
+%attr(755,root,root) %{_libdir}/%{name}/bin/typer
 %{_libdir}/%{name}/bin/start*.*
 %dir %{_libdir}/%{name}/erts-*
 %{_libdir}/%{name}/erts-*/doc
@@ -161,6 +167,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/run_erl
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/start
 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/to_erl
+%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/typer
 %{_libdir}/%{name}/erts-*/bin/start*.*
 # (file list dynamically generated) %{_libdir}/%{name}/lib
 %dir %{_libdir}/%{name}/misc
This page took 0.32233 seconds and 4 git commands to generate.