]> git.pld-linux.org Git - packages/erlang.git/blob - erlang.spec
- missing dirs
[packages/erlang.git] / erlang.spec
1 Summary:        OpenSource Erlang/OTP
2 Summary(pl):    Erlang/OTP z otwartymi ¼ród³ami
3 Name:           otp
4 Version:        R9C_2
5 Release:        0.1
6 Epoch:          1
7 License:        distributable
8 Group:          Development/Languages
9 %define         _version        %(echo %{version} | tr _ -)
10 Source0:        http://www.erlang.org/download/%{name}_src_%{_version}.tar.gz
11 URL:            http://www.erlang.org/
12 BuildRequires:  XFree86-devel
13 BuildRequires:  autoconf
14 BuildRequires:  flex
15 BuildRequires:  perl-base
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Erlang is a programming language designed at the Ericsson Computer
20 Science Laboratory. Open-source Erlang is being released to help
21 encourage the spread of Erlang outside Ericsson.
22
23 %description -l pl
24 Erlang to jêzyk programowania opracowany w Ericsson Computer Science
25 Laboratory. Open-source Erlang zosta³ wydany, aby pomóc w
26 rozpowszechnianiu Erlanga poza Ericssonem.
27
28 %prep
29 %setup -q -n %{name}_src_%{_version}
30
31 %build
32 %{__autoconf}
33 cd lib
34 %{__autoconf}
35 cd erl_interface
36 %{__autoconf}
37 cd ../gs
38 %{__autoconf}
39 cd ../megaco
40 %{__autoconf}
41 cd ../snmp
42 %{__autoconf}
43 cd ../../erts/
44 %{__autoconf}
45 cd ..
46 %configure
47 ERL_TOP=`pwd`; export ERL_TOP
48 %{__make} \
49         TARGET="%{_build}"
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         TARGET="%{_build}" \
56         INSTALL_PREFIX=$RPM_BUILD_ROOT
57
58 rm -f $RPM_BUILD_ROOT%{_libdir}/erlang/erts-*/*.html
59
60 sed -i -e"s#$RPM_BUILD_ROOT##" \
61         $RPM_BUILD_ROOT%{_libdir}/erlang/bin/{erl,start,start_erl}
62
63 for l in erl erlc ; do
64         ln -sf %{_libdir}/erlang/bin/$l $RPM_BUILD_ROOT%{_bindir}
65 done
66 ERTSDIR=`echo $RPM_BUILD_ROOT%{_libdir}/erlang/erts-* | sed -e"s#^$RPM_BUILD_ROOT##"`
67 for l in ear ecc elink escript ; do
68         ln -sf $ERTSDIR/bin/$l $RPM_BUILD_ROOT%{_bindir}
69 done
70 ln -sf $ERTSDIR/bin/epmd $RPM_BUILD_ROOT%{_libdir}/erlang/bin
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc AUTHORS EPLICENCE README erts/notes.html
78 %attr(755,root,root) %{_bindir}/*
79 %dir %{_libdir}/erlang
80 %dir %{_libdir}/erlang/bin
81 %attr(755,root,root) %{_libdir}/erlang/bin/epmd
82 %attr(755,root,root) %{_libdir}/erlang/bin/erl
83 %attr(755,root,root) %{_libdir}/erlang/bin/erlc
84 %attr(755,root,root) %{_libdir}/erlang/bin/run_erl
85 %attr(755,root,root) %{_libdir}/erlang/bin/start
86 %attr(755,root,root) %{_libdir}/erlang/bin/start_erl
87 %attr(755,root,root) %{_libdir}/erlang/bin/to_erl
88 %{_libdir}/erlang/bin/start*.*
89 %dir %{_libdir}/erlang/erts-*
90 %{_libdir}/erlang/erts-*/doc
91 %{_libdir}/erlang/erts-*/man
92 %{_libdir}/erlang/erts-*/src
93 %{_libdir}/erlang/erts-*/*.ear
94 %dir %{_libdir}/erlang/erts-*/bin
95 %attr(755,root,root) %{_libdir}/erlang/erts-*/bin/beam*
96 %attr(755,root,root) %{_libdir}/erlang/erts-*/bin/child*
97 %attr(755,root,root) %{_libdir}/erlang/erts-*/bin/e*
98 %attr(755,root,root) %{_libdir}/erlang/erts-*/bin/heart*
99 %attr(755,root,root) %{_libdir}/erlang/erts-*/bin/inet_gethost
100 %attr(755,root,root) %{_libdir}/erlang/erts-*/bin/run_erl
101 %attr(755,root,root) %{_libdir}/erlang/erts-*/bin/start
102 %attr(755,root,root) %{_libdir}/erlang/erts-*/bin/to_erl
103 %{_libdir}/erlang/erts-*/bin/start*.*
104 %{_libdir}/erlang/lib
105 %dir %{_libdir}/erlang/misc
106 %attr(755,root,root) %{_libdir}/erlang/misc/*
107 %{_libdir}/erlang/releases
108 %{_libdir}/erlang/usr
109 %attr(755,root,root) %{_libdir}/erlang/Install
This page took 0.06409 seconds and 4 git commands to generate.