]> git.pld-linux.org Git - packages/erlang.git/blob - erlang.spec
- up to R12B_1
[packages/erlang.git] / erlang.spec
1 # NOTE: Building requires working DNS setup. Build may hang
2 #       even if _only_ first dns specified in resolv.conf
3 #       is unreachable.
4 # TODO
5 # - separate -devel (at least header files!)
6 # - modularize (odbc, etc)
7 # - manuals to %{_mandir}
8 # - investigate fPIC.patch
9 #
10 # Conditional build:
11 %bcond_with     java            # with Java support
12 %bcond_without  odbc            # without unixODBC support
13 #
14 Summary:        OpenSource Erlang/OTP
15 Summary(pl.UTF-8):      Erlang/OTP z otwartymi źródłami
16 Name:           erlang
17 Version:        R12B_1
18 Release:        1
19 Epoch:          1
20 %define         _version        %(echo %{version} | tr _ -)
21 License:        distributable
22 Group:          Development/Languages
23 Source0:        http://www.erlang.org/download/otp_src_%{_version}.tar.gz
24 # Source0-md5:  6de3630b446e9c2150edfe01e383c917
25 Source1:        http://www.erlang.org/download/otp_doc_man_R12B-1.tar.gz
26 # Source1-md5:  96da62bcfb40e5d3ec2945bb2b050024
27 Patch0:         %{name}-fPIC.patch
28 Patch1:         %{name}-optional_java.patch
29 Patch2:         %{name}-tinfo.patch
30 URL:            http://www.erlang.org/
31 %{?with_java:BuildRequires:     /usr/bin/jar}
32 BuildRequires:  xorg-lib-libX11-devel
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  flex
36 %{?with_java:BuildRequires:     jdk >= 1.2}
37 BuildRequires:  ncurses-devel
38 BuildRequires:  openssl-devel >= 0.9.7
39 Buildrequires:  openssl-tools
40 BuildRequires:  perl-base
41 %if %{with odbc}
42 BuildRequires:  unixODBC-devel
43 %else
44 BuildConflicts: unixODBC-devel
45 %endif
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define _erl_target %(echo %{_build} | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
49
50 %description
51 Erlang is a programming language designed at the Ericsson Computer
52 Science Laboratory. Open-source Erlang is being released to help
53 encourage the spread of Erlang outside Ericsson.
54
55 %description -l pl.UTF-8
56 Erlang to język programowania opracowany w Ericsson Computer Science
57 Laboratory. Open-source Erlang został wydany, aby pomóc w
58 rozpowszechnianiu Erlanga poza Ericssonem.
59
60 %prep
61 %setup -q -n otp_src_%{_version}
62 %{__tar} xzf %{SOURCE1} man/ COPYRIGHT
63 #%patch0 -p1
64 %patch1 -p1
65 %patch2 -p1
66
67 %build
68 find . -name config.sub | xargs -n 1 cp -f /usr/share/automake/config.sub
69 %{__autoconf}
70 cd lib
71 %{__autoconf}
72 cd erl_interface
73 %{__autoconf}
74 cd ../gs
75 %{__autoconf}
76 cd ../megaco
77 %{__autoconf}
78 cd ../odbc
79 %{__autoconf}
80 cd ../snmp
81 %{__autoconf}
82 cd ../../erts/
83 %{__autoconf}
84 cd ..
85 %configure \
86         --with%{!?with_java:out}-java
87 ERL_TOP=`pwd`; export ERL_TOP
88  %{__make} -j1 \
89         TARGET="%{_erl_target}" \
90         || { find . -name erl_crash.dump | xargs cat ; exit 1 ; }
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         TARGET="%{_erl_target}" \
97         INSTALL_PREFIX=$RPM_BUILD_ROOT
98
99 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/*.html
100
101 sed -i -e"s#$RPM_BUILD_ROOT##" \
102         $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/{erl,start,start_erl}
103
104 for l in erl erlc escript dialyzer epmd run_erl to_erl typer; do
105         ln -sf %{_libdir}/%{name}/bin/$l $RPM_BUILD_ROOT%{_bindir}
106 done
107 ERTSDIR=`echo $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-* | sed -e"s#^$RPM_BUILD_ROOT##"`
108 for l in epmd ; do
109         ln -sf $ERTSDIR/bin/$l $RPM_BUILD_ROOT%{_bindir}
110 done
111 ln -sf $ERTSDIR/bin/epmd $RPM_BUILD_ROOT%{_libdir}/%{name}/bin
112
113 cp -r man $RPM_BUILD_ROOT%{_libdir}/%{name}
114 find $RPM_BUILD_ROOT%{_libdir}/%{name}/man -type f | xargs gzip -9
115
116 # some files in the library need +x, so we build the list here
117 echo "%%defattr(644,root,root,755)" > lib.list
118 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type d \
119         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%dir %%{_libdir}/%%{name}/#" >> lib.list
120 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f -perm -500 \
121         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%attr(755,root,root) %%{_libdir}/%%{name}/#" >> lib.list
122 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f '!' -perm -500 \
123         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%{_libdir}/%%{name}/#" >> lib.list
124
125 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/lib
126 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/include/internal
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files -f lib.list
132 %defattr(644,root,root,755)
133 %doc AUTHORS EPLICENCE README COPYRIGHT
134 %attr(755,root,root) %{_bindir}/*
135 %dir %{_libdir}/erlang
136 %dir %{_libdir}/%{name}/bin
137 %attr(755,root,root) %{_libdir}/%{name}/bin/dialyzer
138 %attr(755,root,root) %{_libdir}/%{name}/bin/epmd
139 %attr(755,root,root) %{_libdir}/%{name}/bin/erl
140 %attr(755,root,root) %{_libdir}/%{name}/bin/erlc
141 %attr(755,root,root) %{_libdir}/%{name}/bin/escript
142 %attr(755,root,root) %{_libdir}/%{name}/bin/run_erl
143 %attr(755,root,root) %{_libdir}/%{name}/bin/start
144 %attr(755,root,root) %{_libdir}/%{name}/bin/start_erl
145 %attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
146 %attr(755,root,root) %{_libdir}/%{name}/bin/typer
147 %{_libdir}/%{name}/bin/start*.*
148 %dir %{_libdir}/%{name}/erts-*
149 %{_libdir}/%{name}/erts-*/doc
150 %{_libdir}/%{name}/erts-*/man
151 %{_libdir}/%{name}/erts-*/src
152 %{_libdir}/%{name}/erts-*/include
153 #%{_libdir}/%{name}/erts-*/*.ear
154 %dir %{_libdir}/%{name}/erts-*/bin
155 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
156 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/child*
157 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dialyzer
158 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/e*
159 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/heart*
160 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/inet_gethost
161 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/run_erl
162 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/start
163 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/to_erl
164 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/typer
165 %{_libdir}/%{name}/erts-*/bin/start*.*
166 # (file list dynamically generated) %{_libdir}/%{name}/lib
167 %dir %{_libdir}/%{name}/misc
168 %attr(755,root,root) %{_libdir}/%{name}/misc/*
169 %{_libdir}/%{name}/releases
170 %{_libdir}/%{name}/usr
171 %doc %{_libdir}/%{name}/man
172 %attr(755,root,root) %{_libdir}/%{name}/Install
This page took 0.069446 seconds and 4 git commands to generate.