]> git.pld-linux.org Git - packages/erlang.git/blob - erlang.spec
- AMD64 fixes
[packages/erlang.git] / erlang.spec
1 Summary:        OpenSource Erlang/OTP
2 Summary(pl):    Erlang/OTP z otwartymi ¼ród³ami
3 Name:           erlang
4 Version:        R9C_2
5 Release:        1
6 Epoch:          1
7 License:        distributable
8 Group:          Development/Languages
9 %define         _version        %(echo %{version} | tr _ -)
10 Source0:        http://www.erlang.org/download/otp_src_%{_version}.tar.gz
11 # Source0-md5:  3cdb1c58671995d6b334e0f8da414816
12 Source1:        http://www.erlang.org/download/otp_man_R9C-0.tar.gz
13 # Source1-md5:  f94bbaba800cc73e67704b92df5aab60
14 Patch0:         %{name}-fPIC.patch
15 URL:            http://www.erlang.org/
16 BuildRequires:  XFree86-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  flex
20 BuildRequires:  perl-base
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Erlang is a programming language designed at the Ericsson Computer
25 Science Laboratory. Open-source Erlang is being released to help
26 encourage the spread of Erlang outside Ericsson.
27
28 %description -l pl
29 Erlang to jêzyk programowania opracowany w Ericsson Computer Science
30 Laboratory. Open-source Erlang zosta³ wydany, aby pomóc w
31 rozpowszechnianiu Erlanga poza Ericssonem.
32
33 %prep
34 %setup -q -n otp_src_%{_version}
35 %{__tar} xzf %{SOURCE1} man/ COPYRIGHT
36 %patch0 -p1
37
38 %build
39 find . -name config.sub | xargs -n 1 cp -f /usr/share/automake/config.sub
40 %{__autoconf}
41 cd lib
42 %{__autoconf}
43 cd erl_interface
44 %{__autoconf}
45 cd ../gs
46 %{__autoconf}
47 cd ../megaco
48 %{__autoconf}
49 cd ../snmp
50 %{__autoconf}
51 cd ../../erts/
52 %{__autoconf}
53 cd ..
54 %configure
55 ERL_TOP=`pwd`; export ERL_TOP
56 %{__make} \
57         TARGET="%(echo %{_build} | sed -e's/amd64/x86_64/')"
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         TARGET="%(echo %{_build} | sed -e's/amd64/x86_64/')" \
64         INSTALL_PREFIX=$RPM_BUILD_ROOT
65
66 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/*.html
67
68 sed -i -e"s#$RPM_BUILD_ROOT##" \
69         $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/{erl,start,start_erl}
70
71 for l in erl erlc ; do
72         ln -sf %{_libdir}/%{name}/bin/$l $RPM_BUILD_ROOT%{_bindir}
73 done
74 ERTSDIR=`echo $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-* | sed -e"s#^$RPM_BUILD_ROOT##"`
75 for l in ear ecc elink escript ; do
76         ln -sf $ERTSDIR/bin/$l $RPM_BUILD_ROOT%{_bindir}
77 done
78 ln -sf $ERTSDIR/bin/epmd $RPM_BUILD_ROOT%{_libdir}/%{name}/bin
79
80 cp -r man $RPM_BUILD_ROOT%{_libdir}/%{name}
81 find $RPM_BUILD_ROOT%{_libdir}/%{name}/man -type f | xargs gzip -9
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS EPLICENCE README erts/notes.html COPYRIGHT
89 %attr(755,root,root) %{_bindir}/*
90 %dir %{_libdir}/erlang
91 %dir %{_libdir}/%{name}/bin
92 %attr(755,root,root) %{_libdir}/%{name}/bin/epmd
93 %attr(755,root,root) %{_libdir}/%{name}/bin/erl
94 %attr(755,root,root) %{_libdir}/%{name}/bin/erlc
95 %attr(755,root,root) %{_libdir}/%{name}/bin/run_erl
96 %attr(755,root,root) %{_libdir}/%{name}/bin/start
97 %attr(755,root,root) %{_libdir}/%{name}/bin/start_erl
98 %attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
99 %{_libdir}/%{name}/bin/start*.*
100 %dir %{_libdir}/%{name}/erts-*
101 %{_libdir}/%{name}/erts-*/doc
102 %{_libdir}/%{name}/erts-*/man
103 %{_libdir}/%{name}/erts-*/src
104 %{_libdir}/%{name}/erts-*/*.ear
105 %dir %{_libdir}/%{name}/erts-*/bin
106 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
107 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/child*
108 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/e*
109 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/heart*
110 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/inet_gethost
111 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/run_erl
112 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/start
113 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/to_erl
114 %{_libdir}/%{name}/erts-*/bin/start*.*
115 %{_libdir}/%{name}/lib
116 %dir %{_libdir}/%{name}/misc
117 %attr(755,root,root) %{_libdir}/%{name}/misc/*
118 %{_libdir}/%{name}/releases
119 %{_libdir}/%{name}/usr
120 %doc %{_libdir}/%{name}/man
121 %attr(755,root,root) %{_libdir}/%{name}/Install
This page took 0.078699 seconds and 4 git commands to generate.