]> git.pld-linux.org Git - packages/erlang.git/blob - erlang.spec
- up to R11B_5
[packages/erlang.git] / erlang.spec
1 # NOTE: Building requires working DNS setup. Build may hang
2 #       even if _only_ first dns specified in resolv.conf
3 #       is unreachable.
4 # TODO
5 # - separate -devel (at least header files!)
6 # - modularize (odbc, etc)
7 # - manuals to %{_mandir}
8 # - investigate fPIC.patch
9 #
10 # Conditional build:
11 %bcond_with     java            # with Java support
12 %bcond_without  odbc            # without unixODBC support
13 #
14 Summary:        OpenSource Erlang/OTP
15 Summary(pl.UTF-8):      Erlang/OTP z otwartymi źródłami
16 Name:           erlang
17 Version:        R11B_5
18 Release:        1
19 Epoch:          1
20 %define         _version        %(echo %{version} | tr _ -)
21 License:        distributable
22 Group:          Development/Languages
23 Source0:        http://www.erlang.org/download/otp_src_%{_version}.tar.gz
24 # Source0-md5:  96acec41da87d6ee0ef18e1aab36ffdd
25 Source1:        http://www.erlang.org/download/otp_doc_man_R11B-3.tar.gz
26 # Source1-md5:  645ef1ded84b470e9c05a4757dce88cf
27 Patch0:         %{name}-fPIC.patch
28 Patch1:         %{name}-optional_java.patch
29 Patch2:         %{name}-hipe_optimistic_regalloc_once_only.patch
30 Patch3:         %{name}-tinfo.patch
31 URL:            http://www.erlang.org/
32 %{?with_java:BuildRequires:     /usr/bin/jar}
33 BuildRequires:  xorg-lib-libX11-devel
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  flex
37 %{?with_java:BuildRequires:     jdk >= 1.2}
38 BuildRequires:  ncurses-devel
39 BuildRequires:  openssl-devel >= 0.9.7
40 Buildrequires:  openssl-tools
41 BuildRequires:  perl-base
42 %if %{with odbc}
43 BuildRequires:  unixODBC-devel
44 %else
45 BuildConflicts: unixODBC-devel
46 %endif
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define _erl_target %(echo %{_build} | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
50
51 %description
52 Erlang is a programming language designed at the Ericsson Computer
53 Science Laboratory. Open-source Erlang is being released to help
54 encourage the spread of Erlang outside Ericsson.
55
56 %description -l pl.UTF-8
57 Erlang to język programowania opracowany w Ericsson Computer Science
58 Laboratory. Open-source Erlang został wydany, aby pomóc w
59 rozpowszechnianiu Erlanga poza Ericssonem.
60
61 %prep
62 %setup -q -n otp_src_%{_version}
63 %{__tar} xzf %{SOURCE1} man/ COPYRIGHT
64 #%patch0 -p1
65 %patch1 -p1
66 %patch2 -p1
67 %patch3 -p1
68
69 %build
70 find . -name config.sub | xargs -n 1 cp -f /usr/share/automake/config.sub
71 %{__autoconf}
72 cd lib
73 %{__autoconf}
74 cd erl_interface
75 %{__autoconf}
76 cd ../gs
77 %{__autoconf}
78 cd ../megaco
79 %{__autoconf}
80 cd ../odbc
81 %{__autoconf}
82 cd ../snmp
83 %{__autoconf}
84 cd ../../erts/
85 %{__autoconf}
86 cd ..
87 %configure \
88         --with%{!?with_java:out}-java
89 ERL_TOP=`pwd`; export ERL_TOP
90  %{__make} -j1 \
91         TARGET="%{_erl_target}" \
92         || { find . -name erl_crash.dump | xargs cat ; exit 1 ; }
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         TARGET="%{_erl_target}" \
99         INSTALL_PREFIX=$RPM_BUILD_ROOT
100
101 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/*.html
102
103 sed -i -e"s#$RPM_BUILD_ROOT##" \
104         $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/{erl,start,start_erl}
105
106 for l in erl erlc escript dialyzer epmd run_erl to_erl typer; do
107         ln -sf %{_libdir}/%{name}/bin/$l $RPM_BUILD_ROOT%{_bindir}
108 done
109 ERTSDIR=`echo $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-* | sed -e"s#^$RPM_BUILD_ROOT##"`
110 for l in epmd ; do
111         ln -sf $ERTSDIR/bin/$l $RPM_BUILD_ROOT%{_bindir}
112 done
113 ln -sf $ERTSDIR/bin/epmd $RPM_BUILD_ROOT%{_libdir}/%{name}/bin
114
115 cp -r man $RPM_BUILD_ROOT%{_libdir}/%{name}
116 find $RPM_BUILD_ROOT%{_libdir}/%{name}/man -type f | xargs gzip -9
117
118 # some files in the library need +x, so we build the list here
119 echo "%%defattr(644,root,root,755)" > lib.list
120 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type d \
121         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%dir %%{_libdir}/%%{name}/#" >> lib.list
122 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f -perm -500 \
123         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%attr(755,root,root) %%{_libdir}/%%{name}/#" >> lib.list
124 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f '!' -perm -500 \
125         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%{_libdir}/%%{name}/#" >> lib.list
126
127 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/lib
128 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/include/internal
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files -f lib.list
134 %defattr(644,root,root,755)
135 %doc AUTHORS EPLICENCE README COPYRIGHT
136 %attr(755,root,root) %{_bindir}/*
137 %dir %{_libdir}/erlang
138 %dir %{_libdir}/%{name}/bin
139 %attr(755,root,root) %{_libdir}/%{name}/bin/dialyzer
140 %attr(755,root,root) %{_libdir}/%{name}/bin/epmd
141 %attr(755,root,root) %{_libdir}/%{name}/bin/erl
142 %attr(755,root,root) %{_libdir}/%{name}/bin/erlc
143 %attr(755,root,root) %{_libdir}/%{name}/bin/escript
144 %attr(755,root,root) %{_libdir}/%{name}/bin/run_erl
145 %attr(755,root,root) %{_libdir}/%{name}/bin/start
146 %attr(755,root,root) %{_libdir}/%{name}/bin/start_erl
147 %attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
148 %attr(755,root,root) %{_libdir}/%{name}/bin/typer
149 %{_libdir}/%{name}/bin/start*.*
150 %dir %{_libdir}/%{name}/erts-*
151 %{_libdir}/%{name}/erts-*/doc
152 %{_libdir}/%{name}/erts-*/man
153 %{_libdir}/%{name}/erts-*/src
154 %{_libdir}/%{name}/erts-*/include
155 #%{_libdir}/%{name}/erts-*/*.ear
156 %dir %{_libdir}/%{name}/erts-*/bin
157 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
158 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/child*
159 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dialyzer
160 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/e*
161 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/heart*
162 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/inet_gethost
163 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/run_erl
164 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/start
165 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/to_erl
166 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/typer
167 %{_libdir}/%{name}/erts-*/bin/start*.*
168 # (file list dynamically generated) %{_libdir}/%{name}/lib
169 %dir %{_libdir}/%{name}/misc
170 %attr(755,root,root) %{_libdir}/%{name}/misc/*
171 %{_libdir}/%{name}/releases
172 %{_libdir}/%{name}/usr
173 %doc %{_libdir}/%{name}/man
174 %attr(755,root,root) %{_libdir}/%{name}/Install
This page took 0.137452 seconds and 4 git commands to generate.